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Introducing Pixelmator

Pixelmator is the beautifully designed, easy-to-use, fast 
and powerful image editor for Mac OS X that has 
everything needed to create, edit and enhance still 
images.

Designed to be the image editor for the rest of us, Pixelmator is an 
all-in-one tool that provides:

• Interface designed for work with images

• Layers-based image editing

• Over 20 tools for selecting, cropping, slicing, painting, 
retouching, typing, measuring and navigating

• Over 15 color correction tools

• Over 130 !lters

• Adjust image size and resolution

• Transform images, layers or selections using transform tools

• Fill and Stroke images, layers or selections

• Quick access to iPhoto Library, events, albums, Smart Albums and 
Pictures folder via Photo Browser palette

• Use of your iSight camera to add pictures to your compositions

• Automator actions for converting, resizing, enhancing and 
adding special e"ects to images

• Save for web

• Compatibility with over 100 still image !le formats

• Image processing that is powered by Core Image and Open GL

• Deep Mac OS X integration via technologies such as Core Image, 
Quartz Composer, ColorSync, Quick Look, Spotlight, Apple Fonts 
palette, Apple Colors palette, drag-and-drop and many other



System Requirements

The system requirements for Pixelmator are:

• Mac OS X 10.6 Snow Leopard or later

• Some features require iLife

Additional notes about system requirements: Pixelmator is based 
on a modern foundation that takes advantage of the latest Mac OS X 
technologies. And while you can rest assured that the application will 
work without any performance glitches on the latest Intel-based Macs 
with Mac OS X 10.6 Snow Leopard, it is still good to know things that 
Pixelmator is relying on when it is used:

• OS: Pixelmator requires Mac OS X 10.6 Snow Leopard. 

• GPU: Pixelmator is based on Core Image technology that uses your 
Mac’s video card for image processing. Core Image utilizes the graphics 
card for image processing operations, freeing the CPU for other tasks. 
And if you have a high-performance card with increased video 
memory (VRAM), you’ll !nd real-time responsiveness across a wide 
variety of Pixelmator operations. Pixelmator is blistering-fast on all 
Intel-based Macs. It is noteworthy that the faster and the better your 
Mac’s GPU is, the faster you can process larger images using 
Pixelmator. With an old and slow GPU, the application will still work, 
but it might be slow - especially when working with larger images.

• CPU: Though the most important hardware for Pixelmator is the GPU, 
the application still uses your Mac’s CPU for some tasks such as 
changing image size, accepting !lters and some others.

• RAM. The third thing that Pixelmator uses is RAM. Nearly all the latest 
Macs come with more than enough RAM included, so there is no need 
to worry about whether it’ll be enough. However, just like any other 
application out there, Pixelmator will use your RAM to its advantage.

• HD. Yet another element that helps Pixelmator run smoothly is the 
available disc space. Please make sure you always have at least a few 
gigabytes of free HD space since Pixelmator uses it to store temporary 
Undo and Redo !les. Those will disappear when you quit the 
application.

iLife requirement note: The Pixelmator feature that requires iLife is 
the Photo Browser. You can use Photo Browser to quickly access your 
iPhoto Library, events, albums and Smart Albums in iPhoto. 
If you do not have iPhoto, you will still be able to access your Pictures 
folder via the Photo Browser.
Other iLife applications such as iMovie, GarageBand or iDVD are not 
required. For more information about iLife, please visit 
www.apple.com/ilife.

http://www.apple.com/ilife
http://www.apple.com/ilife


Installation

It is very easy to install Pixelmator. All you need to do is download 
the Pixelmator.zip !le from the Pixelmator Web site (or any other 
place where it might be available) and, once the application has 
automatically unzipped in your downloads folder, launch it. 

Once launched, the app will ask whether to move itself directly to 
the Applications folder or not. Click ‘Move to Applications Folder’.

Registration
The Pixelmator application that you have just installed is not yet 
registered, and once it is launched for the !rst time, you will be 
prompted to do one of three things:

• Use Pixelmator in Demo mode

• Enter License

• Buy License

While we would love to have you license Pixelmator by purchasing 
a serial number, it is not necessary to do that immediately. 
Pixelmator’s Demo mode allows you to freely use the application 
for 30 days. That’s more than enough time to try the application 
and decide whether you like it or not. To use Pixelmator in Demo 
mode, click the Use Demo button in the License window.

If you already love Pixelmator and would like to get the license for 
it, click the Buy License button. It will take you to the Pixelmator 
Store where you can easily and securely purchase a new serial 
number to unlock the application and continue using it even after 
the 30 days have passed.

It is worth knowing that by purchasing the license, you will not only 
own a lovely application but will also support the hard work of the 
Pixelmator Team.

Once you make the purchase, you will receive your Pixelmator serial 
number via e-mail. To add the serial number to Pixelmator, do one 
of the following:

• Launch Pixelmator and click Enter License button in the License 
sheet

• Launch Pixelmator, choose Pixelmator > License... and click the 
Enter License button

http://www.pixelmator.com
http://www.pixelmator.com
http://www.pixelmator.com/buy/
http://www.pixelmator.com/buy/
http://www.pixelmator.com/buy/
http://www.pixelmator.com/buy/


In both cases the License sheet will appear:

The best way to add your serial number to the license sheet is to 
simply copy it from your e-mail and paste it into the Enter Your 
License Code !eld. Please make sure you  select all the serial 
number digits when copying.

Click the License Now button, and you are done! The window 
asking to license Pixelmator will never appear again when 
launching the application.

Retrieving Lost License
If something happens to your Mac and you lose your Pixelmator 
license, there is no need to worry, at least about retrieving another 
Pixelmator license. All you need to do is send an e-mail to the 
Pixelmator Team at info@pixelmator.com asking us to send your 
serial number. Please make sure you mention your !rst and last 
names in the e-mail so that your serial number can be found in the 
Pixelmator purchasers database.

Note: Please do not share your license with anyone. It’s illegal. If you 
have two Macs, a desktop and a notebook, and would like to use 
Pixelmator on both, the Pixelmator Team has no problem with that as 
long as the app is not used for commercial purposes.

Note: Since you now know everything you need to know about 
installing and licensing Pixelmator, later in this manual’s screenshots 
and descriptions we will only use an installed and registered copy of 
Pixelmator on Mac OS X 10.6 Snow Leopard.

mailto:info@pixelmator.com
mailto:info@pixelmator.com


Resources

Though this manual is a good start to learning Pixelmator, there are 
many more resources available to you.

Built-in Help
Pixelmator comes with a built-in Help that includes an overview of 
nearly every feature in Pixelmator, instructions for completing tasks 
and keyboard shortcuts to do things faster. Pixelmator Help is 
always current since it is updated with almost every minor or major 
version release of Pixelmator. Choose Help > Pixelmator Help to 
open the Pixelmator Help window where you can browse various 
topics or use search to look for a speci!c feature that interests you.

Learn Website
Pixelmator’s Learn website at www.pixelmator.com/learn is all 
about learning how to use Pixelmator. It features helpful text, video, 
and third-party tutorials, tips, and tricks, as well as practical 
resources to make the most of the powerful Pixelmator features 
and tools.

Website
Pixelmator’s website is all about Pixelmator. It features lots of up-to-
date information about the application, including new and 
updated features, development news, and tutorials. Technical 
support for new and registered users is also available via 
Pixelmator’s website at www.pixelmator.com.

Weblog
One of the most entertaining and fun places on Pixelmator’s 
website is the weblog at www.pixelmator.com/weblog, which is 
written by the developers. One can !nd articles about the 
development process of Pixelmator, tutorials, tips and tricks, inside 
information about developers, press releases, description of 
upcoming features and many interesting happenings in the 
Pixelmator world. 

Forums
Pixelmator’s o#cial forums are full of Pixelmator users that are 
always available to answer questions, discuss the feature requests 
and anything related to image editing. Pixelmator forums also 
include a place where users share and discuss their tutorials with 
others. Pixelmator enjoys having one of the most active and 
friendly user communities in the Mac universe, and that anyone is 
welcome to join at www.pixelmator.com/support.

Tech Specs
An in-depth list of supported !le formats, features available and 
technologies used in Pixelmator can be found at 
www.pixelmator.com/specs.

http://www.pixelmator.com/learn
http://www.pixelmator.com/learn
http://www.pixelmator.com
http://www.pixelmator.com
http://www.pixelmator.com/weblog
http://www.pixelmator.com/weblog
http://www.pixelmator.com/support
http://www.pixelmator.com/support
http://www.pixelmator.com/specs
http://www.pixelmator.com/specs


Mailing List
You can subscribe to Pixelmator’s mailing list at 
www.pixelmator.com/subscribe to be the !rst to hear about new 
releases and special o"ers from the Pixelmator Team.

Feedback and Bug Reporting
Though the Pixelmator Team developers invest a lot of time and 
hard work making sure Pixelmator is a high-quality application, as 
with any other software, bugs still sometimes !nd their way into 
the application. That is why it is very important to keep developers 
informed about any bugs you are experiencing or any 
improvements that you think should be done in order to improve 
the application. And the sooner developers are informed, the faster 
they can act to !x or improve a feature. 

Feedback about the User Manual you are reading now is also very 
welcome.

Use the Report a Bug or Provide feedback forms at 
www.pixelmator.com/support to let the Pixelmator Team 
developers know about any bugs or feature requests you have.

Software Update
You may want to check the software update page at 
www.pixelmator.com/support/updates since the Pixelmator Team 
releases new versions of Pixelmator frequently. Pixelmator updates 
include new features, various improvements and bug !xes.

Tip: You can set up Pixelmator to automatically check whether there 
are any updates available by choosing Pixelmator > Preferences... and 
selecting the Updates tab. 
Check the box that says “Notify me when a new version of Pixelmator is 
available” or click the Check Now button to check immediately for 
updates.

Tip: Because the Pixelmator Team is so serious about improving 
Pixelmator, every major 1.X update is given an unusual software name. 
For example, the !rst version of Pixelmator, codenamed Firestarter, is 
called Pixelmator 1.0 Firestarter. Other versions are Pixelmator 1.1 
Kitten, Pixelmator 1.2 Draftsman, Pixelmator 1.3 Tempo, Pixelmator 1.4 
Sprinkle, Pixelmator 1.5 Spider. The most current version is Pixelmator 
1.6 Nucleus. Pixelmator 1.X updates are usually free for registered 
users.

http://www.pixelmator.com/subscribe
http://www.pixelmator.com/subscribe
http://www.pixelmator.com/support
http://www.pixelmator.com/support
http://www.pixelmator.com/support/updates
http://www.pixelmator.com/support/updates
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Part I: Interface

The Pixelmator interface is specially designed for work with 
images. It includes a variety of palettes, menus and tools for 
viewing, editing and enhancing your images.

Chapter 1 An Overview of Pixelmator

Chapter 2 The Pixelmator Interface

Chapter 3 Creating, Opening and Placing Images



Chapter 1: An Overview of Pixelmator

Pixelmator is designed to be the easy-to-use, fast and real-Mac OS X application center of your image editing work$ow, 
allowing you to create, edit and enhance your pictures and deliver professional-quality images.

This chapter provides an overview of how Pixelmator works and what you can do with it. If you are new to Pixelmator, this chapter is for you. If 
you are familiar with the Pixelmator features and interface, feel free to skip this chapter. The chapter doesn’t provide all the detailed 
information and instructions needed to work with your images. Once you are familiar with Pixelmator, you’ll !nd in-depth explanations and 
instructions in later chapters.

This chapter covers:

• A First Look at Pixelmator

• Image Processing

• Mac OS X Integration

• Compatibility



A First Look at Pixelmator

When you launch Pixelmator and open a picture, you see the following view:

Floating palettes in Pixelmator help you monitor and modify your work. While some palettes are displayed by default, there are many more 
available in Pixelmator that you can show or hide by selecting them from the View menu. More detailed information about every palette is 
available later in this manual.

All palettes in Pixelmator are transparent, so you can see through them and focus on your image instead of the application interface.

Tools palette: this is where you choose tools that 
let you select, paint, retouch, crop, move, edit, 
type, sample, and view images.

Layers palette: this is where you select, add, 
remove, link, unlink layers, adjust their opacity, 
change blending modes, add layer masks, create 
clipping masks.

Tools Options 
palette: this is 
where you 
customize the way 
your currently 
selected tool works.

Brushes palette: 
use to manage your 
brushes.

Swatches palette: 
use to select and 
manage your 
swatches.

Document window: 
displays the image 
you are working on.



Image Processing

Pixelmator is a layers-based image editor built on top of modern 
technologies, and features everything you need to create, edit and 
enhance your images.

Tools
Use Pixelmator tools for selecting, cropping, painting, 
retouching, typing, measuring and navigating.

With Pixelmator’s pixel-accurate collection of selection 
tools, you can quickly and easily select any part of your 
image. That means you can edit and apply special e"ects 
to portions of your pictures, remove unwanted objects, 
or cut out objects from one picture to put on another. 

Pixelmator painting tools allow you to use di"erent 
brush sizes, shapes, hardness and blending modes when 
painting. You can paint with Pixelmator as you would 
traditionally, play with gradients or !ll spaces with 
colors. Pixelmator’s painting tools can be used not only 
for any style of painting but also for improving your 
selections with masks or retouching.

Pixelmator has the tools for perfecting your aging or buggy photos. 
With its retouching tools, you can easily blur hard edges or sharpen 
fuzzy areas of your image. Or paint with a sample of an image to 
remove wrinkles from faces or scratches in your photos. You can use 
any of the adjustment or painting tools to polish or to re!ne your 
images.

Pixelmator also has everything you need for typing text on your 
pictures, analyzing colors, cropping, transforming, moving anything 
in your pictures or navigating through your images.

Layer-based image editing
Since layers are the building blocks of many image creations, 
Pixelmator o"ers layers-based image editing. Layers are stacked on 
top of each other, and the !nal appearance of the picture depends 
on their order.

Using Pixelmator, you can quickly 
create layers from your photos, other 
pictures, or Mac’s built-in iSight 
camera. 

Not only can you link and arrange 
added layers, but Pixelmator allows 
you to blend layers, change their 
opacity, create clipping masks, or add 
layer masks to hide some portions of 
a layer.

Image Size and Resolution, Canvas Size, and Transform Tools
Use Pixelmator’s Transform Tools to rotate, scale, stretch, $ip or 
distort an image or any object in it.

Use the Image Size tool to change the print dimensions and 
resolution of an image.

Use the Canvas Size tool to increase or decrease the full editable 
area of an image.

Fill and Stroke
Use Pixelmator’s Fill Tool to !ll a layer or selection with a color.

Use the Stroke command to paint a colored border around an 
image,  selection or layer.



Color Correction Tools
Pixelmator features an easy-to-use and powerful collection of 
intuitive color correction tools. Using these tools, you can !ne-tune 
hue, saturation, and luminance; adjust exposure, color levels, 
brightness and contrast; use Auto Enhance to dramatically improve 
less-than-perfect images with one click; even use Curves, Color 
Balance, Channel Mixer, Desaturate, Invert, Replace Color, Equalize, 
Threshold and Posterize.

Color Management
You can use a Color Management sheet to assign ColorSync pro!les 
or convert pixels to any ColorSync pro!le to maintain a consistent 
color among devices.

Color Correction Tools
Pixelmator features an easy-to-use and powerful collection of 
intuitive color correction tools. Using these tools, you can ne-tune 
hue, saturation, and luminance; adjust exposure, color levels, 
brightness and contrast; use Auto Enhance to dramatically improve 
less-than-perfect images with one click; even use Curves, Color 
Balance, Channel Mixer, Desaturate, Invert, Replace Color, Equalize, 
Threshold and Posterize.

Color Management
You can use a Color Management sheet to assign ColorSync pro les 
or convert pixels to any ColorSync pro le to maintain a consistent 
color among devices.

Filters
Pixelmator sports a huge collection of lters - over 130 are available 
for your needs. You can use distortion, blur, sharpen, color, stylize, 
halftone, generator, transitions and Quartz Composer lters to 
create breathtaking special e ects.

Pixelmator’s powerful plug-in architecture fully supports third-
party Core Image Units or Quartz Composer compositions as lters. 
This means you can simply download or create your own Core 
Image unit or Quartz Composer composition and play with it right 
away in Pixelmator.

Core Image
Pixelmator is based on Mac OS X’s Core 
Image technology that uses your Mac’s 
video card for image processing.

Core Image utilizes the graphics card for 
image processing operations, freeing the 
CPU for other tasks. And if you have a high-
performance card with increased video memory (VRAM), you’ll nd 
real-time responsiveness across a wide variety of Pixelmator 
operations. 

Filters
Pixelmator sports a huge collection of !lters - over 130 are available 
for your needs. You can use distortion, blur, sharpen, color, stylize, 
halftone, generator, transitions and Quartz Composer !lters to 
create breathtaking special e"ects.

Pixelmator’s powerful plug-in architecture fully supports third-
party Core Image Units or Quartz Composer compositions as !lters. 
This means you can simply download or create your own Core 
Image unit or Quartz Composer composition and play with it right 
away in Pixelmator.

Core Image
Pixelmator is based on Mac OS X’s Core 
Image technology that uses your Mac’s 
video card for image processing.

Core Image utilizes the graphics card for 
image processing operations, freeing the 
CPU for other tasks. And if you have a high-
performance card with increased video memory (VRAM), you’ll !nd 
real-time responsiveness across a wide variety of Pixelmator 
operations. 



Mac OS X Integration and Compatibility

Pixelmator harnesses the full power of Mac OS X. It takes advantage 
of Core Image, OpenGL and Automator, and it also supports, Quartz 
Composer, ColorSync, Spotlight, Quick Look and many other Mac 
OS X technologies.

Photo Browser
The Photo Browser palette in Pixelmator o"ers quick 
access to your iPhoto Library, events, albums, Smart 
Albums and pictures in your Pictures folder. Best of all, 
just drag-and-drop any of those images as layers in 
your Pixelmator composition.

iSight
Use Pixelmator to take a picture of yourself with Mac’s 
built-in iSight camera and add it as a layer into your 
composition. Then you can play with the image. For 
example, cut yourself out, put in another background 
and create a postcard for your friends.

Tablet Support
Using Pixelmator’s graphics drawing tablet support, 
you can hand-draw or paint with the Pencil, Brush, 
and Clone Stamp tools, or erase with the tablet’s 
eraser. You can take advantage of the tablet’s 
pressure sensitivity to work with Blur and Sharpen 
tools.

Automator Actions
Using powerful and time-saving Pixelmator actions 
in Automator, you can quickly enhance, resize, or 
transform your images, add any special e"ects, 
watermarks, or export your images to over 100 
di"erent !le formats. You can do that to as many 
images at once as you wish.

Quartz Composer
Pixelmator supports Quartz Composer compositions 
as !lters. Every version of Mac OS X 10.6 Snow 
Leopard comes with a free Quartz Composer 
application that can be used to create almost any 
possible !lter for use with Pixelmator.

ColorSync
Pixelmator supports Apple ColorSync technology to maintain a 
consistent color among devices. You can choose a ColorSync pro!le 
for an image so that its colors are matched to your device.

Quick Look
Pixelmator’s built-in Quick Look plug-in makes it possible to view 
almost any of more than 100 image !le formats supported by 
Pixelmator, without having to launch the application itself. 

Spotlight
Pixelmator’s Spotlight plug-in allows you to !nd 
Pixelmator images using any metadata information. 
You can view and edit metadata information using the 
File Info sheet in Pixelmator.

Compatibility
Pixelmator supports over 100 di"erent !le formats. You can open 
and save in PSD, TIFF, JPEG, PNG, PDF, EPS and scores of other 
image formats. Above all, Pixelmator can open and save Photoshop 
!les with layers. 

Note: An in-depth list of supported !le formats, features available and 
technologies used in Pixelmator can be found at www.pixelmator.com/
specs.

http://www.pixelmator.com/specs
http://www.pixelmator.com/specs
http://www.pixelmator.com/specs
http://www.pixelmator.com/specs


Chapter 2: The Pixelmator Interface

The Pixelmator interface is specially designed for work with images.

This chapter describes the names and functions of the Pixelmator interface elements. Use this chapter to orient yourself while learning 
Pixelmator.

This chapter covers:

• Welcome Screen

• Work Area

• Palettes and Menus

• Tools

• Viewing Images

• Rulers, Guides, and Grid

• Undo, Redo, and Revert to Saved

• Preferences



Welcome Screen

The very !rst window you’ll see when Pixelmator is launched is the 
Welcome Screen. It is the starting point for working with the 
application.

Pixelmator’s Welcome Screen allows you to choose whether to 
create a new image, open an already existing one, or simply jump 
right into the application without opening or creating any images 
yet.

Click the Create New Image button in the Welcome Screen to 
create a new image. When the new Image window appears, you 
can specify new image dimensions. Read more about creating new 
images later in this manual.

Click the Open Existing Image button to open any image that is 
stored on your Mac’s hard disk.

Click the Open Recent Image button to open the image that you 
were working with during your last session.

If you would like to set up your work area before creating a new 
image or opening an existing one, click the Close button in the 
Welcome Screen window.

If you do not want Pixelmator to show the Welcome Screen on 
every launch of the application, uncheck the Show this dialog box 
on startup checkbox. 

However, if you already turned o" the Welcome Screen and would 
like to have it appear on startup again, choose Pixelmator  > 
Preferences > General and select Show Welcome from the On 
startup pop-up menu.

If you want Welcome Screen turned o" on launch, but wish to 
temporarily open the Welcome Screen window, choose Help > 
Welcome Screen when Pixelmator is launched.

Tip: Before Pixelmator is launched, you can drag and drop any image 
on the Pixelmator application icon to open it. Pixelmator will not show 
the Welcome Screen but will skip it and open the dragged image 
instead.



Work Area

The work area of Pixelmator consists of a document window, $oating palettes and a menu bar.

Document window displays the !le you are working on. 

Floating palettes contain tools for creating and editing images as well as helping you monitor and modify your work. For example, in the Tools 
palette you choose tools that let you select, paint, retouch, crop, move, edit, type, sample, and view images, while the Tool Options palette is 
used to customize the way your currently selected tool works. You can use over 10 di"erent $oating palettes in Pixelmator to help you to 
modify your work.

Pixelmator also has dozens of color adjustment tools and !lters palettes. These palettes are not $oating ones and appear only when you 
choose a command from the Menu bar.

The Pixelmator menu bar at the top organizes commands under menus. It’s where you choose copy, paste, adjustment tools, !lters, transform 
tools, add or remove any $oating palettes, and more.

There are also sheets in Pixelmator, which are used to make adjustments to the whole document. For example, change image size, canvas size 
and make other adjustments.



Menu Bar
The Pixelmator menu bar at the top organizes commands under 
menus. Pixelmator menu bar is carefully organized by topic, and 
once you understand how it is arranged, it’s very easy to quickly 
!nd the required tool or command.

The !rst menu is called Pixelmator. It’s where you control the whole 
application. It does not include any tools for image editing but 
includes the About Box, Preferences... command which opens a 
preference window for applications; a License window if the 
application is not yet registered and a menu item for providing 
feedback, which will simply take you to the Provide Pixelmator 
Feedback website at www.pixelmator.com; and menu items for 
hiding and quitting Pixelmator.

The File menu in Pixelmator groups menu commands for creating, 
opening, saving, exporting, reverting to saved, printing images or 
getting in-depth information about the current document.

The Edit menu includes commands for undoing or redoing your 
work, copying, pasting, clearing, and cutting selections or text. It 
also has commands for loading and re!ning selections; !lling and 
stroking; transforming selections, layers or images; editing in quick 
mask mode; and spell checking.

The Image menu is the place where all the color adjustment tools 
are based as well as tools for adjusting image and canvas size.

The Layer menu is for working with layers. For more information 
about Layers, see Chapter 13 of this manual.

Note: The Pixelmator About Box (Pixelmator > About Pixelmator) is a 
place where you can check the version and the build number of the 
currently launched application. For example, if you see Pixelmator 1.6 
Nucleus (5240), 1.6 is a version, Nucleus is a code-name and 5240 is a 
build number.

The Filter menu is for using available !lters. For more information 
about !lters, see Chapter 16 of this manual.

The View menu contains commands for viewing images as well as 
for showing and hiding $oating palettes and rulers.

The Window menu contains commands for organizing and 
managing Pixelmator windows. It includes minimize and zoom 
window commands and a list of currently open windows.

The Help menu includes built-in Pixelmator Help as well as 
commands for opening Welcome Screen, Acknowledgments 
information, getting support and  downloading this User Manual.

Some commands have keyboard shortcuts listed next to them. You 
can press the keys shown to instantly perform the action without 
using a menu.

http://www.pixelmator.com
http://www.pixelmator.com


Menu commands that do not include an ellipsis (for example, Auto 
Enhance) are performed immediately without showing any dialog 
box. You might choose the wrong command from the menu bar or 
press the keyboard shortcut for an other command that you 
wanted. If Action Tooltips are enabled when you choose any tool 
that does not have a palette, it will show an action label just so you 
know you did choose something. It is useful when you are using 
keyboard shortcuts, especially undo/redo, since action tooltip will 
pop-up to tell you what you just undid or redid.

To enable or disable Action Tooltips, choose Pixelmator > 
Preferences and check or uncheck the checkbox next to Show 
Action Tooltips. 

Floating Palettes
Floating palettes in Pixelmator help you monitor and modify your 
work. While some palettes are displayed by default, there are more 
available in Pixelmator that you can show or hide by selecting them 
from the View menu. 

Almost all palettes in Pixelmator are transparent, so you can see 
through them and focus on your image instead of the application 
interface.

The most important palette in Pixelmator is the Tools palette. It is 
where you choose tools that let you select, paint, move, edit, type, 
sample and view images. To show or hide Tools palette, choose 

Tip: Menu bar commands that have an ellipsis (for example, Image 
Size...) will open a dialog or a sheet where you can specify additional 
options. Menu commands that do not have an ellipsis (for example, 
Auto Enhance) are performed immediately without showing any 
dialog box, palette or sheet.
If the command is dimmed, it is not available. For example, the Re!ne 
Selection... command may be dimmed unless you have selected any 
portion of your image using any of the selection tools.

View > Show (or Hide) Tools or use the Command + 1 keyboard 
shortcut.

The Tool Options palette allows you to customize the way your tool 
works. To show or hide the Tool Options palette, choose View > 
Show (or Hide) Tool Options or use the Command + 2 keyboard 
shortcut.2



The Layers palette is for managing layers for your image. To show or 
hide the Layers palette, choose View > Show (or Hide) Layers or 
use the Command + 3 keyboard shortcut.

The Brushes palette in Pixelmator is for selecting, creating, editing 
and managing your brushes. To show or hide the Brushes palette, 
choose View > Show (or Hide) Brushes or use the Command + 5 
keyboard shortcut.

The Gradients palette is for selecting, creating, editing and 
managing your gradients for use with the Gradient Tool. To show or 
hide the Gradients palette, choose View > Show (or Hide) 
Gradients or use the Command + 4 keyboard shortcut.

The Swatches palette is used for storing often-used colors. To show 
or hide the Swatches palette, choose View > Show (or Hide) 
Swatches or use the Command + 6 keyboard shortcut.

The Scratch palette is used for choosing a new foreground color. To 
show or hide the Scratch palette, choose View > Show (or Hide) 
Scratch or use the  Command + 7 keyboard shortcut.



A Photo Browser in Pixelmator o"ers quick access to your iPhoto 
Library, events, albums, Smart Albums and pictures in your Pictures 
folder. To show or hide the Photo Browser palette, choose View > 
Show (or Hide) Photo Browser or use the Command + 8 keyboard 
shortcut.

In addition to $oating transparent Pixelmator palettes, you can use 
the default Mac OS X Colors and Fonts palettes that are not 
transparent.

Color palette is used to choose foreground, background and any 
other colors in Pixelmator. To show or hide the Colors palette, 
choose View > Show (or Hide) Colors or use the Command + C 
keyboard shortcut.

The Fonts palette is used for advanced type options. To show or 
hide the Fonts palette, choose View > Show (or Hide) Fonts or use 
the Shift + Command + T keyboard shortcut.

In addition to using the View menu or keyboard shortcut to hide 
palettes, you can click the close button on the palette.

If you wish to hide or show all the palettes at once, press Tab. 

To get rid of the palette clutter in Pixelmator, there is a feature 
called Smart Palette Hide. When any adjustment or !lter is 
launched, unnecessary palettes that won’t be used for now 
temporarily dissolve. Once you’re done with that adjustment or 
!lter tool, palettes that were hidden come back. This allows a better 
focus on an image you are working on. Smart Palette Hide can be 
turned on or o" by choosing Pixelmator > Preferences > General 
and checking or unchecking the checkbox next to Hide 
unnecessary palettes when using adjustments or "lters.

Of course, you can move all the $oating palettes in Pixelmator to 
anywhere you like on your desktop. You move the palette by 
dragging its title bar at the top.

Some palettes such as Layers, Photo Browser and some others can 
be resized. To resize the palette, hold down the mouse button while 
you drag the bottom-right corner of a palette.

If palettes don’t reappear on screen when trying to enable them 
through the View menu, use the Shift + Command + R keyboard 
shortcut. This will reset locations of the palettes.



Other Palettes
Pixelmator also has dozens of other palettes such as color 
adjustment tools and !lters palettes. These palettes are not $oating 
ones and appear only when you choose a command from the 
menu bar.

All of these palettes include some additional settings for the 
command you chose. It may include tabs, sliders, checkboxes and 
any other controls that you use to manipulate your image, layer or 
selection. In addition to the controls mentioned, some !lters 
palettes have a rope that you use to point to the center of the 

selected !lter. You can move a rope’s end point to select the center 

Reset button: click to 
reset all of the 
parameters, to their 
default values.

Cancel and OK buttons: 
click to accept or cancel 
changes.

Controls: use to change 
parameter values. Controls 
have varying value ranges 
depending on the parameter

Note: Since there are tens of adjustments and hundreds of !lter 
palettes in Pixelmator, we will not review them in this chapter. An in-
depth look at adjustment tools and !lters is available in later chapters 
in this manual.

of the currently used !lter.

Non-$oating palettes have Reset, Cancel and OK buttons. In order 
to continue editing an image, the currently selected adjustment 
tool or !lter must be accepted or cancelled. Click the OK button to 
accept changes or click the Cancel button to reject changes.

You may also press the Return key on your keyboard for OK and 
Command + . for Cancel.

If you accidentally accepted changes and didn’t like the result, you 
may undo or redo changes by Choosing Edit > Undo or Edit > Redo 
respectively.

However, when you make changes in adjustment tool or !lter, the 
real-time preview is always available.

The Reset button allows resetting the adjustment tool or !lter 
changes to their defaults.

Rope: allows you to point to the center of the 
selected !lter. You can move a rope’s end point to 
select the center of the !lter.



Sheets
Another type of dialog in Pixelmator is sheets. A sheet is a modal 
dialog attached to a particular image that adjusts the whole image, 
not just a selection or layer.

In Pixelmator, sheets are Save As, Export, File Info, Page Setup, Print, 
Canvas Size, Image Size and Color Management functions, as well 
as Brushes and Gradients editors.

The standard in nearly every document-based application sheet is 
Save As... sheet. It is used to save the image on your Mac’s harddisk. 
In addition, the Save As... sheet allows choosing the !le format for 
your image. The default !le format is Pixelmator; however, you can 
save your image in other formats that will be discussed later in this 
manual.  Choose File > Save As... or use the Shift + Command + S 
keyboard shortcut to save your image.

Note: For more information about using Mac OS X Save As... or Open... 
dialogs, you should see Mac OS X Help documentation that is available 
under the Help menu in Finder.

The Export sheet in Pixelmator allows exporting (saving as a copy) 
your image to any of the formats supported by Pixelmator. In order 
to use the Export sheet, choose File > Export....

The Send to iPhoto sheet in Pixelmator allows sending your image 
directly to iPhoto Library.

The Send to Mail sheet allows sending your image to Mail.



The Send to Flickr sheet allows uploading your image directly to 
Flickr.

The Send to Facebook sheet allows uploading your image directly 
to Facebook.

The Send to Picasa Web Albums sheet allows uploading your image 
directly to Picasa.

In order to use any of the Send To sheets, choose File > Send To > 
Mail..., iPhoto..., Flickr..., Facebook..., or Pixelmator....

Page Setup and Print sheets are also standard Mac OS X sheets that 
are the same in nearly every Mac application. Page Setup is used to 
set paper size, orientation, and scaling before printing an image (or 
any other document in Mac OS X) while the Print sheet lets you 



choose how an image is printed. You can choose the number of 
copies, change how colors appear, print several pages on a sheet of 

paper, and more. Choose File > Page Setup... or use the Shift + 
Command + P keyboard shortcut for Page Setup and File > Print... 
or the Command + P keyboard shortcut for Print sheet.

In File Info sheet in Pixelmator, you can view essential !le 
information, EXIF data and assign keywords for an image. To view 

Note: For more information about using Mac OS X Page Setup... or 
Print... dialogs, see Mac OS X Help documentation that is available 
under the Help menu in Finder.

the File Info sheet, do one of the following: choose File > File Info... 
or press the Option + Shift + Command + I keys on your keyboard.

Use the Canvas Size sheet in Pixelmator to edit the size of the full 
editable area of an image. To view the Canvas Size sheet, choose 
Image > Canvas Size... or use the Option + Command + C 
keyboard shortcut.



The Image Size sheet in Pixelmator is used to change the print 
dimensions and resolution of an image. Choose Image > Image 
Size... or use Option + Command + I to view the Image Size sheet. 

The Trim sheet in Pixelmator is used to crop an image by trimming 
surrounding transparent pixels, or background pixels of the color 
you specify. Choose Image > Trim... to view the Trim sheet.

The Color Management sheet in Pixelmator is used to choose a 
ColorSync pro!le for an image so that its colors are matched to your 
devices, or you can change your image so that it matches a speci!c 

ColorSync pro!le. To open the Color Management sheet, choose 
Image > Color Management... or use the Shift + Command + K 
keyboard shortcut.

Gradients or Brushes editor sheets are used to create new or edit 
gradients or brushes in Pixelmator. You can show Gradient or Brush 
editors by clicking the + button or double-clicking any of the 
brushes or gradients in the Brushes or Gradients palettes.

Sheets, such as Image Size or Canvas Size, include a reset button, 
while others include a Help button that is a shortcut to Pixelmator 
Help documentation page about the sheet you are currently using.

All sheets have Cancel and OK buttons. In order to continue editing 
an image, the currently viewed sheet’s changes must be accepted 
or cancelled. Click the OK button to accept changes or click Cancel 
button to reject changes.

You may also press the Return key on your keyboard for OK and the 
Command + . for Cancel.

An in-depth description of what every sheet does and how it works 
is available later in this manual.



Contextual Menus
Use Pixelmator contextual menus to quickly choose commands or 
perform actions speci!c to an active tool, selection or palette. 

Di"erent items appear in the contextual menu, depending on the 
context. For example, if the Zoom tool is selected, you can use the 
contextual menu to quickly !t your image in the window or to 
zoom to view actual pixels. 

In fact, in addition to quickly choosing commands that are also 
available in the menu bar, there are some secret, even advanced 
commands hiding in contextual menus in Pixelmator. For example, 
when a selection is created, you can quickly make a layer via copy 
or via cut from that selection, or even use the selection to crop an 
image. We will  take a look at all the contextual menus of tools, 
palettes or selections. 

To see the contextual menu for an item, hold down the Control key 
and click the item or click the secondary (right) button of your 
mouse.



Tools

The most important palette in Pixelmator is the Tools palette. This is where you choose tools that let you select, paint, move, edit, type, sample 
and view images. The Tools palette also allows you to change foreground and background colors, switch to Quick Mask mode, and switch to 
Full Screen view.

Tools: choose tools for making selections, 
painting, moving objects, editing, typing, 
cropping, sampling and viewing images.

Colors: change foreground or background colors.

Quick Mask: this is where you switch between 
Standard mode and Quick Mask mode.

Enter Full Screen: click to switch between window 
and full-screen modes.



Toolbox
Pixelmator comes with over 20 tools for selecting, cropping, painting, retouching, typing, measuring and navigating. A list of Pixelmator tools 
showing the tool icon, name, description, and keyboard shortcut is available below.

Move (V) Move layers or selections Eraser (E) Erase portions of your image 

Rectangular Marquee (M) Make rectangular selections Magic Eraser (E) Use to erase similarly colored areas

Elliptical Marquee (Y) Make elliptical selections Gradient (G) Use to create linear, radial or angle blends 
between colors

Lasso (L)* Make freehand selections Paint Bucket (N) Fill similarly colored areas with color

Polygonal Lasso (L) Make straight edged selections Blur (R) Use to blur hard edges in an image

Magic Wand (W) Use to select similarly colored areas Sharpen (O) Use to sharpen soft edges in an image

Crop (C) Use to trim images Type (T) Create type on an image

Slice (K) Use to slice images Eyedropper (I) Sample colors in an image

Pencil (P) Paint hard-edged strokes Hand (H) Move an image within its window

Brush (B) Paint brush strokes Zoom (Z) Magnify and reduce the view of an image

Clone Stamp (S) Paint with a sample of an image

* Some tools such as Lasso and Polygonal Lasso, Eraser and Magic Eraser share the same keyboard shortcut. In order to switch to a secondary tool, click the 
shortcut twice. For example, if you selected the Lasso Tool (L) but wish to use the Polygonal Lasso Tool, click the L shortcut again.



Use a tool
In order to use a tool, make sure the Tools palette is visible. If it is 
not visible, choose View > Show Tools or press the Command + 1 
keyboard shortcut to show the Tools palette.

To use a tool in the Tools palette, do one of the following:

• Click a tool in the Tools palette.

• Press the tool’s keyboard shortcut.

When you select a tool, its icon pops up and stays bigger so you can 
see which tool is currently active.

Currently active 
tool: when a tool is 
selected, its icon is 
bigger than other 
tool icons.

Cycle through hidden tools
Some tools such as Polygonal Lasso and Magic Eraser are not visible 
in the Tools palette by default. Instead, these tools are grouped 
with primary tools such as Lasso and Eraser. So if 
you want to use Polygonal Lasso instead of Lasso 
or Magic Eraser instead of Eraser, do one of the 
following:

• Select a primary tool (Lasso or Eraser), choose View > Show Tool 
Options and in the Tool Options palette click the secondary tool 
(Polygonal Lasso or Magic Eraser).

• Select primary tool (Lasso or Eraser) and click its keyboard 
shortcut to switch to the secondary tool. To switch back to a 
primary tool, click its keyboard shortcut again.

Tip: Some items in Pixelmator such as tools or buttons may have help 
tags (tips or hints) that give you additional information. To see if an 
item has a help tag, rest the pointer over it for a second or two.

That is a quick way to see a tool’s name and keyboard shortcut without 
looking into help documentation.



Tool Options
When working with Pixelmator tools, you may need to use the Tool 
Options palette frequently since it allows you to customize the way 
your tool works.

Tool Options: the picture 
shows tool options for the 
Magic Wand Tool.

To show or hide the Tool Options palette choose View > Show (or 
Hide) Tool Options or press the Command + 2 keyboard shortcut.

The Tool Options palette changes every time you switch tools since 
every single tool in Pixelmator has its own settings. Some settings 
are common to several tools while others are speci!c to just one 
tool.

Tool Options: the 
picture shows tool 
options for the Type Tool.

We will take an in-depth look at all the settings and tools in later 
chapters of this manual.



Viewing Images

It is very useful to learn the tools for viewing images in Pixelmator 
since they help you to work faster and more precisely with your 
images.

Full-screen Mode
There are two screen modes in Pixelmator: a standard mode, which 
is present when Pixelmator launched, and a full-screen mode, 
which you can switch to by doing one of the following:

• Choose View > Full Screen.

• Click on the full-screen mode button in the Tools palette.

Full-screen button: click to switch 
to or from the full-screen mode.

• Press F on your keyboard to cycle through standard and full-
screen modes.

Full-screen mode hides your desktop, window title bar, and scroll 
bars so you can view images on your entire screen and better focus 
on your image. 

Though in the full-screen mode Menu Bar is hidden, it is still 
accessible by moving your mouse pointer up to the upper edge of 
the screen.

To exit full-screen mode, do one of the following:

• Choose View > Full Screen.

• Click on the full-screen mode button in the Tools palette.

• Press F on your keyboard to cycle through standard and full-
screen modes.



Canvas Background Color
You can change the background color of the work area by right-
clicking on an area outside the canvas and choosing white, grey, or 
black. 



Navigating in an Image
To view another area of an image, do one of the following:

• Use the window scroll bars

• Select the Hand Tool and drag to pan over an image

Zoom In or Out
Since zooming is one of the most used functions in image editing, 
there are many ways to zoom in or out in Pixelmator.

To zoom in or out of an image, do one of the following:

• Select the Zoom Tool in Tools palette. The cursor becomes a 
magnifying glass with a plus sign in its center. In the Tool Options 
palette, choose either the Normal (Zoom In) or Alternate (Zoom 

Tip: To temporarily use the Hand Tool while another tool is selected, 
hold down the Spacebar as you drag in the image.

Out) radio buttons. Click the area of an image you want to 
magnify. Notice the mouse cursor changes to a plus or minus 
icon.

• Select the Zoom Tool in Tools palette. The default Zoom tool is 
activated. It shows you the plus sign on its cursor’s icon. Click the 
area of an image to zoom in, or Option + Click the area to zoom 
out. Notice that Zoom cursor now has a minus sign on it. In the 
Tool Options palette, if Alternate (Zoom Out) zoom is chosen, 
Option + Click will temporarily change it to Normal (Zoom In).

• Select the Zoom Tool in Tools palette and click and drag a 
selection rectangle, called a marquee, around the area you want 
to magnify. The area you just selected using the Zoom tool will be 
displayed at the highest possible magni!cation level.



• Choose View > Zoom In to zoom in or View > Zoom Out to zoom 
out.

• If the Zoom Tool is selected and you wish to set the zoom level 
more precisely, you can drag the zoom slider in the Tool Options 
palette. Exactly the same zoom slider is also available in the Tool 
Options palette if the Hand Tool is selected.

• To zoom in or out using your mouse scroll wheel, press the 
Option key on your keyboard and scroll your mouse’s wheel up to 
zoom in or back to zoom out.

• Control-click or right mouse button click on an image with the 
Zoom Tool selected and choose Zoom In or Zoom Out from the 
contextual menu to magnify.

• Use the Hand Tool’s Tool Options palette to zoom in or out when 
the Hand tool is selected.

• Use Command + to zoom in and Command - to zoom out.

The keyboard shortcut for quickly selecting the Zoom Tool is Z.

100% Zoom
To display an image at 100% zoom, do one of the following:

• Double-click the Zoom Tool in Tools palette.

• Choose View > Actual Pixels.

• Control-click or right mouse button click on an image with the 
Zoom Tool or Hand Tool selected and choose Actual Pixels from 
the contextual menu.

Note: The maximum magni!cation level in Pixelmator is 3200%. When 
this level is reached, the Zoom Tool cursor’s magnifying glass appears 
empty.

• Use the Option + Command + 0 keyboard shortcut.

Fit an Image to Window
To !t an image to a window or screen (in case you work in full-
screen mode), do one of the following:

• Double-click the Hand Tool in Tools palette.

• Choose View > Fit in Window.

• Control-click or right mouse button click on an image with the 
Zoom Tool or Hand Tool selected and choose Fit in Window from 
the contextual menu.

• Use the Command + 0 keyboard shortcut.

The keyboard shortcut for quickly selecting the Hand tool is H. 

Tip: It is highly recommended that you remember the Zoom Tool (Z) 
and Hand Tool (H) keyboard shortcuts since these tools are used a lot 
when editing images.



Rulers, Guides, and Grid

Rulers, guides, a grid or any combination of them in Pixelmator 
help you position your  images or objects precisely. When shown, 
rulers appear along the top and left side of the window. A grid 
appears as lines or dots on an image itself, and guides appear as 
lines and can be added or removed. Both guides and grids are 
nonprinting lines that $oat over the image.

Rulers
Rulers appear along the top and left side of the window. Rulers 
show the size of an image and mouse pointer location. The ruler’s 
zero origin and units of measurement can be changed. 

Show or Hide Rulers
To show or hide rulers, do one of the following:

• Choose View > Show (or Hide) Rulers.

• Use the Command + R keyboard shortcut.

Change Ruler’s Zero Origin
The ruler’s zero origin can be changed for measuring from a speci!c 
point on an image. To change the ruler’s zero origin, click and drag 

the upper left corner of the ruler on to your image. A set of dotted 
cross lines appear marking the new origin for the rulers.

To reset a ruler’s origin to its default  value, double - click the upper 
left corner you just used to click and drag your ruler’s origin pointer.

Tip: Hold down the Shift key as you drag the ruler’s origin lines to make 
them stick to the ruler ticks.

Tip: Notice that some ruler ticks become brighter when you move the 
mouse cursor when rulers are displayed. Those ticks mark your 
pointer’s position when you move it.



Change Ruler’s Unit of Measurement
The units of measurement for rulers can be changed to pixels, 
inches, centimeters, millimeters, points, picas or percentages. To 
change the ruler’s unit of measurement, do one of the following:

• Choose Pixelmator > Preferences > Rulers and choose the unit 
from Default Units pop-up.

• Control + Click or right mouse button click on a ruler in the 
Pixelmator window for a contextual menu to appear. Choose a 
unit from the Ruler Units list in a contextual menu.

The default ruler unit is pixels. However, if you change the default 
measurement unit in Preferences window, the next time  you open 
any picture, it will use that selected unit.

Guides
Guides appear as nonprinting lines that $oat over the image and 
help you precisely position objects in the place you want them. 
Guides can be placed anywhere on your image, moved, removed 
and locked.

Add Guide
 To add a guide, do one of the following:

• If the rulers are not visible, choose View > Show Rulers. Click and 
drag any of the  horizontal or vertical ruler bars and drop the 
guideline anywhere on your image.

Tip: Once you change ruler units in Preferences, Pixelmator will use 
that unit for later images. But if you choose the ruler unit from a ruler 
contextual menu, it will be used only for the current image. If you close 
and open that image, it will still use the measurement unit that was 
chosen in the Preferences window.



• Double-click any of the horizontal or vertical ruler bars and a New 
Guide sheet will appear. Select horizontal or vertical orientation 
and enter a position where your guide should be placed. Click OK 
after you are done.

Show or Hide Guides
Guides can be hidden or shown. To show or hide guides, do one of 
the following:

• Choose View > Show (or Hide) Guides.

• Control + Click or right mouse button click on a ruler bar in 
Pixelmator window for a contextual menu to appear. Choose 
Hide (or Show) Guides.

• Use the Option + Command + ; keyboard shortcut.

Tip: Hold down the Shift key as you drag a guide to make it snap to 
the ruler ticks.

Tip: Hold down the Option key as you drag away from vertical ruler to 
create a horizontal guide and vice versa.

Move a Guide
Once placed, guides can still be moved. To move an already placed 
guide, select the Move Tool from the tools palette and position the 
pointer over the guide. Notice the cursor changes in to a move 
guide icon. Now you can drag the guide to move it.

You can change the guide orientation by holding down the Option 
key on your keyboard as you click and drag the guide.

Remove Guide
To remove a single guide from an image, do one of the following:

• Drag and drop the guide outside the image window. A poof 
animation will appear to notify you that the guide is removed.

• Select the Move Tool, position the pointer over the guide, Control 
+ Click or right mouse button click on a guide and choose 
Remove Guide from the guide contextual menu.

To remove all guides in an image, right-click the mouse on the Ruler 
Bar and select Clear Guides in the rulers contextual menu.

Tip: To temporarily switch to Move Tool when any other tool is 
selected, hold down the Command key. This allows you to quickly 
move a guide.



Lock and Unlock Guides
You can lock guides so that they will not be moved by accident. To 
lock guides in an image, right-click the mouse on the ruler bar and 
choose Lock Guides in the rulers contextual menu.

To unlock guides in an image, right-click the mouse on the ruler bar 
and choose Unlock Guides in the rulers contextual menu.

Change Guide’s Color and Opacity
You can customize the look of a guide by choosing its color and 
adjusting opacity.

To change a guide’s color and adjust opacity, choose Pixelmator > 
Preferences > Rulers and click on Guides Color button. Select the 
color and adjust the opacity in Apple Color picker.

Grid
The Grid provides you with a means of aligning an image’s 
elements to the horizontal or vertical axis and is useful for laying 
out objects symmetrically. The grid appears as nonprinting lines.

Tip: For the most accurate placement of guides, it is best to view the 
image at 100% or maximum (3200%) zoom level.

Show or Hide Grid
To show or hide a grid, do one of the following:

• Choose View > Show (or Hide) Grid.

• Use the Option + Command + ‘ keyboard shortcut.

Grid Settings
To adjust the grid spacing, choose Pixelmator > Preferences > 
Rulers and enter a value to indicate how many units a gridline 
should have and at what unit value subdivisions should be placed 
to divide the gridline.

If needed, change the units for the gridline setting.

Change Grid Color and Opacity
You can customize the look of a grid by choosing its color and 
adjusting its opacity.

To change the color and adjust opacity, choose Pixelmator > 
Preferences > Rulers and click on the Grid Color button. Select the 
color and adjust the opacity in Apple Color picker.



Snapping
Guides and grids are especially useful when positioning objects 
with the Snapping feature enabled. Snapping makes selections, 
some tools, and layers snap to within 5 screen pixels of a guide, 
grid, layers or the edges. 

Enable Snapping
To set selections, some tools, and layers to snap to desired objects 
such as guides, grid, layers or document boundaries, choose 
Pixelmator > Preferences > Rulers and choose one or more of the 
following options from the Snapping section:

Guides snaps to guides; Grid snaps to the gridlines and gridline 
subdivisions; Layers snap to layers edges; Slices snap to slice 
boundaries; and Document Bounds snap to the edges of the 
image.

A check mark near the name of an element indicates that snapping 
for that element is enabled.



Info Labels

Info labels appear next to the mouse cursor and show useful 
information, depending on the tool in use.

Info labels show the following information:

• Size of the elliptical or rectangular selections when drawing 
them.

• Tolerance level for the Magic Eraser, Magic Wand, and Paint 
Bucket tools.

• RGB color values when the Eyedropper tool is clicked and 
dragged.

• Dimensions such as size, angle, and coordinates for the Crop, 
Slice, and Transform tools.

• Angle or radius for the Gradient tool.

• Position of the guide when added.

Show or Hide Info Labels
To show or hide the info labels:

• Choose Pixelmator > Preferences....

• Check the Show information labels checkbox in the General tab.



Preferences

Preferences is a place where some Pixelmator settings are available. 
Preference settings a"ect only the default behavior and 
appearance of the application. The Pixelmator preferences window 
includes General, Transparency, Rulers, and Updates tabs.

To open a Preferences window, do one of the following:

• Choose Pixelmator > Preferences....

• Use the Command + , keyboard shortcut.

General
The General tab includes Welcome Screen behavior settings, allows 
you to set new image content, and settings for Smart Palette Hide 
and Action Tooltips features.

If you would like to turn the Welcome Screen of Pixelmator on or 
o",  in Pixelmator Preferences choose Show Welcome or Do 
Nothing from the On Startup pop-up menu.

When creating a new image in Pixelmator, the new image’s content 
is transparent by default. However, if you would like to change this 
or have a white or black background layer, choose White, Black or 
Transparent from the New Image Contents pop-up menu.

A feature called Smart Palette Hide can be turned on or o" by 
checking or unchecking the Hide unnecessary palettes when 
using adjustments or !lters. When any adjustment or !lter is 
launched, unnecessary palettes that won’t be used for now 
temporarily dissolve. Once you’re done with that adjustment or 
!lter tool, palettes that were hidden come back. This allows a better 
focus on an image you are working on. Smart Palette Hide is turned 
on by default.

Another useful feature in Pixelmator is Action Tooltips. If Action 
Tooltips are enabled in Pixelmator Preferences, when you choose 

any tool that does not have a palette, it will show an action label so 
you know you did choose something. It is useful for working using 
keyboard shortcuts especially the undo/redo ones since action 
tooltip will pop-up to tell you what you just undid or redid. Action 
Tooltips can be enabled or disabled by checking or unchecking the 
Show Action Tooltips checkbox.

Info labels appear next to mouse cursor and show useful 
information depending on the tool in use. Check or uncheck the 
Show info labels checkbox to show or hide info labels.

Transparency
The Transparency tab includes the Pixelmator transparency 
checkerboard settings. This is a nonprinting checkerboard that 
helps you to know when there are no layers or layer opacity is low 
in an image. For example, you can see the transparency 
checkerboard when all layers in an image are turned o" or 
removed, or if layers that are in your image are transparent.

To set the transparency checkerboard grid size, choose Small, 
Medium or Large from the Grid Size pop-up menu in 
Transparency preferences.



To set the transparency checkerboard grid color, choose Light, 
Medium or Dark from the Grid Color pop-up menu in 
Transparency preferences.

Rulers
The Rulers tab in Pixelmator Preferences includes appearance 
settings for rulers, guides and a grid.

To set the default ruler units for an application, choose Pixels, 
Inches, Centimeters, Millimeters, Points, Picas or Percent from the 
Default Units pop-up menu in rulers preferences.

To change the default color settings for guides in Pixelmator, click 
the Guides Color button and use the Color palette to choose a 
preferred color for guides. You can also adjust the opacity slider in 
Color palette to change the guide’s opacity.

To change the default color settings for a grid in Pixelmator, click 
the Grid Color button and use the Color palette to choose a 
preferred color for the grid. You can also adjust the opacity slider in 
Color palette to change the grid opacity.

To adjust the grid spacing, enter a value for Gridline every to set 
the number of units a gridline should use for placement and at 
what unit value subdivisions should be placed to divide the 
gridline. If needed, change the units for the gridline setting.

To change the default color settings for slices in Pixelmator, click 
the Slices Color box and use the Color palette to choose a preferred 
color for slices. 



Updates
The Pixelmator Team frequently releases free updates for 
Pixelmator. These updates include new features and important 
stability or performance updates for Pixelmator. Using the 
Pixelmator Updates preferences, you can check for updates 
manually or set the application to automatically check for new 
updates.

To set the application to tell you when a new update is available, 
check the Notify me when a new version of Pixelmator is available 
checkbox in the Pixelmator Updates tab.

If you would like to check whether there are any updates, click the 
Check Now button.

When Pixelmator detects that an update is available, you can 
choose to install, skip or cancel the update.

The software update feature is turned on by default.

Note: Pixelmator Software Update does not send any personal 
information to developers. The only thing that Pixelmator software 
update servers receive is the current version number of the 
application.

For more information about what software update may bring visit 
the software update page at www.pixelmator.com/support/
updates .

http://www.pixelmator.com/support/updates
http://www.pixelmator.com/support/updates
http://www.pixelmator.com/support/updates
http://www.pixelmator.com/support/updates


Undo, Redo and Revert to Saved

The Undo or Redo commands in Pixelmator let you undo or redo 
your work. You also have an ability to revert to the last saved 
version of your work. 

Undo, redo and revert to saved commands will undo or redo 
changes you made to your image but not changes you made to the 
application’s interface, tool options or palettes position.

Undo and Redo
To undo or redo, do one of the following:

• Choose Edit > Undo (command name) or Edit > Redo (command 
name).

• Use the Command + Z keyboard shortcut to undo; or use the 
Shift + Command + Z keyboard shortcut to redo.

Revert to Saved
You can also revert to the last saved version of your work by 
choosing File > Revert to Saved.... Though after choosing Revert to 
Saved Pixelmator will ask you whether you really would like to 
revert your work, be careful about using this feature since the 
operation cannot be undone.

Note: Though Pixelmator undo and redo operations are unlimited, 
they depend on your available free hard disk space. For example if you 
work on an image that includes a single 1000 x 1000 pixels layer it will 
create a temporary 4 Mb !le on your hard disk.
It is highly recommended that you have at least 3 Gb of free hard disk 
space when you work in Pixelmator. 
However, if the hard disk space runs out - Mac OS X Finder noti!es you 
about that.

Temporary !les are removed from your hard disk each time you close 
the document you are working on whether you save it or not.



Chapter 3: Creating, Opening and Placing Images

Pixelmator supports over 100 di"erent !le formats. You can open or place into your compositions any PSD, TIFF, JPEG, 
PNG, PDF !le and scores of other image formats. Using the Photo Browser palette, you can quickly access images from 
your iPhoto library even without switching applications.

This chapter explains how to create, open and place new images and introduces you to Photo Browser and Pixelmator images.

This chapter covers:

• Creating New Images

• Opening Images

• Placing Images

• Importing Images From Devices

• Pixelmator Images



Creating New Images

You start working in Pixelmator by creating or opening images. 
When creating new images, you choose a new document preset or 
create your own by specifying the image width, height and 
resolution.

Create a New Image
To create a new image in Pixelmator do one of the following:

• Choose File > New....

• Use the Command + N keyboard shortcut.

• Click the Create New Image button in the Welcome Screen 
window.

When a new dialog box appears, choose a new document preset or 
manually set the width, height, and resolution for the document.

Fo your convenience, you can choose the measurement unit from 
the Width or Height pop-up menu to specify an image width or 
height in pixels, inches or centimeters. You can also use pixels per 
inch or pixels per centimeter measurement to set the resolution for 
your image by choosing it from the Resolution pop-up menu.

3. When you !nish, click OK to show a newly created image.

Document Presets
Pixelmator comes with a number of the most popular and standard 
image presets for your work. Pixelmator document presets can be 
divided into these categories:

• Display category that includes the majority of standard screen 
sizes: 640 x 480, 800 x 600, 1024 x 768, 1280 x 800, 1650 x 1080, 
1920 x 1200 sizes. Sizes are in pixels.

• Web category that features most popular standard banner sizes: 
Rectangle (180 x 50), Medium Rectangle (300 x 250), Leaderboard 
(728 x 90), Wide Skyscraper (160 x 600). Sizes are in pixels.

• Photo category includes 2 x 3 photo, 4 x 6 photo, 5 x 7 photo and 
8 x 10 photo. Sizes are usually shown in inches.



• Print category includes the standard A6, A5, A4, Letter, Legal and 
Tabloid paper sizes.

• Other sizes that don’t !t in the previous categories: iPhone 
Desktop (320 x 480) and iTunes artwork (300 x 300).

New Document From Clipboard
The document presets list also includes a Clipboard setting that you 
can choose in order to create a new document with the width and 
height settings of a document that is in Clipboard.

To create a new image from clipboard (assuming that your 
clipboard is not empty), do one of the following:

• Choose File > New....

• Use the Command + N keyboard shortcut.

• Click the Create New Image button in the Welcome Screen 
window.

When a new dialog box appears, choose Clipboard from the 
document presets pop-up menu.

Click OK.

Or simply click right-click the Pixelmator icon in the Dock and 
choose New from Clipboard. 

Image Size and Resolution: The default resolution for pictures is 72 
dpi (dots per inch). It is the standard used for Web images as well as for 
digital photos.
However, if you would like to print your image in an exact size, you will 
have to change the default dpi setting in the New Image dialog box or 
Image Size sheet. The best results can be achieved when printing in 
300 dpi.
When creating images for print, it is recommended that you use the 
default document presets that will automatically set dpi for your 
image.

If the clipboard is empty, the clipboard menu item in the Presets 
pop-up menu and Dock menu will be dimmed. 

To check whether your clipboard includes any information:

1. Switch to Finder.

2. Choose Edit > Show Clipboard.

Create New Document Preset
Sometimes you may want to create a new document preset to 
quickly create a required document when needed. To create a new 
document preset:

1. In the New dialog box set the width, height and resolution.

2. In the Action menu choose Save Preset As.

3. In the sheet that appears, enter preset name and select the 
presets group.

4. Click OK. Your new document preset should be available in a New 
dialog’s Preset pop-up menu.



Edit Document Preset
You can edit your document preset anytime you want. To edit the 
new document preset:

1. Choose Manage Presets in the New dialog Action menu.

2. Double-click on preset name, width, height or resolution to edit.

3. Click OK once you are done.

Delete Document Preset
To delete the document preset:

1. Choose Manage Presets in the New dialog Action menu.

2. Select the document preset you want to delete from the presets 
list.

3. Click the Delete button (-) to delete the selected preset.

Share Document Preset
You may want to share your document preset with your friends. To 
share the document preset:

1. Choose Manage Presets in the New dialog Action menu.

2. Click and drag the document preset you would like to share onto 
your desktop.

3. A document with the name of the preset is created. 

You can give the preset document to a friend who uses Pixelmator. 

To add the saved document preset to Pixelmator, simply drag and 
drop the document onto the application icon.

Sharing Document Presets
You can also share your document presets with other Pixelmator 
users. 

To share your Pixelmator document preset:

1. Click on any of the presets in the Manage 
New Document Presets sheet and drag it to 
your desktop.

2. A document appears which you can send to 
your friend.

3. To add a preset document into Pixelmator, 
simply drag the document preset icon onto the Pixelmator 
application icon, Manage New Document Presets sheet or 
document window. It will appear in the Presets pop-up menu.



New Image Contents
When you create a new image, it will be completely empty and will 
show the transparency checkerboard by default. If you would like 
the new image to have a white or black layer for a start, you can set 
that in Pixelmator > Preferences > General by choosing White, 
Black or Transparent from the New Image Contents pop-up.

 



Opening Images

Using Pixelmator, you can open over 100 di"erent image formats 
including PXM, PSD, TIFF, PNG, JPEG, GIF, PDF and many others. You 
can open images using Open and Open Recent commands as well 
by simply dragging and dropping images on the Pixelmator 
application icon.

Open Image

To open an image, do one of the following:

• Choose File > Open, select the document in the Open dialog box 
and click Open.

• Drag and drop an image you want to open onto the Pixelmator 
icon in the Mac OS X dock.

• Use the Command + O keyboard shortcut, select the document 
in the Open dialog box and click Open.

• Click the Open Existing Image button in the Welcome Screen 
window.

Open Recent Image
To open a recently used !le, choose File > Open Recent > select a 
!le from the submenu.

Open Recent command keeps ten recently used !les in the list. If 
you would like to clear the list, Choose > File > Open Recent > Clear 
Menu.

Open Image using the Photo Browser
Though Pixelmator Photo Browser is mostly used for placing 
photos and pictures as layers to your compositions, you can also 
use it to open images that are located in your iPhoto Library or 
Pictures folder.

To open an image using Photo Browser:

1. Choose View > Show Photo Browser. 

2. In the Photo Browser source view, select the iPhoto Library, 
Album or Pictures folder, depending on where your image is 
located.

3. Look for your image in image browser and double-click it to open 
it in Pixelmator.



Open PDF File
PDF is an abbreviation for Portable Document Format, and a !le 
with this format can contain a single image or multiple pages and 
images. When you open a PDF document in Pixelmator, you can 
choose which page to open if the document contains more than 
one.

Opening a PDF document is the same as opening any other images. 
And if the PDF contains a single page or image, you won’t see any 
di"erence from other images.

However, if the PDF you open contains multiple pages, an Open 
PDF dialog box appears, and you can choose which page to open in 
Pixelmator.

Use the Open PDF cover $ow to scroll through pages, and once you 
locate the page you would like to open, double-click on it or click 
the OK button.



Placing Images

You can place any Pixelmator-supported image in your 
composition as a layer. And placing is as simple as drag and drop.

Place an Image into Your Composition
To place an image into your composition:

1. Open the Pixelmator image that is the destination for the picture.

2. Drag and drop the image you want to place from Finder onto the 
opened image window.

The placed image appears as a new layer in your composition that 
you can edit as you would any other layer in Pixelmator.

Tip: You can place images from nearly anywhere in your Mac to your 
composition: directly from other applications that support drag and 
drop such as iPhoto, from Finder, even from other Pixelmator 
documents.

Placing Layers from One Pixelmator Image to Another
To put a layer from one image in another:

1. Open the Pixelmator image that is the destination for the placed 
layer.

2. Open the image that has a layer that you want to place in the 
destination image.

3. Drag and drop a layer from the layers palette to the destination 
image.

For more information about Layers, see Chapter 13 in this manual.



Photo Browser
The Photo Browser palette in Pixelmator o"ers quick access to your 
iPhoto Library, events, albums, Smart Albums and pictures in your 
Pictures folder. Drag and drop any of the images in iPhoto or 
Pictures folder as layers in your Pixelmator composition.

To open the Photo Browser, do one of the following:

• Choose View > Show Photo Browser.

• Use the Command + 8 keyboard shortcut.

Tip: You can set Photo Browser source view to show iPhoto albums or 
Pictures folder in a pop-up menu or a list by dragging the split line 
between source list and photo thumbnails view up or down.

Place an Image from Photo Browser
To place a picture in your composition from iPhoto Library, events, 
albums, Smart Albums or Pictures folder:

1. Choose View > Show Photo Browser if it is not shown yet.

2. Select the iPhoto album or Pictures folder depending on where 
your picture is located.

3. Locate your picture by scrolling through photo thumbnails in the 
Photo Browser or by using the search !eld to !nd that speci!c 
picture.

4. Drag the photo thumbnail to the document window in 
Pixelmator where you want to place that picture.

Tip: You can use the Photo Browser palette to open an image. Simply 
look for your image in Photo Browser and instead of dragging its 
thumbnail to your composition, double-click it to open it in Pixelmator.



Importing Images from Devices

Images can be imported from cameras and scanners. The browser 
shows both USB and network devices. It displays their names, 
types, and icons. The list is updated dynamically as devices are 
plugged in, removed, or renamed. The camera device type includes 
camera-phones (including the iPhone) and memory card readers. 
The scanner device type includes multifunction devices such as 
printer-scanner-FAX machines.

To import an image from a scanner:

1. Choose File > Import....

2. Select the scanner from the Devices list.

3. Wait until scanner heats up and scans a preview image.

3. If needed, adjust the boundaries and resolution of the image.

4. Click Scan.

To import an image from other devices:

1. Choose File > Import....

2. Select the device from which you want to import images.

3. Locate and select document(s) you want to import.

4. Click Import or Import All.



Pixelmator Images

Pixelmator supports over 100 di"erent !le formats including PSD 
with layers, TIFF, PNG, JPEG, GIF and many others. The default !le 
format for Pixelmator is PXM.

Getting File Information
Most images have basic information such as height, width, !le 
format, resolution, color space, attached ColorSync pro!le, 
keywords, and more attached to them. Such information is called 
Metadata.

To view the metadata information, do one of the following:

• Open an image for which you would like to view the information.

• Choose File > File Info.

• Use the Option + Shift + Command + I keyboard shortcut.

File Info sheet appears.

The Summary tab in the File Info sheet contains information such as 
!le name, !le format, !le size, image size, image resolution in 
pixels/inch, color space and attached ColorSync pro!le.

For more information about the opened image, click the Details 
tab. Here you will !nd formats information such as Exif and IPTC, 
and others such as TIFF.

If the image doesn’t have any metadata information except for the 
basics, the Details tab will be empty.

Assigning Keywords to an Image
You can also assign keywords to your image, and since Pixelmator 
comes with a built-in Spotlight plug-in, you can perform searches 
using those keywords.

To assign keywords to an image:

1. Choose File > File Info.

2. Select the Keywords tab.

3. Do one of the following:

• To add a keyword, click Add (+).

• To delete a keyword, select it and click Delete (-).

• To edit a keyword, double-click it.

Exif and IPTC: The latest digital cameras always attach the Exif data to 
each photo taken. Exif information includes the capture time, camera 
settings for the photo (exposure, ISO, even GPS coordinates if such a 
feature is available).
Additional IPTC metadata stored includes detailed non-technical 
information such as photographer’s name, photo copyright, 
description, capture place, etc. IPTC data is usually added by the 
photographer.



PXM File Format

The default Pixelmator !le format is PXM. 
It is the best way to save and store your 
compositions for further editing since it 
o"ers full  support for Pixelmator 
features. For example, layers, type layers, 
masks, blending modes and opacity 
settings information is stored within the 
PXM !le and is not lost when the 
document is saved. Other !le formats 
such as JPEG, PNG, GIF, BMP and many 
others cannot store such information, and once saved, the majority 
of the data that has to do with Pixelmator features is lost.

However, there is one disadvantage to using the PXM format. Since 
PXM is quite a new !le format, it is not supported by other 
applications. For example, a Preview application that comes with 
the Mac OS X is not capable of opening PXM !les. There are other 
!le formats available in Pixelmator that you can save in for 
compatibility.

In case you are working on a composition and just want to save it 
for later editing, the best format to save in is PXM, but if you would 
like to open your image in any other application, use other !le 
formats such as PSD, TIFF, PNG, GIF etc.

PSD Compatibility
PSD is an abbreviation for Photoshop Document. The PSD format is 
the default format for Adobe Photoshop. The PSD format stores an 
image with support for most features available in Adobe 

Tip: A Quick Look plug-in for the Mac OS X that comes with Pixelmator 
makes it possible to quickly view almost any of the 100 image !le 
formats supported by Pixelmator without having to launch the 
application. The Pixelmator Quick Look plug-in supports PXM and can 
show a quick preview of Pixelmator compositions in Finder.

Photoshop including layers, transparency, type, blending modes 
and some other information.

Pixelmator can open and save PSD 
documents. However, not all of the features 
of PSD are supported by Pixelmator. 

Features of a PSD !le format that Pixelmator 
supports are bitmap layer information and 
blending settings and guides. Adjustment 
layers, layer e"ects and vector layers are not 
supported at this time.

TIFF Compatibility
Short for Tagged Image File Format, TIFF is a 
widely used bitmapped graphics !le format that 
Pixelmator can open. However, some TIFF 
documents may contain layers. TIFF layers are not 
currently supported by Pixelmator, but the 
application is able to open such TIFF image in a merged layers 
mode.

JPEG Compatibility
Short for Joint Photographic Experts Group, JPEG 
is a popular image !le format that lets you create 
highly compressed graphics !les. The amount of 
compression used can vary. Less compression 
results in a higher-quality image. JPEG !les usually 
have the “.jpg” extension.

Pixelmator o"ers full support for opening JPEG images.

Note: Some images created using other applications may use di"erent 
color modes such as CMYK, Indexed Color or Grayscale. When you 
open such a !le in Pixelmator, the !le will be converted to RGB color 
mode since that is the only mode used by Pixelmator. For more 
information about color, color modes see Chapter 4 in this manual.



PNG Compatibility
Short for Portable Network Graphics, PNG is a 
bitmapped graphics !le format that has been 
approved by the World Wide Web Consortium to 
replace patented GIF !les. PNG !les are patent-
and-royalty-free.

Pixelmator o"ers full support for opening PNG images.

GIF Compatibility
Short for Graphics Interchange Format, GIF is the 
!le format mainly used to display indexed-color 
images in websites. 

Pixelmator o"ers full support for opening GIF 
images, but the application cannot play GIF 
animations.

Quick Look Plug-in
Using Quick Look in Mac OS X, you can view the preview of an 
image without opening it. Pixelmator Quick Look plug-in allows 
viewing of all the images supported by Pixelmator, including the 
default Pixelmator !le format.

Note: For a complete list and description of !le formats supported by 
Pixelmator, see Chapter 22.

You don’t need to worry about installing the plug-in since it comes 
with the application and works as soon as you have Pixelmator on 
your Mac. For more information about the Quick Look and how to 
use it, see the Mac OS X help documentation.

Spotlight Plug-in
Pixelmator’s Spotlight plug-in allows !nding Pixelmator images by 
using any metadata information. You can view metadata 
information and edit keywords using the File Info sheet in 
Pixelmator.

Spotlight plug-in will work on your Mac as soon as Pixelmator is on 
your Mac. There is no need to do any additional installations.
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Part II: Color

Pixelmator features a simple and elegant collection of intuitive 
color management and color correction tools. Using these tools, 
you can !ne-tune hue, saturation, and luminance; adjust 
exposure, color levels, brightness and contrast; use Auto Enhance 
to dramatically improve less-than-perfect images with one click; 
even use Curves, Color Balance, Channel Mixer and much more.

Chapter 4 Color in PIxelmator

Chapter 5 Making Color Adjustments



Chapter 4: Color in Pixelmator

Pixelmator features the very easy to use Color Management sheet that you can use to easily assign color pro!les  to 
your images or match your images to color pro!les. Use Apple Color Picker to select colors from anywhere on your 
desktop and then add those to your Swatches palette in Pixelmator.

This chapter explains color and color management in Pixelmator. It also provides an introduction to choosing colors.

This chapter covers:

• Color Model and Depth

• Color Management

• Choosing colors



Color Model and Depth

It’s worth knowing that Pixelmator works in RGB color model and 
can process 8-bit images.

Color Model
Color model describes how colors in images are 
stored and processed. Pixelmator supports 
RGB color model, which means one dot in an 
image is described by three colors - red, 
green and blue. The RGB color model is 
universal since it is used in computer 
displays or for storing digital photos. 
Pixelmator RGB is also optimized to work 
with your Mac’s graphics card.  

Other Color models: Other well-known color models are CMYK, Lab 
and Indexed Colors. Though Pixelmator understands images saved 
using these color models, it will convert them to RGB when opening a 
document.

CMYK Myth: There is a myth that if you want to prepare an image for 
print, you have to work in CMYK color model. That is not true. By being 
a naturally narrow color model for printing devices, CMYK has less 
image editing capabilities and it usually produces a poorer quality.
When working with images for print one should edit them in RGB color 
model and then rely on RGB to CMYK converting software.
Or if an image is being prepared for professional printing, RGB to CMYK 
conversion should be done by specialists.

Bit Depth
Bit depth shows the number of tonal values or shades of a color 
each channel in a pixel is capable of displaying. Increasing the bit 
depth of color channels in an image’s pixels exponentially increases 
the number of colors each pixel can express.

Pixelmator currently supports 8-bit depth images. That is 24 bits of 
information for each pixel or an ability to display almost 17 million 
colors while the human eye is capable of understanding 10 million 
colors. So that is more than enough.

Other Bit Depths: Other bit depths include 16-bit and 32-bit. These 
two depths are usually used by professionals (professional 
photography, medicine, biology, astronomy, movie industry, HDR 
processing).
When opening 16-bit or 32-bit images, Pixelmator will convert them to 
8-bit depth.



Color Management

Pixelmator supports Apple ColorSync technology to maintain a 
consistent color among devices. You can choose a ColorSync pro!le 
for an image so that its colors are matched to your device, or you 
can change your image so that it matches a speci!c ColorSync 
pro!le.

Usually you won’t have to worry about color management at all - 
Pixelmator will do that for you. But if it happens that an image has 
incorrect color management settings or an image is supposed to 
work in another platform, Pixelmator has all the tools you need to 
!x that. 

Assign Pro"le
If you decide to change the color management settings for your 
image, use the Color Management sheet in Pixelmator.

To change the color management settings:

Choose Image > Color Management or use the Shift + Command 
+ K keyboard shortcut.

In a color management sheet, select one of the following options:

• Universal: the Generic RGB pro!le is assigned. It is 
recommended for print, display and sharing.

• Web: sRGB pro!le is assigned - best for Web images.

Color Pro"les: Color pro!les is a small document attached to an image 
that describes how each color in an image should be understood by 
other devices. 
Colors in image editing applications such as Pixelmator are displayed 
after they (colors) are processed through one of the color pro!les. 
Color pro!le is usually attached by a digital camera so it doesn’t need 
to be changed.

• Advanced: you can choose and assign any ColorSync RGB pro!le 
that is available on your Mac. 

• None: no color management for the image will be used. Pro!le is 
not assigned. This setting is not recommended since images 
without pro!les will look di"erent on other devices.

Click OK after you are done.

Please note that you should use these options only if you think that 
the currently assigned pro!le is not appropriate for your image 
since any color pro!le changes could cause dramatic image color 
changes.



Convert Pixels to Selected Pro"le
If you would like to change the color pro!le and at the same time 
keep the resulting colors as close to the original as possible, use the 
Convert pixels to selected pro!le option. It is useful for preparing 
web images.

To convert pixels to a selected pro!le:

Choose Image > Color Management or use the Shift + Command 
+ K shortcut.

In a color management sheet select one of the following options:

• Universal: the generic RGB pro!le is assigned. It is recommended 
for print, display and sharing.

• Web: sRGB pro!le is assigned - best for Web images.

• Advanced: you can choose and assign any ColorSync RGB pro!le 
that is available on your Mac.

• None: no color management for the image will be used. Pro!le is 
not assigned. This setting is not recommended since images 
without a pro!le will look di"erent on other devices.

Select the Convert pixels to selected pro"le checkbox.

Click OK after you are done.



Choosing Colors

You use Mac OS X Colors palette, Scratch palette, Swatches palette 
or the Eyedropper Tool to choose colors for your painting tools, !ll 
and stroke and for some !lters in Pixelmator. 

Choose Colors in the Tools Palette
As you may have noticed already, there are two color boxes in the 
Tools palette. The box that is fully visible contains the foreground 
color while the box behind the foreground color contains 
background color.

Foreground color is used nearly everywhere in Pixelmator: for 
painting, !lling, stroking and more.

Both the foreground and background color are used by some 
!lters.

Foreground Color: 
used for painting, 
!lling, stroking etc..

Background Color: 
used by some 
!lters.

Eyedropper Tool: 
use to select the new 
foreground color 
from the active 
image..

You can select the new foreground or background color using the 
Eyedropper Tool, the Colors palette, or the Swatches and Scratch 
palettes.

To change the foreground or background color, click the 
foreground or background color box in the Tools palette you want 
to change.

Choose Colors With the Eyedropper Tool
The Eyedropper Tool samples color from the active image to 
designate a new foreground or background color.

To choose foreground color with the Eyedropper 
Tool:

Select the Eyedropper Tool.

To select a new foreground color, click in 
the image.

Switch Colors: To switch foreground and background colors, in the 
Tools palette Control + Click or right mouse button click on the color 
box and choose Switch Colors from the color box contextual menu or 
simply press X on your keyboard.

Reset Colors: To reset foreground and background colors to black and 
white, in the Tools palette Control + Click or right mouse button click 
on the color box and choose Reset Colors from the color box 
contextual menu or press D on your keyboard.

Select Background Color: To select a new background color instead 
of foreground color with the Eyedropper tool, Option click in the 
image.



Copy Colors as HEX
You can use the Eyedropper tool to copy color as a hexadecimal or 
HEX color value, which is useful for those who work with web 
images.  You can simply copy the HEX color value and paste it into 
your CSS or HTML code for further editing. To copy the HEX color 
value, Control + Click or right mouse button click in an image with 
the Eyedropper tool selected and choose Copy as HEX from the 
Eyedropper contextual menu.

Adjust the Sample Size of the Eyedropper
You can also change the sample size of the Eyedropper. To do that, 
choose Point Sample, 3 by 3 Average, 5 by 5 Average or 11 by 11 
Average in the sample size pop-up menu in the Eyedropper Tool 
Options palette. You can also change sample size in the Eyedropper 
contextual menu by Control + Clicking or right mouse button 
clicking anywhere on an active image.

Point Sample reads the precise value of the pixel you click while 
Average sample read the average value of the speci!ed number of 
pixels within the area.

Choose Color With the Apple Colors Palette
Pixelmator takes advantage of the default Mac OS X Color palette 
to choose colors. You use Apple Colors palette to select the 
background, foreground or any other item’s color.

To choose colors with the Colors palette:

1. Open the Colors palette by clicking the 
color box in the Tools palette, or choose 
View > Show Colors, or click a color box 
in one of the !lter palettes.

2. Click anywhere in the color wheel. The 
selected color is displayed in the color 
box at the top of the Colors palette.

3. To make the color lighter or darker, drag 
the slider on the right side of the Colors 
palette.

4. To make the color more transparent, 
drag the Opacity slider to the left or enter a percentage value in 
the Opacity !eld.

5. To use the swatches table, open it by dragging the handle at the 
bottom of the Colors palette. Save a color in the swatches table 
by dragging a color from the color box to the swatches table. To 
remove a color from the swatches table, drag a blank square to 
the color you want to remove.

Temporary Switch to Eyedropper Tool: Hold down the Option key to 
temporarily switch to Eyedropper tool while using Pencil, Brush, Paint 
Bucket or Gradient tools.



6. To match the color of another item on the screen, click the search 
icon to the left of the color box in the Colors palette. Click the 
item on the screen whose color you want to match. The color 
appears in the color box. Select the item you want to color in the 
document window, and then drag the color from the color box to 
the item. 

In addition to color wheel, you can also use color sliders  such as 
RGB, Gray, CMYK and HSB; color palettes such as Web Safe Colors, 
Crayons, Developer, Apple; image palettes; and Crayons.

Web Color Plug-In
Pixelmator comes with the Web color plug-in for the Apple Colors 
palette that allows viewing a selected color’s hexadecimal color 
code, which can be copied to the clipboard for later pasting into 
your HTML or CSS editor. 

Web Color plug-in is automatically installed into the Apple Colors 
palette when Pixelmator is launched.

To use the Web Color plug-in:

1. Select any color using the Eyedropper tool, in the Swatches or 
Scratch palette, with the Apple Colors palette, or any other way you 
like.

2. Open the Colors palette, if it is not yet visible, by choosing View > 
Show Colors or by clicking in the color box in the Tools palette.

3. In the Colors palette toolbar, click the Web Colors icon to view the 
hexadecimal color code for your selected color.

4. Edit the color code if you wish, or click the Copy to Clipboard 
button to copy the color code to the clipboard.

5. Paste your hexadecimal color code anywhere you like whether it 
is HTML, CSS editor, or simply notes.



Scratch Palette

Use scratch palette to choose a new foreground color from 
spectrum image.

To select color from the Scratch palette:

1. Choose View > Show Scratch or press Command + 7 on your 
keyboard to show the Scratch palette.

2. Click anywhere on the Scratch palette to choose a new 
foreground color.

Swatches Palette
The Swatches palette in Pixelmator stores colors that you use often. 
You can add or delete colors from the palette.

To show the Swatches palette, do one of the following:

• Choose View > Show Swatches.

• Use the Command + 6 keyboard shortcut.

To select color from the Swatches palette, click on any swatch in the 
Swatches palette to choose a new foreground color.

To add color to the Swatches palette:

1. Select color with the Eyedropper tool or Apple Colors Palette to 
choose the foreground color you would like to add to the 
Swatches palette.

2. Click the plus button in the Swatches palette to add the 
foreground color to the Swatches palette.

To remove color from the Swatches palette:

1. Move your mouse pointer over the color you want to remove in 
the Swatches palette.

2. Click the right mouse button or Control - click so Swatches 
contextual menu will appear and choose Remove Swatch.



Chapter 5: Making Color Adjustments

Pixelmator features a simple and elegant collection of intuitive color correction tools. Using these tools, you can !ne-
tune hue, saturation, and luminance; adjust exposure, color levels, brightness and contrast; use Auto Enhance to 
dramatically improve less-than-perfect images with one click; even use Curves, Color Balance, Channel Mixer and 
much more.

This chapter provides information about applying color adjustments to images, layers or selections in Pixelmator.

This chapter covers:

• Color Adjustment Tools in Pixelmator

• Auto Enhance

• Levels

• Curves

• Color Balance

• Brightness and Contrast

• Hue/Saturation

• Desaturate

• Colorize

• Replace Color

• Channel Mixer

• Exposure

• Invert

• Threshold

• Posterize



Color Adjustment Tools in Pixelmator

Pixelmator features a simple and elegant collection of intuitive color correction tools that help you to improve the appearance of your images, 
selections or layers. You can make color adjustments using the color adjustment tools in the Image menu.



You can make the following adjustments to images, layers or selections in Pixelmator:

Adjustment Description

Auto Enhance The Auto Enhance adjustment analyzes the image, layer or selection and applies an adjustment to it 
based on that analysis.

Levels Adjust shadows, mid-tones, and highlights in the image, selection or layer.

Curves Adjust the entire tonal range, make precise adjustments to individual channels.

Color Balance Change the overall mixture of colors.

Brightness and Contrast Adjust brightness and contrast.

Hue and Saturation Change hue, saturation and lightness.

Desaturate Convert to black and white.

Colorize Create a monotone e"ect.

Replace Color Turn one color into another.

Channel Mixer Create creative color adjustments.

Exposure Adjust the exposure.

Invert Invert the colors.

Threshold Convert colors to high-contrast, black-and-white colors.

Posterize Use posterize to remap red, green, and blue color components to the number of brightness values you 
specify for each color component.



Using the Adjustment Tools
All the color adjustment tools are based in the Image menu in 
Pixelmator. To add any of the color adjustment tools:

Select a layer, or if you wish to add the adjustment to a portion of 
your image, make a selection using the selection tools.

Choose any of the adjustment tools from the Image menu.

Each adjustment contains individual parameters, for which you 
specify a range of values. Use the adjustment controls such as 
sliders or wheels to change parameter values.

After you are done, click OK to accept changes or Cancel to reject 
changes.



Auto Enhance

The Auto Enhance adjustment analyzes the image, layer or 
selection and applies an adjustment to it based on that analysis.

The Auto Enhance usually brightens the photo or adjusts its 
contrast levels based on preset criteria.

Auto Enhance is good for quick image improvements.

Use Auto Enhance
To use the Auto Enhance, choose Image > Auto Enhance.

Since the Auto Enhance edits your image instantly, no palette will 
appear, only Action Tooltip if it is turned on in the Pixelmator 
Preferences window.

Example
On the right is an example of a picture before Auto Enhance was 
added and the same picture after Auto Enhance was added:

Auto Enhance Engine: The Pixelmator’s Auto Enhance uses a 
sophisticated formula to analyze and apply adjustments based on that 
analysis. The formula includes converting image to Lab color space 
and adjusting lightness and, if necessary, color channels.

Before Auto Enhance adjustment

After Auto Enhance adjustment



Levels

Use Levels to set the tonal values of shadows, midtones, and 
highlights in an image, selection or layer. It is useful for adjusting 
the brightness of an image and color correction.

To adjust levels in an image:

1. Choose Image > Levels or press the Shift  + L keyboard shortcut 
so the Levels palette appears.

2. Drag the Black Levels and White Levels sliders to where they 
touch the outside of the histogram. This will result in more 
de!ned blacks and highlight values as well as increase overall 
contrast.

3. Drag the Midtone Levels slider to adjust the brightness values of 
the midtone while limiting the brightening e"ect in the black and 
white points.

4. Click OK or Cancel to accept or reject changes.

Black Levels Slider: drag 
to set the shadows.

White Levels Slider: drag 
to set the highlights.

Histogram
As you may have noticed already, the Levels tool includes a 
histogram. A histogram is a graph that displays relative brightness 

in an image, from pure black to pure white. 

The area under the graph represents all the pixels in the image. 
From left to right, the histogram describes the range of shadows 
(dark pixels), midtones (gray pixels), and highlights (bright pixels) in 
the image. The shape of the histogram depends on the tonality of 
the scene and the exposure. Histogram is a good way to evaluate 
exposure although it does not work for all images. 

Sometimes a series of peaks on the left, the darker side of the 
histogram, indicates an underexposed image that consists mainly 
of dark pixels.

In some cases, a series of peaks in the center of the histogram 
indicates a balanced exposure since a majority of the pixels are 
concentrated within the midtones of the histogram.

Grey Levels Slider: drag to set the midtones.

Histogram: a 
graph that 
displays relative 
brightness in an 
image..



An overexposed image will usually have a series of peaks on the 
brighter, right side of the histogram.

However, for some images, such as images shot at night or images 
of snow, interpreting the histogram to evaluate exposure is not an 
option since those naturally have a di"erent histogram that is 
correct.

Example
Below is an example of Levels in action.

Before Levels adjustment After Levels adjustment



Curves

Use Curves to adjust the entire tonal range of an image. Also use 
Curves to make precise adjustments to individual color channels in 
an image.

To use the Curves tool:

Choose Image > Curves... or use the Shift + K keyboard shortcut.

3. Adjust a curve by adding and moving points and adjusting the 
shape of the curve.

Add a point by clicking directly on the curve. Remove a point by 
Command +  clicking on the curve point. To adjust the shape of the 
curve, click a point and drag the curve until the tone and color look 
correct.

To adjust the color balance of the image, select the channel by 
clicking on its icon at the top of the curves palette. RGB will edit all 
three channels while R will edit the red channel, G the green and B 
the blue.

Shadows

Highlights

Midtones

The horizontal axis in the Curves dialog box represents the current 
values of the pixels in an image or a selected part of an image. The 

vertical axis represents the tonal values after the curve is applied. 
The default curve is a straight line with an angle of 45 degrees. For 
each pixel, the input value is the same as the output value.

Changes in the position of the lower left will a"ect the dark values 
in your image. Changes to the center will a"ect the middle values 
most, and changes in the upper right will a"ect the lightest values 
in your image.

Point: 
adjust 
curve by 
adding 
points.

Point



About Histograms: The area under the graph represents all the pixels 
in the image. From left to right, the histogram describes the range of 
shadows (dark pixels), midtones (gray pixels), and highlights (bright 
pixels) in the image. The shape of the histogram depends on the 
tonality of the scene and the exposure. Using a histogram is a good 
way to evaluate exposure, but it does not work for all images. 

Special E!ects: You can use the Curves tool to add interesting color 
e"ects to your image. 

Example
Below is an example of Curves in action.

Before Curves adjustment After Curves adjustment

 



Color Balance

Use the Color Balance tool to change the overall mixture of colors 
in an image for color correction.

To use Color Balance:

1. Choose Image > Color Balance... or press the Command + B 
keyboard shortcut.

2. Select the tonal range that you want to edit whether it is 
shadows, midtones or highlights.

3. Drag the sliders to adjust the color balance, adding to one color 
while subtracting from another. The color sliders are Cyan, Red, 
Magenta and Green, and Yellow and Blue.

Example
On the right is an example of a picture before Color Balance was 
added and the same picture after Color Balance was added:

Preserved Luminosity: When using Color Balance tool, the luminosity 
is always preserved to maintain the tonal balance in the image. 

Before Color Balance adjustment

After Color Balance adjustment



Brightness and Contrast

Use the Brightness and Contrast tool in Pixelmator to adjust 
brightness and contrast in an image. The Brightness and Contrast 
tool makes simple adjustments to the tonal range of an image.

To use Brightness and Contrast:

Choose Image > Brightness and Contrast....

Drag the sliders to adjust the brightness and contrast.

Example
On the right is an example of a picture before Brightness and 
Contrast was added and the same picture after Brightness and 
Contrast was added:

Before Brightness and Contrast adjustment

After Brightness and Contrast adjustment



Hue and Saturation

Use the Hue and Saturation tool to adjust the hue, saturation, and 
lightness of a speci!c color in an image or all colors in an image. 
Hue and Saturation is mainly used for image color correction.

To use the Hue and Saturation tool:

1. Choose Image > Hue and Saturation.... or press the Command + 
U keyboard shortcut.

2. Choose which color to adjust in the colors tab. The Hue and 
Saturation tool can either be applied to the whole image or a 
restricted palette, such as only the red tones. To adjust the whole 
image, leave the first tab selected. To adjust a particular tone, for 
instance the reds, select the red tab.

3. For Hue, do one of the following:

• To shift the colors of the entire image, spin the dots around the 
color wheel.

• To shift a particular color, select its tab at the top. Further, 
adjusting the handles tightens or loosens the color tones.

4. To adjust the Saturation, drag the slider to the right to increase 
the saturation or to the left to decrease it.

5. Drag the Lightness slider to the right to increase lightness or the 
left to decrease lightness.

Adjust the Range of Colors
To specify what range of colors to adjust with the Hue and 
Saturation tool, in the Hue and Saturation palette choose a color 
from the colors tab and spin the range dots around the color wheel.  
The more saturated area on the color wheel is included in the 
editable range of colors, while the desaturated area of the color 
wheel is not included and will not be edited.



Example
Below is an example of Hue and Saturation in action.

Before Hue and Saturation adjustment After Hue and Saturation adjustment



Desaturate

Use the Desaturate command to convert your image, selection or layer to a black and white image.

To convert your image to grayscale, do one of the following:

• Choose Image > Desaturate.

• Use the Option + Command + U.

Example
Below is an example of Desaturate in action.

Before Desaturate adjustment After Desaturate adjustment

 

Note: Desaturate command has exactly the same e"ect as setting the 
Saturation in the Hue and Saturation tool to - 100. 



Colorize

Use the Colorize adjustment to colorize an image for a monotone 
e"ect.

To use Colorize adjustment:

1. Choose Image > Colorize....

2. Spin the dot around the color wheel to choose whichever color 
you want your image to turn into.

3. Drag the saturation slider to adjust the level of saturation.

4. Moving the slider will adjust the lightness of the pixels. 

Lightness control is crucial when you need to colorize black or 
white pixels. Since black and white cannot hold any shades of color, 
the lightness slider needs to be adjusted to bring in color.

Example
On the right is an example of a picture before Colorize was added 
and the same picture after Colorize was added:

Before Colorize adjustment

After Colorize adjustment



Replace Color

Use Replace Color adjustment to turn any selected color to another.

To use Replace Color:

1. Choose Image > Replace Color....

2. Select the color you want to replace by doing any of the 
following:

• Click the color box in the Replace Color palette. The Mac OS X 
Color Picker appears and you choose which color you want to 
replace. By default, the color box will feature the foreground 
color selected in your Pixelmator toolbox.

• Move your mouse cursor on an image for an Eyedropper cursor 
to appear and click any color in an image that you would like to 
replace.

3. Adjust the radius slider. The radius lets you specify how wide the 
colors can extend from the base color selected above. A narrow 
radius will switch only a limited palette, while a high radius will 
replace more color variants.

A unique feature of the radius control is that while adjusting it will 
show you a preview of range of colors that are to be a"ected by 
Replace Color tool. Portions of an image that appear white in a 
preview are in the a"ected range, while the black pixels are not 
going to be touched by any changes.

4. Spin the dots around the color wheel to get your desired color 
change.



5. Use the Saturation and Lightness sliders to adjust the saturation 
and lightness of the pixels.

Example 
Below is an example of Replace Color in action.

Before Replace adjustment After Replace adjustment

 



Channel Mixer

Use Channel Mixer adjustment to create sepia tone or other tinted 
images or creative color adjustments by mixing color channels.

To use the Channel Mixer tool:

1. Choose Image > Channel Mixer....

2. In the Channel Mixer palette, select the color channel in which to 
blend one or more existing channels.

3. To decrease the channel’s contribution to the output channel, 
drag a source slider to the left; to increase it drag to the right.

Example
On the right is an example of a picture before Channel Mixer was 
added and the same picture after Channel Mixer was added:

Before Channel Mixer adjustment

After Channel Mixer adjustment



Exposure

Use Exposure adjustment to adjust the exposure setting for tonal 
range of an image. 

To use the Exposure tool:

1. Choose Image > Exposure....

2. Drag the exposure slider to the right to increase exposure or drag  
it to the left to decrease it.

Example
On the right is an example of a picture before Exposure was added 
and the same picture after Exposure was added:

Before Exposure adjustment

After Exposure adjustment



Invert

Use Invert to invert colors in an image.

To invert colors:

1. Choose Image > Invert or press Command + I. 

Example
On the right is an example of a picture before Invert was added and 
the same picture after Invert was added:

Before Invert adjustment

After Invert adjustment



Threshold

Use Threshold adjustment to convert image, selection or layer to 
high-contrast, black-and-white pixels.

To use the Threshold tool:

1. Choose Image > Threshold....

2. Drag the slider to set the threshold level you want, and click OK.

Example
On the right is an example of a picture before Threshold was added 
and the same picture after Threshold was added:

Before Threshold adjustment

After Threshold adjustment



 Posterize

Use Posterize adjustment to remap red, green, and blue color 
components to the number of brightness values you specify for 
each color component.

To use the Posterize tool:

1. Choose Image > Posterize....

2. Drag the slider to specify the number of tonal levels.

Example
On the right is an example of a picture before Posterize was added 
and the same picture after Posterize was added:

Before Posterize adjustment

After Posterize adjustment



Grunge Artwork - Created by Saulius Dailide



Part III: Selecting

With Pixelmator’s powerful, pixel-accurate collection of selection 
tools, you can quickly and easily select any part of your images. 
That means you can edit and apply special e"ects to portions of 
your pictures, remove unwanted objects, or even cut out objects 
from one picture to put on another.

Chapter 6 Making Selections

Chapter 7 Adjusting Selections

Chapter 8 Working With Selected Pixels



Chapter 6: Making Selections

Someone who is editing images must be able to select the right shapes, portions or objects in images. With 
Pixelmator’s powerful, pixel-accurate collection of selection tools you can quickly and easily select any part of your 
images.

This chapter provides information about selection tools in Pixelmator.

This chapter covers:

• Selecting

• Selection Tools



Selecting

Selecting is a very important part of image editing since you can 
select any part of your images and edit that part by applying color 
adjustments, special e"ects and !lters, !ll, stroke, transform, move, 
delete, duplicate or copy and paste the selected part as a new layer 
to other images.

Selection isolates selected parts of your image and after they are 
edited unselected areas are left untouched.

Selection tools in Pixelmator include:

Move Use to move layers and 
selected pixels.

Rectangular Marquee Use to select rectangles.

Elliptical Marquee Use to make elliptical 
selections.

Lasso Use to make freehand 
selections.

Polygonal Lasso Use to draw straight-edged 
selections.

Magic Wand Use to select similarly 
colored areas.

You can also use commands in the Edit menu to select all pixels, to 
deselect, reselect, invert, cut, copy or to select a range of colors 
within an entire image or even load selections from layers.

For easier and more precise selecting, a Quick Mask editing mode is 
available in Pixelmator that allows you to temporarily show your 
selection as a colored overlay and use any of the painting tools or 
!lters to modify it.

The Re!ne Selection option helps you to enhance your selections 
by modifying its smoothness, feathered aspects and size.



Selection Tools

Pixelmator has every tool you need to easily make a precise 
selection. Selection tools in Pixelmator include Rectangular 
Marquee, Elliptical Marquee, Lasso, Polygonal Lasso and Magic 
Wand. In addition, you can use menu bar commands such as Select 
All, Deselect, Reselect and Select Color.

Select All
To select all pixels on a layer within the canvas boundaries, do one 
of the following:

• Choose Edit > Select All or use the Command + A keyboard 
shortcut.

• If any of the selection tools is selected in the Tools palette right 
mouse button click or Control click anywhere on an image and 
choose Select All from the contextual menu.

Deselect
To deselect selections, do one of the following:

• Choose Edit > Deselect.

• Press Command + D on your keyboard.

• Click anywhere in the image outside the selected area using any 
of the selection tools.

• Control - click or right mouse button click anywhere in the image 
using any of the selection tools and choose Deselect from the 
selection tools contextual menu.

Reselect
To reselect the most recent selection, do one of the following:

• Choose Edit > Reselect.

• Press Shift + Command + D on your keyboard.

• If any of the selection tools is selected in the Tools palette, right 
mouse button click or Control click anywhere on an image and 
choose Select All from the contextual menu.

Select Color
The Select Color tool allows you to select a speci!ed color or a 
range of colors in an image. To use the Select Color tool:

1. Choose Edit > Select Color....

2. Choose the color you would like to select by clicking on the 
Color swatch button and using the Colors palette to choose.



3. Select preferred color range with the radius slider. While 
moving, any pixels that show white are in the selection, while 
the black pixels will not be added into the selection.

Tip: You can also point your mouse cursor on an image so that an 
Eyedropper tool will appear. Use the Eyedropper to quickly select 
color you want by clicking on the image.

4. Click the OK button to accept changes, Cancel to reject 
changes or the Reset button to revert to the original selection.

Rectangular Marquee and Elliptical Marquee Tools
The Rectangular Marquee Tool lets you select rectangles while the 
Elliptical Marquee Tool lets you make elliptical selections. Both tools 
work in a similar way:

Tip: You may use the Select Color tool to select a speci!ed color not 
only within an entire image but also within an existing selection. Make 
a selection using any of the selection tools and then use the Select 
Color tool to select color range within an existing selection.



1. Select a Marquee Tool in the Tools palette. Press the M key for 
Rectangular Marquee and press the Y key for Elliptical 
Marquee.

2. Choose a selection mode in the Tool Options palette:

New Draw a new selection.

Add To Add to the border of an existing 
selection.

Subtract From Subtract from the border of an existing 
selection

3. If selecting with the Elliptical Marquee Tool, check the Anti-alias 
setting for smoothing the edges of a selection. For jagged but 
precise edges, uncheck the Anti-alias checkbox.

4. Drag over the area you want to select.

Lasso Tool
Lasso Tool lets you make freehand selections. To use 
the Lasso tool:

1. Select the Lasso Tool in the Tools palette or 
press L on your keyboard.

2. Choose a selection mode in the Lasso Tool 
Options palette:

New Draw a new selection.

Add To Add to the border of an existing 
selection.

Subtract From Subtract from the border of an existing 
selection

3. Check the Anti-alias setting for smoothing the edges of a 
selection. For jagged but precise edges, uncheck the Anti-alias 
checkbox.

4. Drag to draw a freehand selection.

Tip: To select a square using the Rectangular Marquee Tool or to select 
a circle using the Elliptical Marquee Tool, hold down Shift as you drag.

To draw a selection from its center, hold down the Option key after you 
begin dragging.



Polygonal Lasso Tool
The Polygonal Lasso Tool lets you make straight-edged selections. 
To use the Polygonal Lasso Tool:

1. Select the Lasso Tool in the Tools palette 
(or press L on your keyboard) and 
choose Polygonal tool type in the Tool 
Options palette (or press the L key again).

2. Choose a selection mode in the Lasso Tool 
Options palette:

New Draw a new selection.

Add To Add to the border of an existing 
selection.

Subtract From Subtract from the border of an existing 
selection

3. Check the Anti-alias setting for smoother edges of a selection. 
For jagged, but precise edges, uncheck the Anti-alias checkbox.

4. Click in the image to set the starting point.

5. Continue clicking in the image to set endpoints.

6. Once you are done, close the selection by doing one of the 
following:

• Position the Polygonal Lasso pointer over the starting point and 
click on it.

• Double-click the Polygonal Lasso pointer anywhere on an image. 

• Press the Return key on your keyboard.

To cancel drawing the selection using the Polygonal Lasso Tool, 
press the Escape key on your keyboard.



Magic Wand Tool
Use the Magic Wand Tool to select similarly colored areas. To use 
the Magic Wand:

1. Select the Magic Wand Tool in the Tools 
palette or press the W key.

2. Choose a selection mode in the Magic Wand 
Tool Options palette:

New Draw a new selection.

Add To Add to the border of an existing 
selection.

Subtract From Subtract from the border of an existing 
selection

3. Check the Sample All Layers checkbox if you want to make a 
selection from all visible layers. With Sample All Layers 
unchecked, it will only make a selection from the currently 
selected layer.

4. Check the Anti-alias setting for smoothing the edges of a 
selection. For jagged but precise edges, uncheck the Anti-alias 
checkbox.

5. Click the color you want to select in an image and slowly drag 
over it. As you drag, the colored area (selection) grows to 
include the contiguous area that uses similar colors. You can 

Tip: To temporarily switch from the Polygonal Lasso Tool to the Lasso 
Tool, press Option key on your keyboard when making a selection with 
the Polygonal Lasso Tool.

control how much of the image is selected by dragging less or 
more.

6. Release your mouse after you are done, and the colored area will 
change to selection.



Chapter 7: Adjusting Selections

Pixelmator allows you to easily enhance your selections simply by moving, inverting, transforming, adding to or 
subtracting from them or using the Re!ne Selection Tool. In addition, for more precision, selections can be edited in 
the Quick Mask mode.

This chapter provides information about selection tools in Pixelmator.

This chapter covers:

• Enhancing Selections

• Using Quick Mask Mode



Enhancing Selections

Once you have made a selection, you can improve it by moving, 
inverting, adding to the selection or subtracting from the selection. 
You can also use the Re!ne Selection tool to quickly smooth, 
feather and change the size of the selection. For more precise 
selecting, you can use the Quick Mask mode.

Move a Selection Border
To move a selection border, position the pointer of the selected 
selection tool inside the selection border and drag to move the 
border.

To move the selected pixels use the Move tool.

Tip: To move the selection by 1 pixel, use the arrow keys on your 
keyboard. To move the selection by 10 pixels, hold down the Shift key 
and use the arrow keys. Invert Selection

To invert the selection, do one of the following:

• Choose Edit > Inverse.

• Control - click or right mouse button click anywhere in the image 
using any of the selection tools and choose Inverse from the 
selection tools contextual menu.

• Press Shift + Command + I on your keyboard.

Tip: Inverting a selection is very useful when cutting out objects 
that are placed on a solid color background. Select the background 
using the Magic Wand Tool or Select Color tool and invert the 
selection. Then you can copy or cut your object. 
There is also a Magic Eraser tool that can help you remove solid 
color background instantly by just clicking and dragging on it.



Add to Selection
To add to a selection using any of the selection tools, do one of the 
following:

• Hold down the Shift key and drag to add to the selection.

• Choose the Add To selection mode in the Tool Options palette 
and then drag to add to the selection.

Add To

Notice that a plus sign appears next to the mouse cursor so you 
always know what the current selection mode is.

Subtract from Selection
To subtract from a selection using any of the selection tools, do one 
of the following:

• Hold down the Option key and drag to subtract another 
selection.

• Choose the Subtract From selection mode in the Tool Options 
palette and then drag to intersect with another selection.

Notice that the minus sign appears next to the mouse cursor so you 
know what the current selection mode is.

Subtract From

Transform Selection

In addition to moving, inverting, adding to or subtracting from a 
selection border, you can also apply transformations to your 
selection. To transform a selection:

1. Make a selection.

2. Control + click or right mouse button click using any of the 
selection tools anywhere in an image and choose Transform 
Selection from the selection tools contextual menu.



3. Scale and rotate your selection using the Transform controls. For 
more information about Transforming, see Chapter 19 in this 
manual.



Re"ne Selection
Use the Re!ne Selection tool to make a smoother outline, to soften 
edges of a selection or even change the size of a selection. To use 
the Re!ne Selection:

1. Make a selection using any of the selection tools.

2. Choose Edit > Re!ne Selection... or use the Option + Command 
+ R keyboard shortcut.

3. Adjust the Smooth slider to create a smoother outline, adjust the 
Feather slider to soften the edges of a selection, and if needed, 
adjust the Size slider to shrink or enlarge your selection edges.

Note: The preview that you see when using the Re!ne Selection tool is 
in a Quick Mask mode; red overlay area is not included within your 
selection while the clearly seen area is in your selection. Quick Mask 
mode helps you to better see how smooth the edges of your selection 
are.



Quick Mask Mode

The Quick Mask mode in Pixelmator allows making precise 
adjustments to selections. In the Quick Mask mode selection is 
converted to a temporary mask for easier editing. The Quick Mask 
appears as a red colored overlay and can be edited using any of the 
tools available in Pixelmator. For example, you can feather your 
selection by adding Gaussian Blur to selection in the Quick Mask 
mode.

Using the Quick Mask Mode

To use the Quick Mask mode to edit part of the image:

1. Use any of the selection tools to select the part of your image you 
would like to edit.

2. Click the Quick Mask mode button in the Tools palette, choose 
Edit > Edit in Quick Mask Mode,  or press Q on your keyboard. A 
red overlay appears which protects the area outside the 
selection.

3. Use any of the painting tools, selection tools or  !lters to modify 
that colored overlay.

4. Click the Normal mode button in the Tools palette to quit the 
Quick Mask mode and see your selection. You can now make any 
further adjustments to your image.

Note: Painting in black in Quick Mask mode will deselect painted areas 
while painting in white will select more of an image. Painting with 
other colors in Quick Mask mode will create a semitransparent areas 
which are useful for feathering the selection.
Semitransparent areas may not be visible once you exit the Quick Mask 
mode, but they are available.



Chapter 8: Working with Selected Pixels

After a selection is ready, you can easily move it’s contents, duplicate or copy it to add it to another image and delete it.

This chapter provides information about selection tools in Pixelmator.

This chapter covers:

• Moving, Copying and Deleting Selected Areas



Moving, Copying and Deleting Selected Areas

Once you have made a selection, you can move, copy, delete, 
extract, add !lters or adjust color of the area that is in the selection.

Moving Selected Areas
To move a selected area:

1. Select the Move Tool or press V on your keyboard.

2. Move the mouse pointer inside the selection border and drag the 
selection area to a new position.

Copying and Pasting Selected Areas
Use the Copy and Paste commands to copy selected areas to other 
Pixelmator documents or even other applications. 

To copy a selected area:

1. Select the area you want to copy using any of the selection tools.

2. Choose Edit > Copy or use the Command + C keyboard shortcut.

To paste copied area as a new layer:

• Choose Edit > Paste.

• Use the Command + V keyboard shortcut.

Deleting Selected Areas
You can use any of the selection tools to select objects in your 
images that you want to delete or cut.

To cut the selected are from the image:

• Choose Edit > Cut.

Copy a selection while dragging: To copy a selected area while 
dragging it, hold down the Option key and drag. 

Copy between applications: You can use Copy, Cut, or Paste 
commands to copy selected areas from Pixelmator images and paste 
them into other applications (i.e. to Apple Keynote, Pages etc.).



To delete the selected area from an image, do one of the following:

• Choose Edit > Clear.

• Press the Delete key on your keyboard

• Press the Backspace key on your keyboard
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Part IV: Painting and Retouching

Painting tools in Pixelmator o"er you the ability to use di"erent 
brush sizes, shapes, advanced settings, and blending modes 
when painting. You can paint with Pixelmator as you would 
traditionally, play with beautiful gradients, or !ll colors with other 
ones. With its advanced retouching tools, you can easily blur hard 
edges or sharpen fuzzy areas of your image. Or you can paint 
with a sample of an image to remove wrinkles from faces or 
scratches in your photos.

Chapter 9 Painting Tools

Chapter 10 Retouching Tools

Chapter 11 Brushes

Chapter 12 Blending Modes



Chapter 9: Painting Tools

Painting tools in Pixelmator o"er you the ability to use di"erent brush sizes, shapes, advanced brush settings, and 
blending modes when painting. You can paint with Pixelmator as you would traditionally, play with beautiful gradients 
or !ll colors with other ones. 

This chapter provides information about selection tools in Pixelmator.

This chapter covers:

• Pencil and Brush Tools

• Eraser Tool

• Paint Bucket Tool

• Gradient Tool

• Fill and Stroke



Pencil and Brush Tools

The Pencil and Brush tools work just like traditional drawing tools. 
The di"erence between the Pencil and Brush is that the Brush tool 
creates soft strokes of colors while the Pencil tool creates hard-
edged lines.

Paint with the Brush or Pencil Tools
To paint with the Brush tool or Pencil tool:

1. Choose a foreground color. (For more info about choosing colors, 
see Chapter 4.)

2. Select the Brush tool (B) to paint soft 
strokes or the Pencil tool (P) to 
paint hard-edged ones.

3. Choose Brush presets from 
the Brushes palette. (For more 
info about the Brush presets and Brushes palette, see Chapter 11.)

4. Set Blending Mode and Opacity for your tool in the Tool Options 
palette. (For more information about the blending modes, see 
Chapter 12.) Using the Opacity setting in the Tool Options 
palette, you can set the transparency of the color you apply. 
Opacity of 100% is opaque. To set other percentages of opacity, 
adjust the opacity slider in the Pencil or Brush Tool Options 
palette. (For more information about the Blending Modes see 
Chapter 12.)

5. Drag in an image to paint.

Draw a straight line: To  draw a straight line, click a starting point in 
the image; then Shift click an ending point.

You can also drag in an image with the Shift key pressed to draw a 
straight line.



Eraser Tool

The Eraser tool works just like a traditional drawing tool. Use Eraser 
tool to erase your images to transparency.

Erase with the Eraser Tool
To erase to transparency with the Eraser tool:

1. Select the Eraser tool (E).

2. Choose a Brush preset from the Brushes 
palette. (For more info about the Brush 
presets and Brushes palette, see Chapter 
11.)

3. Set Eraser Opacity in the Tool Options palette by 
adjusting the Opacity slider. With opacity set at 100%, Eraser tool 
will erase completely.

4. Choose a mode for the Eraser tool. Brush mode will erase using 
brush strokes, while Pencil tool mode will erase with hard-edged 
strokes.

5. Drag an area in the image you want to erase.

Eraser’s Tool Options palette allows choosing the type of the tool: 
Eraser or Magic Eraser. Magic Eraser tool is di"erent from the Eraser 
tool and is explained in later chapters in this manual.

Erase a straight line: To erase a straight line, click a starting point in 
the image, then Shift click an ending point.

You can also drag in an image with the Shift key pressed to erase a 
straight line.

 



Paint Bucket Tool

Use the Paint Bucket tool to !ll an area with color.

Fill with the Paint Bucket Tool
To !ll using the Paint Bucket tool:

1. Select the Paint Bucket tool (N).

2. Choose a foreground color since Paint 
Bucket !lls using that color.

3. Set Blending Mode and Opacity for the 
tool in the Tool Options palette. (For 
more information about the blending 
modes see Chapter 12.) Set the Opacity 
in the Tool Options palette by adjusting the Opacity slider. With 
opacity set at 100%, Eraser tool will erase completely.

4. Check the Anti-alias checkbox in the Tool Options palette so that 
edges of the !ll area are smooth. If the checkbox is unchecked, 
there will be hard edges around the !ll area.

5. Click the color in the image you want to !ll and then slowly drag 
over it. As you drag, the !lled area grows to include the 
contiguous area that has similar colors. You can control how 
much of the image is !lled by dragging less or more.

Paint Bucket contextual menu: Control - click or right mouse button 
click anywhere on an image and the Paint Bucket contextual menu will 
appear. You can use the contextual menu to quickly set the blending 
mode for Paint Bucket.

You can also use the Fill command to !ll layers or selections. The Fill 
command is described later in this chapter. 

 

Temporarily switch to Eyedropper: You may want to temporarily 
switch to Eyedropper in order to to choose color for Paint Bucket 
quickly. To do that, simply press the Option key on your keyboard 
when Paint Bucket tool is selected. The Option key will also allow a 
switch to Eyedropper if Pencil, Brush, or Gradient tools are selected.



Gradient Tool

Use the Gradient Tool to !ll an entire layer or selection with 
multiple colors that have a gradual blend between them.

Fill with the Gradient Tool
To !ll with the Gradient tool:

1. Select the Gradient tool (G).

2. Pick a gradient preset in the Gradients palette or 
create your own. (For more information about 
how to create your own, see Manage Gradient 
Presets later in this chapter.)

3. Set Blending mode and Opacity in the Gradient Tool Options 
palette.

4. Position the pointer on an image where you want to set a starting 
point and click to set the starting point of the gradient.

5. Position the pointer and click on an image again to de!ne the 
ending point.

Tip: The Gradient tool icon in the Tools palette always shows which 
gradient preset is currently selected in the Gradients Palette.

Constrain gradient line angle every 45˚: Hold down the Shift key as 
you set the ending point of gradient to constrain its line angle to a 
multiple 45˚.



Manage Gradient Presets
You add, remove and edit gradients and gradient presets using the 
Gradient Palette in Pixelmator. Gradient palette keeps gradient 
presets that you use often.

Create New Gradient
To create a new gradient:

1. Show the Gradients palette by choosing View > Show Gradients.

2. Click the plus button in the Gradients palette or right mouse 
button click on a Gradients palette and choose New Gradient. A 
Gradient Editor sheet appears.

3. Choose the gradient type:

• Linear gradient blends colors between color stops all along a line.

• Radial gradient blends from start to end in a circular pattern.

• Sweep gradient blends colors in a sweep. 

The way in which your gradient is displayed in the well will depend 
on the gradient type selected.

4. Color Stops represent your color settings along a spectrum that 
you create. A gradient will always have at least 2 colors. You can 
vary your gradient by adding or removing stops, adjusting their 
position, and setting the color of each:

• Quickly available with the Right Mouse (or Control-Left Mouse 
click), contextual menu allows you to insert, reverse, copy and 
paste color stops.

5. Click any of the color stops to !ne tune its color with the Apple 
Color palette or set the opacity level.

6. Click OK to save your new gradient.

Edit Gradient
To edit  a gradient that is in the Gradients palette, do one of the 
following:

• Double-click the gradient you would like to edit in the Gradients 
palette and a gradient editor will appear.

•  Move your mouse pointer over the gradient in the Gradients 
palette you would like to edit and Control - click on it or right 
mouse button click so the gradient contextual menu will appear. 
Choose Edit Gradient... from the gradient contextual menu.

Remove Gradient

To remove a gradient from the Gradients palette:

Move your mouse pointer over the gradient you would like to 
remove and control-click it or right mouse button click and choose 
Remove Gradient from the gradient contextual menu.

Tip: Quick color selection for the color stop is available with the 
Right Mouse Button (or Control-Left Mouse click). Press the Option 
key quick color selection to switch to the Web Safe Color Palette.

Gradient type: this 
is where you select 
the gradient type.

Gradient preview

Color stops: this is 
where you edit a 
gradient.



Fill and Stroke

Use the Fill command in Pixelmator to !ll the inside of a selection or 
layer with a color or Stroke command to paint a colored border 
around a selection or layer.

Fill
To !ll a layer or selection with color:

1. Choose Edit > Fill... or press Option + Command + F on your 
keyboard.

2. In the Fill palette, choose the color you would like to !ll with. By 
default it will use the foreground color.

Fill Quickly: Press the Shift + Backspace keyboard shortcut to 
quickly  !ll the selected layer or selection. The command will use the 
currently selected foreground color and recently used Fill settings to 
!ll.

3. Specify the blending mode and opacity for the !ll.

4. Check the preserve transparency checkbox to !ll only those areas 
containing pixels.

5. Click OK to apply the !ll.

Paint Bucket: Use the Paint Bucket tool to !ll the similarly colored area 
in your image by clicking and dragging. As you drag, the !lled area 
grows to include the contiguous area that uses similar colors. You can 
control how much of the image is !lled by dragging less or more.



Stroke
To stroke a selection or layer with color:

Choose Edit > Stroke... or use the Shift + Command + O keyboard 
shortcut.

6. In the Stroke palette that appears, choose the color you would 
like to stroke with. It will use the foreground color by default.

7. Specify whether to place the border inside, outside or centered 
over the selection or layer boundaries.

8. Specify opacity and blending mode.

9. Check the preserve transparency checkbox to stroke only those 
areas containing pixels.

10.Click OK to apply the stroke.



Chapter 10: Retouching Tools

With Pixelmator’s advanced retouching tools, you can easily blur hard edges or sharpen fuzzy areas of your image. Or 
paint with a sample of an image to remove wrinkles from faces or scratches in your photos.

This chapter provides information about selection tools in Pixelmator.

This chapter covers:

• Clone Stamp Tool

• Blur Tool

• Sharpen Tool

• Magic Eraser Tool



Clone Stamp Tool

Use the Clone Stamp tool to paint with a sample of an image. It is 
useful for duplicating objects or removing defects in images.

To paint with the Clone Stamp tool:

1. Select Clone Stamp tool (S) in the Tools 
palette.

2. Choose Brush preset from the 
Brushes palette. (For more info about 
the Brush presets and Brushes 
palette, see Chapter 11.)

3. Move your mouse pointer over an image area and click to de!ne 
the clone source. To change the clone source point, press the 
Option key and click another area you would like to set as the 
clone source.

4. Set Blending Mode and Opacity for the tool in the Tool Options 
palette. (For more information about the blending modes, see 
Chapter 12). Using the Opacity setting in the Tool Options 
palette, you can set the transparency of the color you apply. 
Opacity of 100% is opaque. To set an other percentage of opacity, 
adjust the opacity slider in the Pencil or Brush Tool Options 
palette.

5. Check the Sample All Layers checkbox in the Tool Options palette 
to include all layers as a clone source. Otherwise it will paint with 
the currently selected layer as the only source.

6. Drag in an image to paint.



Blur Tool

Use the Blur tool to blur image areas.

To use the Blur tool:

1. Select Blur tool (R) in the Tools palette.

2. Choose Brush preset from the Brushes 
palette. (For more info about the 
Brush presets and Brushes palette, 
see Chapter 11.)

3. Select blur strength in the Tool 
Options palette.

4. Drag over the part of the image to blur.

Tip: Use the Gaussian Blur !lter (Filter > Blur > Gaussian Blur...) to blur 
the whole layer or selection.
There are some more special blur !lters such as motion, zoom or box 
available in Filter > Blur menu. 



Sharpen Tool

Use the Sharpen tool to sharpen soft image areas.

To use the Sharpen tool:

1. Select Sharpen tool (O) in the Tools palette.

2. Choose Brush preset from the Brushes 
palette. (For more info about the Brush 
presets and Brushes palette, see Chapter 
11.)

3. Select sharpen strength in the Tool 
Options palette.

4. Drag over the part of the image to sharpen.

Tip: Use the Sharpen Luminance or Unsharp Mask !lters (Filter > 
Sharpen) to sharpen the layers or selections.



Magic Eraser Tool

Use the Magic Eraser tool to remove certain colors in an image until 
it is transparent. It is useful for removing unwanted background or 
other colors. It is also useful for extracting objects that are 
photographed on a single color background.

To remove unwanted color in an image:

1. Select the Magic Eraser Tool or press E twice 
on your keyboard. (A single press will bring 
up the Eraser while pressing again will 
cause a switch between Eraser and Magic 
Eraser tools.)

2. Set the Opacity in the Tool Options palette of 
the Magic Eraser tool.

3. Click the color you want to make transparent and then slowly 
drag over it. As you drag, the selection grows to include the 
contiguous area that uses similar colors. You can control how 
much of the image is deleted to transparency by dragging less or 
more.

Tip: The same result as using Magic Eraser tool can be achieved by 
using the Magic Wand tool to select the area and deleting that 
selected area.  However, using the Magic Eraser tool is much faster.

Tip: You’ll get the best results removing solid colors with clear 
boundaries. To remove areas that are less distinct, select a smaller area 
and repeat the process.



Chapter 11: Brushes

Brushes are the key to painting. Pixelmator features an impressive collection of brushes and gives you the ability to 
create your own brushes with advanced settings. In addition to sharing your brushes with other Pixelmator users, you 
can also import Adobe Photoshop brushes.

This chapter provides information about brushes in Pixelmator.

This chapter covers:

• Brush Presets

• Managing Brush Presets

• Sharing Brushes



Brush Presets

A brush preset is a brush tip with size, shape, hardness and jitter 
settings. All the painting tools in Pixelmator use the brush presets 
for painting. You can create new, modify, save and share your brush 
presets as well as your brushes collections. You manage your brush 
presets and brushes collections in the Brushes palette in Pixelmator.

Pixelmator comes with seven brushes collections that each includes  
from 6 to 17 brush presets. Pixelmator brushes collections include: 
Abstract, Artistic, Default, Grunge, Nature, Smoke and Sparkle 
collections

Select a Brush Preset
To select a brush preset:

1. Choose View > Show Brushes if  the Brushes palette is not yet 
shown.

2. Click on any of the brushes in Brushes palette to select it.

Default Brushes Collection Presets Overview
This is a list and a description of the default brushes collection 
available in Pixelmator:

A simple brush - 1 pixels with 65% 
hardness

A simple brush - 3 pixels with 65% 
hardness

A simple brush - 5 pixels with 65% 
hardness

A simple brush - 10 pixels with 65% 
hardness

A simple brush - 17 pixels with 65% 
hardness

A simple brush - 25 pixels with 75% 
hardness

A simple brush - 30 pixels with 0% 
hardness

A simple brush - 50 pixels with 0% 
hardness

A simple brush - 100 pixels with 0% 
hardness

A simple brush - 100 pixels with 60% 
hardness, 70% spacing, 70% scatter 
and 70% size jitter

A simple brush - 15 pixels with 80% 
hardness with minimum size by 
speed of 78%

A simple brush - 20 pixels with 80% 
hardness with minimum size by 
speed of 49% and 40% by pressure

A bitmap (leaf ) brush - 70 pixels 
with 20% spacing, 30% scatter, 40% 
size jitter, 10% hue jitter and 30% 
lightness jitter.

A bitmap (smoke) brush - 80 pixels 
with 35% spacing, 2% scatter, 50% 
angle jitter



A bitmap (stars) brush - 100 pixels 
with 10% spacing, 40% scatter, 77% 
size jitter, 100% angle jitter and 62% 
opacity jitter.

A bitmap (ripple) brush - 80 pixels 
with 50% angle jitter.

Managing Brush Presets

You can create, edit, duplicate and remove and import brush 
presets and brushes collections. Brush presets are stored in the 
Brushes palette while Brushes collections are available under 
Brushes Action menu. Brush preset settings can be modi!ed in the 
Brush Editor sheet.

Create New Brush Preset
To create a new brush preset:

1. In the Brushes palette (View > Show Brushes), click the Action 
button to make a brushes menu appear.

2. Select New Brush... from the Brushes Action menu. 

3. Modify brush preset settings (see below for more information 
about the brush settings) in the brush editor.

4. Click OK to save your new brush.

Create New Brush Preset from an Image
To create a new brush preset from an image on your desktop:

1. Drag and drop the picture from your desktop that you want to 
use as a brush onto the Brushes palette or Brush editor sheet.

2. Double-click the brush that appears in the Brushes palette to 
modify it.

Or:

1. Select New Brush from Image... from the Brushes Action menu.

2. Select the image you would like to use as a brush in the Open 
dialog box and click Open.



3.  Double-click the new brush that appears in the Brushes palette 
to modify it.

Create New Brush Preset from Layer
If you have a layer that you would like to use as a brush:

1. Drag and drop the layer from your Layers palette that you want 
to use as a brush onto the Brushes palette or Brush editor sheet.

2. Double-click the picture that appears in the Brushes palette to 
modify it.

Edit Brush Preset
To edit a brush preset:

1. Double-click a brush in the Brushes palette to make a brush 
editor to appear or select Edit Brush... from the Brushes palette’s 
Action menu.

2. Adjust the brush settings. For more information about the brush 
settings, see below.

Duplicate Brush Preset
To duplicate a brush preset:

• Select Duplicate Brush from the Brushes Action menu.

• Control-click or right mouse button-click on a brush preset in the 
Brushes palette to make the brushes contextual menu appear 
and choose Duplicate from the brushes contextual menu.

Remove Brush Preset
To remove a brush preset:

• Select Remove Brush from the Brushes Action menu.

• Control-click or right mouse button click on a brush preset in the 
Brushes palette to make the brushes contextual menu to appear 
and choose Remove Brush from the brushes contextual menu.

Switching Brush Collections
In Pixelmator you can have as many brushes collections as you 
wish. To switch brush collections select the desired brush collection 
name from the Brushes Action menu.

Manage Brush Collections
Pixelmator brush collections may be added, removed, renamed and 
duplicated in Finder in Home > Library > Application Support > 
Pixelmator > Brushes folder.



Brush Preset Settings
Brush preset stores the shape, diameter, hardness, spacing,  scatter, 
$ow, follow angle, shape jitter, color jitter, graphics tablet sensitivity 
and control by mouse speed settings.

However, since there are two types of brushes in Pixelmator such as 
simple brush and bitmap brush some settings such as angle jitter 
and follow direction are not available for simple brush while 
hardness is for simple brush only. 

A list of brush preset settings:

Shape Tip SettingsShape Tip SettingsShape Tip Settings

Diamet
er Size of the brush tip

Hardne
ss

Amount of the brush anti-
aliasing (simple brush only)

Spacin
g

Distance between the 
brush points

Scatter
Di"erence in brush points 
placement in a stroke

Flow
Rate at which color is 
applied in a stroke

Follow 
Directi
on

if selected, the brush point 
angle follows the direction 
of the brush stroke

Shape Jitter SettingsShape Jitter SettingsShape Jitter Settings

Size 
(jitter)

Di"erence of brush points 
size in a stroke

Stroke 
(jitter)

Amount of stroke 
di"erence

Angle 
(jitter)

Di"erence of brush points 
angle in a stroke

Opacity 
(jitter)

Di"erence of brush points 
opacity in a stroke

Color Jitter SettingsColor Jitter SettingsColor Jitter Settings

Hue 
(jitter)

Di"erence of brush points 
hue in a stroke

Saturati
on 
(jitter)

Di"erence of brush points 
saturation in a stroke

Lightne
ss 
(jitter)

Di"erence in brush points 
lightness in a stroke

Adjust these brush settings to achieve desired results or simply to 
experiment with painting.



Keyboard Shortcuts for Diameter and Hardness
Use keyboard shortcuts to change the diameter and hardness of 
brushes as well as navigate through brushes in the Brushes palette 
when painting.

To change the diameter when painting, press the [ or ] keys on your 
keyboard.

To adjust the hardness when painting, press Shift + [ or Shift + ]

To cycle through brushes in the Brushes palette, press < or >. 

Control using Graphics Tablet and Mouse
In Pixelmator you can control your brush diameter, scatter and $ow 
settings with graphics tablet sensitivity or use mouse or tablet 
tracking speed.

To control the minimum brush size by graphics tablet sensitivity or 
tracking speed:

1. Double-click the brush on which you would like to adjust the 
graphics tablet or tracking speed control to make Brush editor 
sheet appear.

2. In the Brush editor sheet, click on a diameter, scatter or #ow 
value number to make the graphics tablet and tracking speed 
menu appear.

3. Adjust one or both of the following sliders:

• Pressure: the graphics tablet pressure varies the brush diameter, 
scatter or $ow.

• Speed: the tracking speed varies the brush diameter, scatter or 
$ow.



Brush Sharing

Sharing your brushes with other Pixelmator 
users is as simple as dragging and dropping 
brushes from the Pixelmator Brushes palette 
onto your desktop, and vice versa. 

In addition to letting you load and save brush 
presets, Pixelmator also lets you import Adobe 
Photoshop brushes. Again, it is as simple as 
dragging and dropping .abr !les (Photoshop 
brush presets) into the Pixelmator Brushes palette or window.

Export a Brush Preset
To export a brush preset:

1. Select a brush in the Brushes palette.

2. Click and drag the brush onto your desktop. A brush preset 
document is created on the desktop.

Import a Brush Preset or Brush Collections
To import a brush preset or brush collection, do one of the 
following:

• Choose Import Brushes... from the Brushes Action menu.

• Drag and drop a brush preset document onto the Pixelmator 
document window or Brushes palette.

• Right mouse button-click or Control-click on the Brushes palette 
to make a contextual menu appear. Choose Import From File..., 
select a brush preset document and click OK.

If a collection you are adding to your brushes palette has a single 
brush, it will add the brush to the currently selected collection. If 
the collection has more than a single brush, it will be imported as a 
collection.

Importing a brush preset is the same whether you are importing 
Pixelmator-created or Photoshop-created brushes.

Share Brush Collection
To share your brushes collection, go to Home > Library > 
Application Support > Pixelmator > Brushes folder and share any of 
the brush collection documents therein with your friends.



Chapter 12: Opacity and Blending Modes

Painting tools in Pixelmator o"er you the ability to paint in di"erent blending modes with any opacity setting. 

This chapter provides information about blending modes and opacity in Pixelmator.

This chapter covers:

• Opacity

• About Blending Modes

• Blending Modes Overview



Opacity

When painting with the brush or pencil tools in Pixelmator, you 
may want to modify the transparency of these tools so that they 
apply transparent color.

Adjust Opacity
To adjust the transparency of your brush or pencil tool:

1. Select the tools from the Tools palette.

2. Adjust the Opacity slider in the Tool Options palette (View > 
Show Tool Options).



About Blending Modes

The blending mode speci!es the way in which the painting tool 
brush strokes interact with the color of an image on which you are 
painting.

Blending modes with painting tools can be used to achieve special 
e"ects, to make photo improvements or to retouch photos.

By default, the blending mode for painting tools is set to normal, 
which causes the brush strokes to paint traditionally over the image 
while other blending modes o"er a wide variety of di"erent 
interactions.

Blending modes for painting tools such as Brush, Pencil, Gradient, 
Paint Bucket, and Clone Stamp are available in the Tool Options 
palette in the Blending pop-up.

Blending modes in the Blending pop-up menu can be divided into 
six categories: Basic, Darken, Lighten, Contrast, Comparative and 
HSL. Basic blending modes replace the base pixels, Darken ones 
darken interacting pixels, Lighten - lightens, Contrast modes 
increase or decrease the contrast of interacting pixels, Comparative 
- inverts color, and HSL modes apply a speci!c color component. 

For more in-depth description of each blending mode, see the 
Blending Modes Overview section later in this chapter.

Set a Blending Mode
To set a blending mode for any of the painting tools:

1. Select the painting tool (Brush, Pencil, Gradient, Paint Bucket or 
Clone Stamp).

2. In the Tool Options palette, select any of the blending modes 
from the Blending pop-up menu.



Blending Modes Overview
A list of blending modes that can be used with painting tools or layers in Pixelmator:

Blending Mode Description Preview

BasicBasicBasic

Normal The default mode paints color over the image.

Dissolve

Paints using a pattern of pixels though there is no e"ect if the top layer is 
at 100%. In order to see the e"ect of the Dissolve blending mode, you will 
need to reduce the opacity in the Tool Options palette.  There is no e"ect if 
the opacity is at 100% since Dissolve combines brush strokes with the 
image by using a pattern of pixels.

Behind
Paints behind an image. Best visible if image or layer you paint on is 
smaller than canvas size. Good for quickly making shadows.



DarkenDarkenDarken

Darken
Paints by creating a darker result. Lighter pixels are dropped out 
completely.

Multiply Paints by lessening the saturation and toning down the color.

Color Burn Paints by creating an exaggerated color saturation e"ect.

Linear Burn
The result is similar to the Multiply mode, but it creates more intense color 
saturation.



Darker Color
Similar to Darken mode. Paints by choosing the lowest pixel values to 
create the resulting color.

LightenLightenLighten

Lighten
Paints by creating a brighter result. Pixels darker than the brush color are 
replaced.

Screen Paints by lightening the image and softening the saturation.

Color Dodge Paints by creating exaggerated color saturation e"ect.



Linear Dodge Paints by creating more intense color saturation.

Lighter Color Paints by choosing the highest pixel values to create the result.

ContrastContrastContrast

Overlay Paints by creating a saturated image with strong color.

Soft Light Paints by creating a lighter or darker result, depending on the brush color.



Hard Light
Paints by lightening or darkening the image, depending on the brightness 
of the brush color. Contrast is also increased.

Vivid Light
Paints by creating a highly saturated result that is similar to Color Burn 
mode, but  is not as dark.

Linear Light Paints by increasing or decreasing brightness.

Pin Light Paints by preserving the lighter tones and highlighting the blend value.



Hard Mix Paints by creating the posterized e"ect.

ComparativeComparativeComparative

Di"erence Painting creates brightly saturated colors and inverted image.

Exclusion Works almost like the Di"erence mode, except the contrast is lower.

HSLHSLHSL



Hue
Paints with a tinted e"ect where tinting is darkest in areas of high 
saturation.

Saturation
Paints by applying the saturation of brush to the image while retaining the 
hue and luminance of the image.

Color
Paints by coloring the image while changing the saturation via neutral 
colors.

Luminosity
Paints by applying the brightness of brush colors to the image while 
retaining the hue and saturation of the image.

The best way to learn blending modes is to experiment with them.
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Part V: Layers

Pixelmator is a layer-based image editor. Layers are the building 
blocks of your composition. You can create layers from your 
photos, pictures, from selections, iSight or even from scratch.

Chapter 13 About Layers

Chapter 14 Working with Layers

Chapter 15 Type Layers



Chapter 13: About Layers

Pixelmator is a powerful layers-based image editor.

This chapter provides a basic introduction to layers.

This chapter covers:

• Introduction to Layers



Introduction to Layers

Pixelmator is a layers-based image editor, and if you would like to 
make the most of its power, it is essential to understand the 
concept of layers and how they work.

Layers are the the base of non-destructive image editing. They are 
like sheets stacked one on top of another. Transparent areas on a 
layer let you see layers below and the !nal appearance of the 
picture depends on their order. 

In Pixelmator you can create new layers from your photos, other 
pictures, from selections, or Pixelmator can even add a layer to your 
composition directly from your Mac’s iSight camera.

Though using layers is not necessary, it is always recommended. 
Even when you use the paste command, Pixelmator will 
automatically create a new layer for you. 

You use the Layers palette in Pixelmator to select layers, create new 
layers, remove layers, show and hide layers, arrange stacks of layers, 
create clipping masks, link layers, and preserve a layer’s 
transparency.

To show the Layers palette:

• Choose View > Show Layers.

• Use Command + 3 keyboard shortcut.

Compatibility: Adobe Photoshop is also a layer-based image editor - 
Pixelmator supports the Adobe Photoshop !le format (PSD) which 
includes layers.



Chapter 14: Working with Layers

You can create new, duplicate, rename, load as selections, hide, link and arrange added layers, but Pixelmator also 
allows you to blend layers, change their opacity, create clipping masks and much more.

This chapter provides information about creating, editing and managing layers.

This chapter covers:

• Creating Layers

• Managing Layers

• Layer Groups

• Setting Layer Opacity and Blending

• Masking Layers



Creating Layers

In addition to creating simple layers in Pixelmator, you can create 
layers by taking a picture from your built-in iSight camera, by 
duplicating currently existing layers, or by converting a selection 
into a new layer. 

Create a New Layer
To create a new layer, do one of the following:

• Click the New Layer button in the Layers palette.

• Choose Layer > New Layer... Type a name for a layer, choose 
blending mode, set the opacity and click OK.

• Choose New Layer from the Layers contextual menu.

Create a New Layer from iSight
You can add layers from iSight to your composition if you have a 
Mac with a built-in iSight camera.

1. Choose Layer > New Layer from iSight....

2. Click the Record button, and wait a few seconds while Pixelmator 
captures the picture.

3. If you like your picture, click OK.

Add a New Layer from Photo Browser
You can also add a new layer from the Photo Browser palette by 
dragging and dropping an image from the Photo Browser palette 
onto your opened composition.

Add a New Layer from Finder
To add a layer from Finder, drag & drop an image from the Finder 
onto an opened composition window or layers palette.

Add a New Layer from Other Pixelmator Image
To add a layer from other Pixelmator image, drag and drop any 
layer from one composition’s layers palette onto another 
composition’s window.

Convert a Selection into a New Layer
To convert a selection into a new layer:

1. Make a selection.

2. From the selection tool contextual menu choose one of the 
following:

• Layer via Copy (this will copy the selection content as a 
new layer)

• Layer via Cut (this will cut the selection and paste it as a 
new layer)



Duplicate Layers
To duplicate layers within an image:

1. Select a layer in the Layers palette.

2. Do one of the following:

• Drag the layer onto the New Layer button in the Layers 
palette.

• Choose Duplicate Layer from the Layers menu.

• Choose Duplicate from the Layers palette contextual menu.

• Press Option when moving the layer using the Move Tool to 
duplicate it.



Managing Layers

Once layers are created, you can show, hide, select, move, change 
stack order, lock, unlock, link, unlink, rename, delete, convert into 
pixels, and merge them.

Show or Hide Layer
To show or hide a layer:

• Click the show/hide checkbox in the Layers palette.

• Choose Layer > Hide/Show Layer....

Select Layers
To select a layer in the Layers palette, do one of the following:

• Click a layer in the Layers palette.

• To select multiple contiguous layers, click the !rst layer and Shift-
click the last layer.

• To select multiple noncontiguous layers, Command-click them in 
the Layers palette.

To select layers in the document window:

1. Select the Move tool.

2. Do one of the following:

• In the Move tool Tool Options palette, check the Auto Select Layer 
checkbox and click on the layer in the document window you 
want to select.

• Command-click layer in the image to select it.

• Control-click in the image with the Move tool to make a 
contextual menu appear. The contextual menu lists all the layers 
that are below the cursor that you can choose to select.

Link and Unlink Layers
Linked layers keep their linking until you unlink them. You can 
move or apply transformations to linked layers.

To link layers:

1. Select the layers in the Layers palette that you would like to link.

2. Click the Link button in the Layers palette.

To unlink layers, select any of the linked layers and click the Link 
button.



Change the Stack Order of Layers
To change the stack order of layers, do one of the following:

• Drag the layer up or down in the Layers palette.

• Select a layer and choose Layer > Bring to Front, Bring Forward, 
Send Backward or Send to Back.

Move Layer
To move the content of a layer:

1. In the Layers palette, select the layer that contains objects you 
would like to move.

2. Use the Move tool to move it.

Lock Layer Transparency
To preserve layer transparency from editing:

1. Select a layer.

2. Do one of the following:

• Click the Preserve Transparency button in the Layers palette.

• Choose Layer > Preserve Transparency.

Tips: Once a layer you would like to move is selected, you can move it 
using the Move tool, but you can also nudge the layer by pressing 
arrow keys on your keyboard.

To nudge a layer by 10 pixels, hold down the Shift key and press an 
arrow key on your keyboard.

Rename Layer
To give a layer a name, double-click the layer name in the Layers 
palette and enter a new name.

It is recommended that you give layers names for easier 
identi!cation of them in the Layers palette.

Merge Layers
To merge two or more layers:

1. Select the layers you want to merge.

2. Do one of the following

• Choose Layer > Merge Layers.

• From the Layers contextual menu choose Merge Layers.

• Use the Command + E keyboard shortcut.

Merge All Layers
To merge all layers at once, choose Layer > Merge All Layers.



Delete Layers
To delete a layer:

1. Select one or more layers in the Layers palette.

2. Do one of the following:

• Click the delete button in the Layers palette.

• Drag the layer onto the delete button in Layers palette.

• Use the Backspace keyboard shortcut to delete a layer. Backspace 
keyboard shortcut will not delete a layer if a selection is made or 
you are typing. Instead, it will delete a selection or type.

Tip: Deleting layers you no longer use reduces the size of your 
image !le whether it is a PSD or PXM !le.



Layer Groups

If you are working with many layers, you can organize them into 
groups.

Group Layers
To group layers:

1. Select two or more layers in the Layers palette.

2. Choose Layer > Group Layers or right-click and select Group 
from the contextual menu.

Ungroup Layers
To ungroup layers:

1. Select layers in the Layers palette.

2. Choose Layer > Ungroup Layers or right-click and select 
Ungroup from the contextual menu.

Merge Group
To convert a layer group to a single layer:

1. Right-click on the group in the Layers palette.

2. Select Merge Group from the contextual menu.

Tip: Default blending of a layer group is Pass Through. It preserves 
blending settings of individual layers.



Layer Opacity and Blending

A layer’s blending determines how it blends with underlying layers 
in the composition while a layer’s opacity determines how 
transparent a layer is compared to those beneath it. Opacity and 
blending can be used to create a variety of special e"ects.

Layer Opacity
To set layer opacity:

1. Select a layer in the Layers palette.

2. In the Layers palette, drag the Opacity slider.

Layer Blending
To specify a blending mode for a layer:

1. Select a layer in the Layers palette.

2. In the Layers palette, choose any of the blending modes from the 
Blending pop-up menu.

A description of blending modes is available in Chapter 12 of this 
manual.



Masking Layers

Masking layers is a non-destructive way to hide parts of layers. In 
addition to adding masks, you can also delete, show or hide, link or 
unlink and edit them using any of the painting and color correction 
tools or even !lters.

Add Layer Mask
To add a mask to a layer:

1. Select a layer in the Layers palette.

2. Choose Layer > Add Layer Mask.

A white mask thumbnail near layer thumbnail in the Layers palette 
appears.

Edit Layer Mask
To edit a layer mask:

1. Select a layer mask you want to edit in the Layers palette.

2. Click on the layer mask thumbnail in the Layers palette

3. Use any of the tools to edit the layer mask.

Enable or Disable Layer Mask
To enable or disable a layer mask:

1. Select the layer mask in the Layers palette.

2. Choose Layer > Disable (or Enable) Layer Mask.

When layer mask is disabled, its thumbnail will have a disabled 
mark.

Link or Unlink Layer and Mask
To unlink or link a layer from its mask, click the Link button 
between the layer and its mask in the Layers palette.

Delete Layer Mask
To remove a mask from a layer:

1. Select a layer with the mask you want to remove in the Layers 
palette.

2. Choose Layer > Remove Layer Mask.

Create a Clipping Mask
Use a clipping mask to mask the layers above a currently selected 
layer’s content. To create a clipping mask:

1. Select the !rst layer above the base layer in the layers palette.

2. Do one of the following.

• Choose Layer > Create Clipping Mask.

• Hold down the Option key on your keyboard, position the 
pointer over the !rst layer that you want to include in the 
clipping mask (notice the pointer changes to clipping mask 
pointer), and click.

Remove a Layer from a Clipping Mask
To remove a layer from a clipping mask, do one of the following:

1. Select a layer in the clipping mask.

2. Do one of the following:

• Choose Layer > Release Clipping Mask.

• Hold down the Option key on your keyboard, position the 
pointer over the !rst layer that you want to include in the 
clipping mask (notice the pointer changes to clipping mask 
pointer), and click.



Chapter 15: Type Layers

Use the Type tool in Pixelmator to create and edit type layers in your compositions.

This chapter provides information about creating type in Pixelmator.

This chapter covers:

• Creating Type Layers

• Editing Type Layers



Creating Type

You create type layers in Pixelmator using the Type tool. You can 
create a line of text type or paragraph type.

Create Type Layer
To create a type layer:

1. Select the Type tool in the Tools palette.

2. Do one of the following:

• Click on an image to set the insertion point for the type.

• Click and drag in an image to de!ne a bounding box for the type.

3. Enter the characters.

Resize Type Bounding Box
To resize a type bounding box for paragraph type:

1. Select the Type tool in the Tools palette.

2. Click in the text $ow in the image.

3. Position the pointer over the bounding box handle and drag.



Editing Type

Once a type layer is created, you can edit, check and correct 
spelling, format type characters and convert the type layer into 
pixels.

Edit Text in a Type Layer
To edit text in a type layer:

1. Select the Type Tool in the Tools palette.

2. Position the pointer on the text and click to set the insertion 
point.

3. Enter text.

4. Make changes by choosing any other tool in the Tools palette or 
by pressing Escape on your keyboard.

Check Spelling and Grammar
To check spelling and grammar:

1. Select the text you want to check with the Type tool.

2. Choose Edit > Spelling and Grammar > Show Spelling and 
Grammar.

Format Type Characters
You can use a variety of fonts in Pixelmator, and you can change the 
way they look. To change font type, style, color, and size:

1. Select the Type tool.

2. Position the Type tool cursor in the text, click and drag to select 
one or more characters.

3. Choose View > Show Tool Options (if Tool Options palette is not 
yet available).

4. The Type tool in the Tool Options palette provides options for 
formatting characters. Some formatting options are also available 
in the default Fonts palette. To display the Fonts palette, do one 
of the following:

• Click the Show Fonts button in the Type Tool Options palette.

• Choose View > Show Fonts.

Convert Type Layer into Pixels
In order to add special e"ects, paint on, or use color correction 
tools for the type layer, you must convert the type into pixels.

This converts the type layer into a normal layer and makes the text 
in type layer non editable.

To convert the type layer into pixels:

1. Select the Type layer you want to convert into pixels.

2. Do one of the following:

• Choose Layer > Convert into Pixels.

• Position the Type tool cursor over the text and control-click or 
right mouse button click to make a contextual menu appear and 
choose Convert into Pixels.

• Choose Convert into Pixels from the Layers palette contextual 
menu.



Postcard - Created by Saulius Dailide



Part VI: Filters

Pixelmator is a real !lter machine. It has over 130 !lters and 
special e"ects to meet your needs. Just choose any of nicely 
designed distortion, blur sharpen, color, stylize, halftone, tile 
generator, transition and Quartz Composer !lters and see the 
results in real-time.

Chapter 16 About Filters

Chapter 17 An Overview of Filters

Chapter 18 Third-party Filters



Chapter 16: About Filters

Pixelmator is a real !lter machine. It has over 130 !lters and special e"ects to meet your needs.

This chapter provides a basic introduction to !lters and tells you how to apply them to your images.

This chapter covers:

• Introduction to Filters

• Applying Filters



Introduction to Filters

Filters are used everywhere - from simply retouching or cleaning up 
photos to distorting, adding special e"ects, creating lighting 
e"ects, experimenting or even creating unique pictures from 
scratch. 

Pixelmator includes over 130 di"erent !lters to meet your special 
e"ects and other editing needs. Simply launch Pixelmator, open a 
photo, and choose Filter menu. Groups such as Distortion, Blur, 
Sharpen, Stylize, Halftone, Tile, Color, Generator, Transition, and 
Quartz Composer include some pretty neat !lters that are a 
pleasure to use.

Filters are especially useful when you are a more advanced user and 
know some tips and tricks that take advantage of using a bunch of 
!lters in a row to achieve one e"ect.

It is also noteworthy that due to its powerful plug-in architecture, 
Pixelmator fully supports third-party Core Image Units or Quartz 
Composer compositions as !lters. This means you can simply 
download or create your own Core Image unit or Quartz Composer 
composition and play with it right away in Pixelmator.



Applying Filters

You use the Filter menu in Pixelmator to choose !lters that you 
would like to apply. Filters can be applied to selections or layers.

Apply Filter
To apply a !lter:

1. Select a layer, or if you wish to add the adjustment to a portion of 
your image, make a selection using the selection tools.

2. Choose any of the !lters from the Filter menu.

3. Each Filter palette contains individual parameters and you can 
specify a range of values. Use the !lter controls such as sliders to 
change parameter values and use the rope to point to the center of 
the selected !lter.

4. After you are done click OK to accept changes or Cancel to reject 
changes. 

Apply Last-Used Filter
Use the Last Filter command to apply the last-used !lter with 
recently used settings to your image by choosing Filter > Last Filter 
or press Shift + Command + F on your keyboard.



Chapter 17: Filter Overview

In Pixelmator you can use any of the nicely designed distortion, blur, sharpen, color, stylize, halftone, tile generator, 
transition and Quartz Composer !lters.

This chapter provides an overview of !lters in Pixelmator.

This chapter covers:

• Distortion Filters

• Blur Filters

• Sharpen Filters

• Stylize Filters

• Halftone Filters

• Tile Filters

• Color Filters

• Generator Filters

• Transition Filters

• Quartz Composer Filters



Distortion Filters

Distortion !lters include Bump, Bump Linear, Circle Splash, Circular 
Wrap, Displacement, Glass, Hole, Pinch, Torus Lens, Twirl and Vortex.

To apply any of the distortion !lters:

1. Choose Filter > Distortion > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Distortion Filters Overview

Bump The Bump !lter creates a 
bump that originates at a 
speci!ed point in the image 
layer or selection.

Bump Linear The Bump Linear !lter creates 
a bump that originates from a 
linear portion of the image 
layer or selection.

Circle Splash The Circle Splash distorts the 
pixels, starting at the 
circumference of a circle and 
emanating outward.

Circular Wrap Circular Wrap wraps an image 
around a circle.

Displacement Displacement applies the 
grayscale values of the second 
image to the !rst image.

Glass Glass distorts an image by 
applying a glassy texture.

Hole The Hole creates a circular 
area that pushes the image 
pixels outward, distorting 
those pixels closest to the 
circle most.



Pinch Pinch creates a rectangular-
shaped area that pinches 
pixels inward, distorting those 
pixels closest to the rectangle 
the most.

Torus Lens Torus Lens creates a torus-
shaped lens and distorts the 
portion of the image over 
which the lens is placed.

Twirl Twirl rotates pixels around a 
point to give a twirling e"ect.

Vortex Vortex rotates pixels around a 
point to simulate a vortex.



Blur Filters
Blur !lters include Box Blur, Gaussian Blur, Motion Blur, Noise 
Reduction, Zoom Blur and Median.

To apply any of the Blur !lters:

1. Choose Filter > Blur > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Blur Filters Overview

Box Blur The Box Blur smooths or 
sharpens a layer or selected 
pixels using a box convolution 
kernel.

Gaussian Blur The Gaussian Blur spreads a 
layer or selected pixels by an 
amount speci!ed by a 
Gaussian distribution.

Motion Blur Motion Blur blurs an image to 
simulate the e"ect of using a 
camera that moves at a 
speci!ed angle and distance 
while capturing the image.

Noise 
Reduction

Noise Reduction reduces 
noise using a threshold value 
to de!ne what is considered 
to be noise.

Zoom Blur Zoom Blur simulates the 
e"ect of zooming the camera 
while capturing the image.

Median Median computes the median 
value for a group of 
neighboring pixels and 
replaces each pixel value with 
the median. The e"ect is to 
reduce noise.



Sharpen Filters
Sharpen !lters include Sharpen Luminance and Unsharp Mask.

To apply any of the sharpen !lters:

1. Choose Filter > Sharpen > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Sharpen Filters Overview

Sharpen 
Luminance

This !lter increases the image 
detail by sharpening.

Unsharp 
Mask

This !lter increases the 
contrast of the edges 
between pixels of di"erent 
colors in an image.



Stylize Filters
Stylize !lters include Bloom, Crystallize, Edge Work, Edges, Gloom, 
Height Field from Mask, Hexagonal Pixellate, Line Overlay, Pixellate, 
Pointillize, Spot Color, Spot Light, Shaded Material, Equalize and 
Comic E"ect.

To apply any of the Stylize !lters:

1. Choose Filter > Stylize > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Stylize Filters Overview

Bloom This !lter softens edges and 
applies a pleasant glow to an 
image.

Crystallize This !lter creates polygon-
shaped color blocks by 
aggregating source pixel-
color values.

Edge Work Edge Work produces a stylized 
black-and-white rendition of 
an image that looks similar to 
a woodblock cutout.

Edges This !lter !nds all edges in an 
image and displays them in 
color.

Gloom Gloom dulls the highlights of 
an image.

Height Field 
from Mask

This !lter produces a 
continuous three- 
dimensional, loft-shaped 
height !eld from a grayscale 
mask.

Hexagonal 
PIxellate

Displays an image as colored 
hexagons whose color is an 
average of the pixels they 
replace.



Line Overlay Creates a sketch that outlines 
the edges of an image in 
black.

Noise Applies random pixels to an 
image. Monochromatic 
option applies the !lter to 
only the tonal elements in the 
image without changing the 
colors.

Pixellate This !lter makes an image 
blocky.

Pointillize Pointillize renders the source 
image in a pointillistic style.

Spot Color Replace color or more color 
ranges with spot colors.

Spot Light Applies a directional spotlight 
e"ect to an image.

Shaded 
Material

This !lter produces a shaded 
image from the height !eld 
mask.

Equalize Use Equalize to remap pixel 
values in the image so that 
the brightest value represents 
white, the darkest value 
represents black, and the 
intermediate values are 
evenly distributed throughout 
the grayscale.

Comic E"ect Simulates a comic book 
drawing by outlining edges 
and applying a color halftone 
e"ect.



Halftone Filters
Halftone !lters include CMYK Halftone, Circular Screen, Dot Screen, 
Hatched Screen and Line Screen.

To apply any of the halftone !lters:

1. Choose Filter > Halftone > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Halftone Filters Overview

CMYK 
Halftone

This !lter creates a color 
halftone rendition of the 
source image, using cyan, 
magenta, yellow, and black 
inks over a white page.

Circular 
Screen

This !lter simulates a circular-
shaped halftone screen.

Dot Screen This !lter simulates the dot 
patterns of a halftone screen.

Hatched 
Screen

Hatched Screen simulates the 
hatched pattern of a halftone 
screen.

Line Screen This !lter simulates the line 
pattern of a halftone screen.



Tile Filters
Tile !lters include A#ne Clamp, A#ne, Eightfold Re$ected, Fourfold 
Re$ected, Fourfold Rotated, Fourfold Translated, Glide Re$ected, 
Kaleidoscope, Op, Parallelogram, Perspective, Sixfold Re$ected, 
Sixfold Rotated, Triangle and Twelvefold Re$ected.

To apply any of the tile !lters:

1. Choose Filter > Tile > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Tile Filters Overview

A#ne Clamp This !lter performs an a#ne 
transform on a source image 
and then clamps the pixels at 
the edge of the transformed 
image, extending them 
outwards.

A#ne This !lter applies an a#ne 
transform to an image and 
then tiles the transformed 
image.

Eightfold 
Re$ected

This !lter produces a tiled 
image from a source image by 
applying an 8-way re$ected 
symmetry.

Fourfold 
Re$ected

This !lter produces a tiled 
image from a source image by 
applying a 4-way re$ected 
symmetry.

Fourfold 
Rotated

This !lter produces a tiled 
image from a source image by 
rotating the source image at 
increments of 90 degrees.

Fourfold 
Translated

This !lter produces a tiled 
image from a source image by 
applying 4 translation 
operations.

Glide 
Re$ected

This !lter produces a tiled 
image from a source image by 
translating and smearing the 
image.



Kaleidoscope This !lter produces a 
kaleidoscopic image from a 
source image by applying 12-
way symmetry.

Op This !lter segments an image, 
applying any speci!ed scaling 
and rotation, and then 
assembles the image again to 
give an op art appearance.

Parallelogram This !lter warps an image by 
re$ecting it in a 
parallelogram, and then tiles 
the result.

Perspective This !lter applies a 
perspective transform to an 
image and then tiles the 
result.

Sixfold 
Re$ected

This !lter produces a tiled 
image from a source image by 
applying a 6-way re$ected 
symmetry.

Sixfold 
Rotated

This !lter produces a tiled 
image from a source image by 
rotating the source image at 
increments of 60 degrees.

Triangle This !lter maps a triangular 
portion of image to a 
triangular area and then tiles 
the result.

Twelvefold 
Re$ected

This !lter produces a tiled 
image from a source image by 
rotating the source image at 
increments of 30 degrees.



Color Filters
Color !lters include Color Map, Color Monochrome, Sepia Tone, 
Gamma Adjust, False Color and Mask to Alpha.

To apply any of the Color !lters:

1. Choose Filter > Color > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Color Filters Overview

Color Map Color Map performs a 
nonlinear transformation of 
source color values using 
mapping values provided in a 
table.

Color 
Monochrome

Remaps colors so they fall 
within shades of a single 
color.

Sepia Tone This !lter maps the colors of 
an image to various shades of 
brown.

Gamma 
Adjust

This !lter adjusts midtone 
brightness.

False Color False Color maps luminance 
to a color ramp of two colors.

Mask to 
Alpha

This !lter converts a grayscale 
image to a white image that is 
masked by alpha.



Generator Filters
Generator !lters include Checkerboard, Clouds, Stripes, Lenticular 
Halo, Star Shine, Sunbeams, Constant Color and Random Generator.

To apply any of the Generator !lters:

1. Choose Filter > Generator > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Generator Filters Overview

Checkerboard This !lter generates a 
checkerboard pattern.

Clouds This !lter generates a soft 
cloud pattern.

Stripes This !lter generates a stripe 
pattern.

Lenticular 
Halo

This !lter simulates a halo that 
is generated by the di"raction 
associated with the spread of 
a lens.

Star Shine This !lter generates a 
starburst pattern.

Sunbeams This !lter generates a sun 
e"ect.

Constant 
Color

This !lter generates a solid 
color. Constant Color will use 
your foreground color as a 
color source.

Random 
Generator

Generates an image of in!nite 
extent whose pixel values are 
made up of four independent, 
uniformly-distributed, 
random numbers in the 0 to 1 
range.



Transition Filters
Transition !lters include Bars Swipe, Copy Machine, Flash, Mod, 
Page Curl, Ripple and Swipe.

To apply any of the Transition !lters:

1. Choose Filter > Transition > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes. 

Transition Filters Overview

Bars Swipe This !lter transitions from one 
image to another by passing a 
bar over the source image.

Copy 
Machine

This !lter simulates the e"ect 
of a copy machine.

Flash This !lter creates a $ash in a 
selected layer, image or 
selection.

Mod This !lter transitions from one 
image to another by revealing 
the target image through 
irregularly shaped holes.

Page Curl This !lter transitions from one 
image to another by 
simulating a curling page, 
revealing the new image as 
the page curls.

Ripple This !lter transitions from one 
image to another by creating 
a circular wave that expands 
from the center point, 
revealing the new image in 
the wake of the wave.

Swipe The Swipe transitions from 
one image to another by 
simulating a swiping action.



Quartz Composer Filters

Pixelmator supports Quartz  Composer compositions as !lters. 
Quartz Composer-based !lters work exactly like !lters except that 
they are based in a special Quartz Composer menu. There are !ve 
Quartz Composer groups available in Pixelmator: distortion, stylize, 
generator, other and transitions.

Apply a Quartz Composer Filter
To apply a Quartz Composer !lter:

1. Choose Filter > Quartz Composer > Distortion, Stylize, Other or 
Transitions > any of the !lters.

2. Use the !lter controls such as sliders to change parameter values 
and, if available, use the rope to point to the center of the 
selected !lter.

3. After you are done, click OK to accept changes or Cancel to reject 
changes.

Quartz Composer: Quartz Composer is a node-based visual 
programming language that works by implementing and connecting 
patches. It is easy for anyone to use the Quartz Composer application 
to create filters that can be used with Pixelmator.

The di"erence between Quartz Composer compositions and Core 
Image units is that Quartz Composer uses those same Core Image 
units as a base. Basically, the work is done by embedding various Core 
Image units into a single !lter.

Quartz Composer Filter Overview

DistortionDistortion

Bulge

Dent

Light Tunnel

Pinch



Squeeze

Twirl

Fish Eye

Mirror

Stretch

StylizeStylize

ASCII Art

Blue Print

City Lights



Compound Eye

Concert

Crystalize

Dot Screen

False Color

Film Stock

Glow

Kaleidoscope



Line Overlay

Line Screen

Monochrome

Neon

Pixellate

Pointillize

Posterize

Tracer



Zoom Blur

Black and White

Color Pencil

Comic Book

Pop Art

Sepia

Thermal Camera

X-Ray

GeneratorGenerator



Defocus

Fall

Floor

Gradient

Grid

Image Hose

Moving Shapes

Travelator



Wall

OtherOther

Blur

Color Controls

Exposure Adjust

Image Resizer

Motion Blur

Sharpen

Color Invert

TransitionTransition



Copy Machine

Cube

Dissolve

Mask

Mod

Mosaic Flip

Push

Swing

Zoom Dissolve



Chapter 18: Third-Party Filters

Pixelmator fully supports Core Image Units and Quartz Composer compositions as !lters. This means you can easily 
create any kind of !lter for Pixelmator by yourself.

This chapter provides introductory information about third-party !lters.

This chapter covers:

• Third-Party Filters

• Third-Party Filter Development



Third-Party Filters

Pixelmator signi!cantly outshines other applications with its 
powerful plug-in architecture that takes advantage of both Core 
Image units and Quartz Composer compositions. This means you 
can simply download or create your own Core Image unit or Quartz 
Composer composition and play with it right away in Pixelmator.

You don’t have to worry about the user interface for a !lter whether 
you are using third-party !lter or creating your own !lter. 
Pixelmator uses a default user interface for third-party filters.

Installing Third-party Filters
Once you download a third-party Core Image !lter or Quartz 
Composer composition, it must be installed in order to work with 
Pixelmator.

Third-party !lters should be copied to Library > Graphics > Image 
Units or Quartz Composer Plug-Ins.



Third-Party Filter Development

There are two types of !lters in Pixelmator - Core Image Units and 
Quartz Composer compositions. Core Image Units and Quartz 
Composer compositions can be created using the Apple Developer 
Tools.

Core Image Units
Core Image units are a bit harder to create since it requires 
additional programming knowledge and experience. They are 
usually created using Xcode. If you think you are good programmer, 
you may want to get into Core Image units development by taking 
a look at Apple’s Core Image documentation for developers. Core 
Image units talk directly to your graphics card.

Quartz Composer Compositions
Pixelmator also supports Quartz Composer compositions as !lters.

Quartz Composer is a node-based visual programming language 
that works by implementing and connecting patches. It is easy for 
anyone to use the Quartz Composer application to create filters 
that can be used with Pixelmator. The di"erence between Quartz 
Composer compositions and Core Image units is that Quartz 
Composer uses those same Core Image units as a base. Basically, 
the work is done by embedding various Core Image units into a 
single !lter.

To start working on Quartz Composer-based !lters just get your 
Leopard DVD, install Developer tools, look for the application called 
Quartz Composer, and you’re good to go. Apple even provides 
examples that allow you to start playing with Quartz Composer. 

Resources
If you are considering developing units or compositions for 
Pixelmator, here are a few links that will get you started: 

Core Image Unit Tutorial: http://developer.apple.com/
documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/
index.html 

Quartz Composer: http://developer.apple.com/graphicsimaging/
quartzcomposer/ 

If you need any help solving technical problems, you can contact 
the Pixelmator Team developers at support@pixelmator.com.

Be aware that Pixelmator does not support compositions created with 
Quartz Composer v1.0 or 2.0. It supports only compositions created in 
Quartz Composer 3.0 and later. Quartz Composer is the same free 
application that comes with Mac OS X DVD’s Xcode tools. 

In addition, please be aware that music visualizers and RSS visualizers 
compositions created in Quartz Composer won’t work in Pixelmator.  

http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/documentation/GraphicsImaging/Conceptual/ImageUnitTutorial/index.html
http://developer.apple.com/graphicsimaging/quartzcomposer/
http://developer.apple.com/graphicsimaging/quartzcomposer/
http://developer.apple.com/graphicsimaging/quartzcomposer/
http://developer.apple.com/graphicsimaging/quartzcomposer/
mailto:support@pixelmator.com?subject=Filter%20Development
mailto:support@pixelmator.com?subject=Filter%20Development
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Part VII: Transforming

Transform images, layers or selections using any of the powerful 
Pixelmator transform tools such as Free Transform, Skew, Distort, 
Perspective, Rotate, and Flip. In addition, you can easily adjust 
image size and your composition’s canvas in Pixelmator.

Chapter 19 Transforming Objects

Chapter 20 Image Size

Chapter 21 Canvas Size and Rotation



Chapter 19: Transforming Objects

Transform images, layers or selections using transform tools such as Free Transform, Skew, Distort, Perspective, Rotate,  
and Flip.

This chapter provides information about transforming selections or layers.

This chapter covers:

• Free Transform

• Skew, Distort, Perspective, Rotate, and Flip 



Free Transform

The Free Transform command in Pixelmator lets you apply scale 
and rotate commands in one continuous operation.

To freely transform an item:

1. Choose Edit > Transform or use the Command + F keyboard 
shortcut.

2. If necessary, in the transform bounding box, drag the center 
point to a preferred location. The default center point location is 
the center of the selected object.

3. Do one or more of the following:

• To scale by dragging, drag handles on the bounding box.

• Or enter a value in the width and height !elds of the Transform 
palette that appears. Clicking the link button between the width 
and height values will scale the item proportionally.

• To rotate by dragging, move the pointer outside the bounding 
box and then drag. Notice the cursor changes to an angle pointer 
with arrows.

• You can click the knob in the Transform palette to set the angle of 
rotation.

• Or enter a value in the angle value !eld of the Transform palette 
that appears. 

4. When you !nish, click OK in the Transform palette or press Enter 
on your keyboard or double-click inside the transformation 
bounding box to apply the transformation.

Tip: You can use di"erent units, such as millimeters or pixels when 
entering values into the text !elds of the Transform palette. Right-click 
the text !elds, or just type the units, e.g. “1000 px”.



Skew, Distort, Perspective, Rotate, and Flip

To transform objects, you can also use other commands such as 
Skew, Distort, Perspective, Rotate, and Flip. In Pixelmator, you can 
transform layers, selections or layer masks.

In order to make a transformation, you must select an item to 
transform and then choose a transformation command:

Skew
To slant an item vertically and horizontally:

1. Choose Edit > Transform or use the Command + F keyboard 
shortcut.

2. Click the Action button in the Transform palette and select Skew.

3. Drag handles on the bounding box.

4. When !nished, press Enter on your keyboard or double-click 
inside the transformation bounding box to apply the 
transformation.

Distort
To stretch an item vertically and horizontally:

1. Choose Edit > Transform or use the Command + F keyboard 
shortcut.

2. Click the Action button in the Transform palette and select 
Distort.

3. Drag handles on the bounding box.

4. When !nished, press Enter on your keyboard or double-click 
inside the transformation bounding box to apply the 
transformation.



Perspective
To change opposite sides of an item equally:

1. Choose Edit > Transform or use the Command + F keyboard 
shortcut. 

2. Click the Action button in the Transform palette and select 
Perspective.

3. Drag handles on the bounding box.

4. When !nished, press Enter on your keyboard or double-click 
inside the transformation bounding box to apply the 
transformation.

Rotate Precisely
To rotate an item precisely:

• Choose Edit > Rotate 180˚ to rotate by half-turn.

• Choose Edit > Rotate 90˚ Right to rotate clockwise by a quarter 
turn.

• Choose Edit > Rotate 90˚ Left to rotate counterclockwise by a 
quarter turn.

You can also !nd these commands by clicking the Action button in 
the Transform palette.



Flip
To $ip an item:

• Choose Edit > Flip Horizontal to $ip horizontally

• Choose Edit > Flip Vertical to $ip vertically

You can also !nd these commands by clicking the Action button in 
the Transform palette.

Tip: You can undo transformations by clicking the Action button and 
choosing Reset.



Chapter 20: Changing Image Size

Use the Image Size command to resize an image or document for printing.

This chapter provides information about adjusting image size.

This chapter covers:

• Changing Image Size



Image Size

Use the Image Size sheet in Pixelmator to change the print 
dimensions and resolution of an image.

Adjust Pixel Dimensions
To change the pixel dimensions of an image:

1. Choose Image > Image Size.

2. Check the Scale Proportionally checkbox in order to maintain the 
current ratio of the pixels’ width and height. Make sure that 
Resample Image is selected.

3. Enter values for width and height, or choose a common size from 
the “Fit into” pop-up menu.

4. When you !nish, click OK.

Adjust Print Dimensions
To change the print dimensions and resolution:

1. Choose Image > Image Size.

2. Check the Scale Proportionally checkbox in order to maintain 
the current ratio of the pixels’ width and height.

3. Enter new values for the height and width. If necessary, select a 
new unit of measurement. Or choose a common size from the “Fit 
into” pop-up menu.

4. Enter a new value for resolution. If necessary, select a new unit of 
measurement.

Note: To make the image’s dimensions smaller without losing any 
detail, deselect “Resample image” before changing the width or height.

5. Click OK when you !nish.

Note: The “Fit Into” pop-up menu includes the same presets as does 
the New Image dialog. If you edit the New Image presets, the changes 
will also be visible in a Fit Into pop-up menu.



Chapter 21: Canvas Size and Rotation

Use the Canvas Size sheet or a Crop tool to adjust the size of your work area.

This chapter provides information about the Crop Tool, Canvas Size and Rotation.

This chapter covers:

• Crop

• Canvas Size

• Canvas Rotation



Crop

Use Pixelmator’s Crop Tool to remove portions of an image to 
create focus.

Crop Tool
To crop an image using the Crop Tool:

1. Select the Crop Tool (C) in the Tools palette.

2. If desired, in the Crop Tool’s Tool Options palette choose the 
constrain crop proportions preset from the Constrain pop-up 
menu. Choose custom if you would like Crop Tool to use your 
own width and height dimensions.

3. Drag over the part of an image you want to keep to create a crop 
marquee.

4. Adjust the cropping marquee if necessary:

• Drag the whole marquee to another position by placing the cursor 
inside the bounding box and dragging.

• Scale crop marquee by dragging its handles. Press shift to 
constrain proportions as you drag.

• Rotate the crop marquee by positioning the mouse cursor outside 
the bounding box and dragging. If necessary, you can also adjust 
the center point by dragging the circle at the center of the 
bounding box.

Tip: Hold down the Option key to draw or resize a crop from the 
center. 

Tip: Hold down the Shift key to draw or resize with crop constrained. 

• Once you draw the crop marquee, Crop Tool’s Tool Options palette 
changes, and it now allows you to specify whether you want to 
hide or delete the cropped area. Select Hide to leave the cropped 
area in the image behind the canvas or Delete to completely 
remove the cropped area.

5. To complete the crop, do one of the following:

• Press Return on your keyboard

• Click the Crop button in the Tool Options palette

• Double-click the crop bounding box

• Control-click or right mouse button click on a crop bounding box 
and choose Crop from the contextual menu that appears.

To cancel the crop, do one of the following:

• Click the Cancel button in the Tool Options palette

Tip: Hold down the Shift key to rotate crop every 15˚. 



• Press the Escape key on your keyboard

• Control-click or right mouse button click on a crop bounding box 
and choose Cancel from the contextual menu that appears.

Crop an Image Using a Selection Tool
To crop an image using any of the selection tools:

1. Use a selection tool to select the part of an image you want to 
keep.

2. Control-click or right mouse button click and choose Crop from 
the selection tool contextual menu that appears.

3. The selection now changes to a crop bounding box. Adjust the 
bounding box if necessary:

• Drag the whole marquee to another position by placing the cursor 
inside the bounding box and dragging.

Tip: Double-click on a layer to quickly make a crop marquee with 
dimensions of that layer.

• Scale the crop marquee by dragging its handles. Press Shift to 
constrain proportions as you drag.

• Rotate the crop marquee by positioning the mouse cursor outside 
the bounding box and dragging. If necessary, you can also adjust 
the center point by dragging the circle at the center of the 
bounding box.

• Once you draw the crop marquee, Crop Tool’s Tool Options palette 
changes, and it now allows you to specify whether you want to 
hide or delete the cropped area. Select Hide to leave the cropped 
area in the image behind the canvas or Delete to completely 
remove the cropped area.

5. To complete the crop, do one of the following:

• Press Return on your keyboard

• Click the Crop button in the Tool Options palette

• Double-click the crop bounding box

• Control-click or right mouse button click on a crop bounding box 
and choose Crop from the contextual menu that appears.

To cancel the crop, do one of the following:

• Click the Cancel button in the Tool Options palette

• Press the Escape key on your keyboard

• Control-click or right mouse button click on a crop bounding box 
and choose Cancel from the appeared contextual menu



Trim

The Trim command allows cropping an image by trimming 
surrounding transparent pixels, or background pixels of the color 
you specify.

Crop an Image Using  the Trim Command
1. Choose Image > Trim.

2. In the Trim sheet select a trim option:

• Transparent Pixels - trims away transparency at the edges of the 
image.

• Top Left Pixel Color - removes an area the color of the upper left 
pixel from the image.

• Bottom Right Pixel Color - removes an area the color of the lower 
right pixel from the image.

3. Select one or more areas of the image to trim away.

4. When you !nish, click OK.

5. The selection now changes to a crop bounding box. Adjust the 
bounding box if necessary:

Reveal All: An opposite to the Trim command is the Reveal All 
command which will expand the canvas area of an image  to show all 
the portions of that image if hiding under the canvas area.



Canvas Size

The Canvas Size command allows you to adjust the entire editable 
area of an image. Increasing the editable area adds more editable 
space, while decreasing the area crops the image.

Change Canvas Size
To increase or decrease the canvas size:

1. Choose Image > Canvas Size, or use the Option + Command + C 
keyboard shortcut.

2. In the Canvas Size sheet that appears, enter the dimensions for 
the new canvas in the width and height !elds. You can also 
choose units from the units pop-up menus next to the width and 
height !elds. 

3. Select the Relative checkbox if you want to add or subtract a 
certain number of units from the current canvas size.

4. If necessary, click a square in the Anchor box to position the 
existing image on the new canvas.

5. When you !nish, click OK.

Reveal All
To reveal all the image if there is some portion of it hiding under 
the canvas area, use the Reveal All command.

To reveal the entire image choose Image > Reveal All.



Canvas Rotation

You can use the Rotate Canvas command to rotate or $ip the whole 
editable area. 

Rotate Canvas
To rotate the canvas:

Choose Image > Rotate Canvas >  and choose one of the 
commands: 180˚, 90˚ Right, 90˚ Left, Flip Horizontal or Flip 
Vertical.

180˚ rotates the image by a half turn; 90˚ Right rotates the image 
clockwise by a quarter turn; 90˚ Left rotates the image 
counterclockwise by a quarter turn.

Flip Horizontal $ips an image horizontally, while Flip Vertical $ips 
the image vertically.

Original

180˚

90˚ Right

90˚ Left

Flip Horizontal

Flip Vertical
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Part VIII: Saving, Exporting, and Printing

Pixelmator supports over 100 di"erent !le formats. You can open 
and save in PSD, TIFF, JPEG, PNG, PDF, EPS and scores of other 
image formats. Above all, Pixelmator can open and save 
Photoshop !les with layers.

Chapter 22 Saving and Exporting Images

Chapter 23 File Formats

Chapter 24 Printing Images



Chapter 22: Saving and Exporting Images

You can use Pixelmator to easily prepare images for the web, quickly send them to Mail and iPhoto, or simply store on 
your hard disk. Pixelmator supports over 100 di"erent !le formats. You can open and save in PSD, TIFF, JPEG, PNG, PDF, 
EPS and scores of other image formats.

This chapter provides information about preparing images for the web, saving, exporting as well as providing an overview of !le formats.

This chapter covers:

• Saving Images

• Preparing Images for the Web

• Exporting Images

• File Formats



Saving Images

It’s a good idea to save your document often as you work with any 
application.

After you save your image for the !rst time, you can press 
Command-S to resave as you edit your image.

Pixelmator supports a wide variety of !le formats. The most popular 
ones are included in the Save As... dialogue box, while others are 
available in the Export sheet.

Save
To save an image for the !rst time:

1. Choose File > Save.

2. In the Save As !eld, type a name for the image.

3. If you want your document to be opened using Pixelmator, 
choose Pixelmator from the Format pop-up menu. If you want 
the document to be opened using another application, choose 
that !le format from the Format pop-up menu.

4. Click Save.

Use the Save command or the Command + S keyboard shortcut to 
save changes as you edit your image.

Save As...
Use the Save As... command to save your image in a di"erent 
location, format, or name or to save the image as a copy:

1. Choose File > Save As....

2. In the Save As !eld, type a name for the image.

3. By default it will save in the native Pixelmator !le format. 
However, if you wish to save in another !le format, check the 

Save copy as checkbox; and in the pop-up menu, select the 
format in which you want to save your image. 

4. Click Save.

The document with the new name remains open. To work with the 
previous version, choose File > Open Recent > and choose the 
previous version from the submenu.

Save as PSD Document
You can save a Pixelmator image so that users with Adobe 
Photoshop can open and use it.

To save an image for use with Adobe Photoshop:

1. Choose File > Save As.

2. Type a new name for the image in the Save As !eld.

3. Check the Save copy as checkbox and choose Photoshop from 
the pop-up menu.



4. Choose where you want to save the document.

5. Click Save.

Save as JPEG Document
To save the image as a JPEG document:

1. Choose File > Save As....

2. In the Save As !eld, type a name for the image.

3. Choose where you want to save the document.

4. Check the Save copy as checkbox and choose JPEG from the 
pop-up menu.

5. Drag the quality slider to specify image quality.

6. Click Save.

Save as TIFF Document
To save an image as a TIFF document:

1. Choose File > Save As....

2. In the Save As !eld, type a name for the image.

3. Choose where you want to save the document.

4. Check the Save copy as checkbox and choose TIFF from the pop-
up menu.

JPEG: Short for Joint Photographic Experts Group, JPEG is a popular 
image !le format that lets you create highly compressed graphics !les. 
The amount of compression used can vary. Less compression results in 
a higher-quality image. JPEG !les usually have the “.jpg” extension.

5. Click Save.

Save as PNG Document
To save the image as PNG document:

1. Choose File > Save As....

2. In the Save As !eld, type a name for the image.

3. Choose where you want to save the document.

4. Check the Save copy as checkbox and choose PNG from the pop-
up menu.

5. Click Save.

TIFF: Short for Tagged Image File Format, TIFF is a widely used 
bitmapped graphics !le format that Pixelmator can open. However, 
some TIFF documents may contain layers. TIFF layers are not currently 
supported by Pixelmator, but the application is able to open such TIFF 
image in a merged layers mode.

Other formats: To save the image as BMP, JPEG-2000, PDF, PICT, SGI, 
TGA, or as any other !le format, see Exporting Images later in this 
chapter.



Preparing Images for the Web

Use Pixelmator to prepare and save your images for the web easily, 
whether it is an individual image or web page layout. 

Preparing images for the web usually includes these steps: slicing 
images if needed, optimizing images, and saving images.

Slicing images is optional since slices divide an image into smaller 
images, which can then each be optimized using di"erent 
optimization settings. Slicing is useful for web page layouts with 
di"erent elements such as buttons, logos, layouts with di"erent 
backgrounds, and other objects.

To be more speci!c, if you are working with a single web graphic, 
you don’t need to divide it. 

Optimizing an image for the web means compromising between 
image display quality and the !le size. 

You can use the optimize features in Pixelmator to preview 
optimized images in di"erent !le formats and di"erent format 
settings and to compare them with the original images.

In Pixelmator there are four standard !le formats in which your 
image can be optimized and then saved to use on the web:

JPEG - the standard high quality format usually used for optimizing 
photographs. For a JPEG image you can specify the level of quality, 
which determines the level of compression and matte color. Matte 
color speci!es a !ll color for pixels that were transparent in the 
original image.

PNG - a format used for high quality images that have transparency. 
Transparency can be enabled and disabled just as matte color can 
be set.

GIF - standard low quality format used to compress images with 
crisp detail such as illustrations, logos, etc. GIF supports up to 256 
colors only, and you can specify the number of colors that should 
be used. Fewer colors means smaller !le size. You can also make 
fully transparent pixels transparent by enabling transparency and 
setting a matte color.

PNG Indexed - almost the same as GIF; the only di"erence is that it 
e#ciently compresses solid areas of color while preserving sharp 
detail.



Save Image for the Web
To save an image for the web without slicing it:

1. Choose File > Export for Web....

2. An Export for Web palette appears. Optimize the image by 
choosing JPEG, PNG, PNG Indexed, or GIF from the format pop-
up menu and specifying format options such as quality and 
matte color for JPEG, transparency color for PNG, and quantity of 
colors and matte color for PNG Indexed and GIF. 

3. Click Next.... 

4. The Save As... sheet appears. In the Save As !eld, type a name for 
the image.

5. Choose where you want to save the optimized image.

6. Click Save.

Save Sliced Image for the Web
To save a sliced image for the web:

1. Use the Slice Tool to create slices. For more information about 
using the Slice tool, see later in this chapter.

2. Optimize each slice by choosing JPEG, PNG, PNG Indexed or GIF 
from the format pop-up menu and specifying format options 
such as quality and matte color for JPEG, transparency color for 
PNG, or quantity of colors and matte color for PNG Indexed and 
GIF in the Slice Tool Options palette. 

3. Click the Export for Web... button in the Slice Tool Options 
palette or choose File > Export for Web....

4. The Save As... sheet appears.

5. Choose where you want to save sliced and optimized images.

6. Click Save.



Slice Tool
Use Pixelmator’s Slice Tool to divide an image into smaller images 
and to optimize each part of an image with its own optimization 
settings.

Slicing is useful for web page layouts with di"erent 
elements such as buttons, logos, layouts with 
di"erent backgrounds, and other objects.

To use the Slice Tool:

1. Select the Slice Tool in the Tools palette or press K on your 
keyboard.

2. Drag over the area where you want to create a slice.

Quick Save: To quickly save the optimized slice quickly, drag the slice 
thumbnail from the Slice Tool Options palette onto your desktop.

Select Slice
To select a created slice, select the Slice Tool in the Tools palette and 
click the slice in the image.

To select more than one slice select the Slice Tool and Shift + click 
to add slices to the selection.

Move Slice
To move a created slice border, position the pointer of the selected 
Slice Tool inside the slice border, and drag to move the border.

Tip: To slice a square using the Slice Tool, hold down Shift as you drag.

To draw a slice from its center, hold down the Option key after you 
begin dragging.

Tip: Use snap to align a new slice to a guide or to another slice in the 
image.
To enable snapping, use Control + Click or click the right mouse button 
on a ruler in the Pixelmator window for a contextual menu to appear; 
choose Snap To > and choose one or more of the following options 
from the submenu:
Guides: snaps to guides; Grid: snaps to the gridlines and gridline 
subdivisions; Layers: snap to layers edges; Slices: snaps to slice 
boundaries; and Document Bounds: snaps to the edges of the image.

Tip: Press the Shift key while moving to restrict movement to a vertical, 
horizontal, or 45˚ diagonal line.

Tip: Snapping, if enabled, works not only when creating slices, but also 
when moving slices.



Resize Slice
To resize a slice, grab a corner handle of the slice and drag.

Change the Stacking Order of Slices
Sometimes slices may overlap. In order reach the underlying slices 
you can change their stacking order. To change the stacking order 
of slices:

1. Select one or more slices.

2. With the Slice Tool selected Control + click or click the right 
mouse button over the selected slices.

3. Choose Bring to Front, Bring Forward, Send Backward or Send 
to Back from the Slice Tool contextual menu.

Tip: Press the Shift key while resizing a slice to make a square slice.

Overlapping: When slices overlap, the last slice your created is the top 
slice in the stacking order.

Convert Remaining Areas to Slices
When you create a new slice, additional inactive auto slices are 
generated to account for the remaining areas of the image. You can 
easily convert the remaining area of the image to a slice. To convert 
an inactive slice to an active:

1. With the Slice Tool selected Control + click the right mouse 
button over the inactive slice you would like to convert.

2. Choose Promote to Slice from the Slice Tool contextual menu 
that appears.

Delete Slice
To delete a slice:

1. Select one or more slices.

2. With the Slice Tool selected, do one of the following:

• Press the backspace key on your keyboard.

• Control + click or click the right mouse button over the selected 
slices and choose Remove Slice from the Slice Tool contextual 
menu.



When you delete a slice inactive auto slices are generated 
automatically to !ll the document area.

Delete All Slices
To delete all slices:

1. With the Slice Tool selected, Control + click or click the right 
mouse button over the window.

2. Choose Clear Slices from the Slice Tool contextual menu.

Rename Slice
By default, slices are named Slice 1, Slice 2, Slice 3 etc. It might be 
useful for you to rename your slices. To rename a slice:

1. Select the slice you want to rename.

2. In the Slice Tool Options palette, click on a slice name and type a 
new name.

3. Press Enter on your keyboard to con!rm the new name.

Show or Hide Slices
Sometimes when comparing an optimized image with the original 
image, you may want to hide the slice boundaries.

To show or hide slice boundaries:

1. Select the Slice Tool in the Tools palette.

2. On the Show Slices checkbox in the Slice Tool Options palette, 
check to show the slices or uncheck to hide them.

Change the Color of Slices
The default color of slices (yellow) can be changed if needed.

To change slices’ color:

1. Choose Pixelmator > Preferences....

2. Select the Rulers tab.

3. Click the Slices Color box and use the Color palette to choose a 
new color for slices. 



Exporting Images

Pixelmator can open and save many more !le formats than those 
available in the Save As dialog. Use the Export command to export 
images to one of the 100 !le formats supported by Pixelmator.

Export Image to Other Formats
To export an image to another !le format:

1. Choose File > Export....

2. Choose a format for the image and select any options if available 
and needed, and click Next.

3. Type a new name for the image.

4. Choose where you want to save the image.

5. Click Export.

Send Image to Mail
If you use Mail as your regular email application, you can quickly 
and simply attach your composition to an email, right from within 
Pixelmator.

To email an image:

1. Choose File > Send To > Mail....

2.  Set the size for an image: small, medium, large or actual size. A 
small image will email faster, while larger images will email 
slower.

File Size: Note that Export sheet shows a would be !le size for a JPEG, 
PNG, TIFF, PSD and PDF formats.

Note: The most popular !le formats are available in the Save As dialog. 
Use the Export command if you need a more speci!c !le format that is 
not available in Save As dialog’s Format pop-up list.



3. Click Compose Message.

4. A new mail message opens with the image attached to it. Edit the 
email message and click Send.

Send Image to iPhoto
In addition to sending your composition to Mail, you can send your 
composition to your iPhoto Library.

To send an image to your iPhoto Library:

1. Choose File > Send To > iPhoto....

2.  Set a format for an image: JPEG (variable quality), PNG (high 
quality), or TIFF (highest quality).

3. Click Send.

4. The image will be added your iPhoto library’s Last Import album. 
You can now edit and manage it using iPhoto.

Send Image to Flickr
You can upload a currently open image to Flickr. Please note that 
for this you need to have a Flickr account.

To send image to Flickr:

1. Choose File > Send To > Flickr....

2. If this is your !rst time using this feature, click Set Up and follow 
the instructions.

3. Select an existing set for your image, or create a new one using 
the drop-down menu.

4. If you are creating a new set, enter the title and description.

5. Select privacy setting for your image.

6. Select image size. 

7. Click Send.



Send Image to Facebook
You can upload a currently open image to Facebook. 

To send image to Facebook:

1. Choose File > Send To > Facebook....

2. If this is your !rst time using this feature, click Set Up and enter 
your login credentials or click Sign up for Facebook if you don't 
have an account yet..

3. Select an existing album for your image or create a new one 
using the drop-down menu.

Tip: Web option limits the dimensions of your image to 1024 pixels, 
Optimized to 3048 pixels. Actual Size means that your image will not 
be resized. The last option is available only for Pro account holders.

4. If you are creating a new album, de!ne its title and description, 
and select privacy level.

5. Click Send.

Send Image to Picasa
You can upload a currently open image to Picasa. 

To send image to Picasa:

1. Choose File > Send To > Picasa....

2. If this is your !rst time using this feature, enter the email address 
and password associated with your Picasa account. Click Login.

Tip: Please note that Facebook reduces the dimensions of all uploaded 
images to 720 pixels.



3. Select an existing album, or create a new one using the drop-
down menu.

4. If you are creating a new album, set its title and description.

5. Choose public or private album type.

6. Select image quality level. 

7. Click Send.

Tip: Better quality limits the dimensions of your image to 1600 pixels, 
while Faster upload sets the limit to 1000 pixels. Actual quality keeps 
dimensions of the image unchanged.



File Formats

Pixelmator supports over 100 di"erent !le formats. Most popular !le formats are available in Save As dialog’s format menu while others are 
available under the Format menu in the Export sheet. File Formats Overview:

Extension Description Notes

PXM The default Pixelmator !le format It is the best way to save and store your 
compositions for further editing since it o"ers 
full  support for Pixelmator features.

PSD The default format for Adobe Photoshop Pixelmator can open and save PSD 
documents.

Features of PSD !le format that Pixelmator 
supports when opening are bitmap layer 
information, blending settings and guides. 

TIFF Short for Tagged Image File Format, TIFF is a widely used bitmapped 
graphics !le format.

Some TIFF documents may contain layers. 
TIFF layers are not currently supported by 
Pixelmator, but the application is able to open 
such TIFF image in a merged layers mode.

JPEG Short for Joint Photographic Experts Group, JPEG is a popular image 
!le format that lets you create highly compressed graphics !les. The 
amount of compression used can vary. Less compression results in 
the higher-quality image. JPEG !les usually have the “.jpg” 
extension.

Pixelmator o"ers full support for saving and 
opening JPEG images.

JPEG 2000 Short for Joint Photographic Experts Group 2000, JPEG 2000 is a 
wavelet-based image compression format. It is not as popular as 
JPEG.

Pixelmator can open and save JPEG 2000 
images.

PNG Short for Portable Network Graphics, PNG is a bitmapped graphics 
!le format that has been approved by the World Wide Web 
Consortium to replace patented GIF !les.

Pixelmator o"ers full support for saving and 
opening PNG images.



Extension Description Notes

PDF Short for Portable Document Format a PDF !le can contain a single 
image or multiple pages and images. 

You can open and save PDF documents in 
Pixelmator.

GIF Short for Graphics Interchange Format, GIF is the !le format mainly 
used to display indexed-color images in websites. 

Pixelmator o"ers full support for opening GIF 
images though the application can not play 
GIF animations.

BMP Microsoft Windows bitmap

SGI Iris RGB picture

TGA Truevision Targa Image

AVS AVS X image

Kodak Cineon Kodak Cineon Image Format

DCX ZSoft IBM PC multi-page Paintbrush image 

DIB Microsoft Windows Device Independent Bitmap

DPX SMPTE Digital Moving Picture Exchange 2.0 (SMPTE 268M-2003)

EPDF Encapsulated Portable Document Format

EPI Adobe Encapsulated PostScript Interchange format

EPS Adobe Encapsulated PostScript

EPS2 Adobe Level II Encapsulated PostScript

EPSF Adobe Encapsulated PostScript

EPSI Adobe Encapsulated PostScript Interchange format



Extension Description Notes

EPT Adobe Encapsulated PostScript Interchange format with TIFF 
preview

FAX Group 3 TIFF

FITS Flexible Image Transport System

GRAY Raw gray samples

JNG Multiple-image Network Graphics 

Magick Magick image !le format

MONO Bi-level bitmap in least-signi!cant-byte !rst order

MNG Multiple-image Network Graphics 

MPC Magick Persistent Cache image !le format

MTV Raytracing MTV Raytracing image format

OTB On-the-air Bitmap

PALM Palm pixmap

PAM Common 2-dimensional bitmap format

PBM Portable bitmap format (black and white)

Photo CD Photo CD

PCL HP Page Control Language

PCX ZSoft IBM PC Paintbrush !le



Extension Description Notes

PDB Palm Database ImageViewer Format

PGM Portable graymap format (gray scale)

PICON Personal Icon

PNM Portable anymap

PPM Portable pixmap format (color)

PS Adobe PostScript !le

PS2 Adobe Level II PostScript !le

PTIF Pyramid encoded TIFF

SUN SUN Raster!le

UIL X-Motif UIL table 

UYVY Interleaved YUV raw image

VICAR VICAR raster!le format

VIFF Khoros Visualization Image File Format

Wireless BMP Wireless bitmap

XBM X Windows system bitmap, black and white only

XPM X Windows system pixmap

YUV CCIR 601 4:1:1



Note About Other File Formats Compatibility
Pixelmator is built on open source technology called ImageMagick. 
It is a sophisticated foundation to provide you with the support of 
more than 100 di"erent !le formats. 

ImageMagick is used as a base to support all the !le formats in the 
list above. It can read, convert and write images in a variety of 
formats. 

However, not all !le formats use the ImageMagick foundation. 
Support for the most popular !le formats such as PSD, JPEG, 
JPEG-2000, TIFF, GIF, PNG, PDF, PXM and some others is provided by 
Apple frameworks or created by the Pixelmator Team developers.

For more information about the ImageMagick, please visit the 
website at www.imagemagick.org.

http://www.imagemagick.org/script/formats.php
http://www.imagemagick.org/script/formats.php
http://www.imagemagick.org
http://www.imagemagick.org


Chapter 23: Printing

Printing using Pixelmator is the same as printing using almost any Mac application.

This chapter provides information about printing from Pixelmator.

This chapter covers:

• Printing Images



Printing Images

Pixelmator and Mac OS X provide you with tools to print your 
image in various layouts. You can set the paper size and orientation, 
preview the image before printing and !nally print it.

Set the Paper Size and Orientation
Before you print, you should make sure the paper size and 
orientation are set the way you want by opening the Page Setup 
dialog. 

To set paper size and orientation:

1. Choose File > Page Setup.

2. In the Page Setup dialog, choose the printer you will use from the 
“Format for” pop-up menu. 

3. Choose a standard paper size from the Paper Size pop-up menu. 
You can also set a custom paper size. See Mac OS X help for more 
information about that.

4. Select an orientation option using one of the buttons at the 
bottom of the Page Setup dialog.

Preview Image Before Printing It
To make sure everything is laid out the way you expect, it’s a good 
idea to preview a document onscreen before you print it.

To preview a document for printing:

1. Choose File > Print.

2. Click the Preview button in the Print dialog. Preview shows what 
images will look like when printed.

3. Click Print to print your document directly from the Preview 
window.

For information about using Preview, see Preview Help. Choose 
Help > Preview Help when the Preview application is launched.
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Part IX: Automating Tasks

Using powerful Pixelmator actions in Automator, you can quickly 
enhance, resize, or transform your images, add any special e"ects 
or even export your images to over 100 di"erent !le formats. You 
can do that to as many images at one time as you wish.

Chapter 24 Automator Support



Chapter 24: Automator Support

Pixelmator includes Automator actions for converting, resizing, enhancing and adding special e"ects.

This chapter provides an introduction to Automator actions.

This chapter covers:

• About Automator

• Automator Actions Overview



About Automator

Automator is a Mac OS X application that creates work$ows for 
automating repetitive tasks. 

Individual steps called actions can be assembled into a complete 
task by dragging actions into an Automator work$ow. You can run 
your completed work$ows repeatedly and even share them with 
others.

Actions are the building blocks for creating work$ows. Pixelmator 
includes Automator actions for converting, resizing, enhancing and 
adding special e"ects.

For more information about how to use the Automator application, 
see the Automator Help. 



Automator Actions Overview

Using powerful Pixelmator actions in Automator, you can quickly 
enhance, resize, watermark, or transform your images, add any 
special e"ects or even export your images to over 100 di"erent !le 
formats. You can do that to as many images at one time as you 
wish.

Enhance Action
Enhance action o"ers over 16 color correction tools. Enhance 
action enhances selected images using color correction tools 
similar to those available in Pixelmator: 

• Levels

• Auto Enhance 

• Curves

• Color Balance

• Brightness and Contrast

• Hue and Saturation

• Desaturate

• Colorize

• Replace Color

• Channel Mixer

• Exposure

• Invert

• Equalize

• Threshold 

• Posterize

Add E!ects to Images Action
Special E"ects action allows you to add over 130 Core Image-
powered !lters to selected images. Add E"ects to Images action 
includes:

• Distortion !lters that include Bump, Bump Linear, Circle Splash, 
Circular Wrap, Displacement, Glass, Glass Lozenge, Hole, Pinch, 
Torus Lens, Twirl and Vortex.

• Blur !lters that include Box, Gaussian, Motion, Noise Reduction, 
Zoom, Median.

• Sharpen !lters that include Sharpen Luminance, Unsharp Mask.

• Stylize !lters that include Bloom, Crystalize, Edge Work, Edges, 
Gloom, Height Field From Mask, Hexagonal Pixellate, Line 
Overlay, Pixellate, Pointillize, Shaded Material, Spot Color, Spot 
Light, Comic E"ect.



• Halftone !lters that include Circular Screen, CMYK Halftone, Dot 
Screen, Hatched Screen and Line Screen.

• Tile !lters that include A#ne Clamp, A#ne, Eightfold Re$ected, 
Fourfold Re$ected, Fourfold Rotated, Fourfold Translated, Glide 
Re$ected, Kaleidoscope, Op, Parallelogram, Perspective, Sixfold 
Re$ected, Sixfold Rotated, Triangle and Twelvefold Re$ected.

• Color !lters that include Color Map, Color Monochrome, Gamma 
Adjust, Sepia Tone, False Color and Mask to Alpha.

• Generator !lters that include Checkerboard, Lenticular Halo, Star 
Shine, Stripes, Sunbeams, Constant Color and Random Generator.

• Transition !lters that include Bars Swipe, Copy Machine, Flash, 
Mod, Page Curl, Ripple and Swipe.

Fit Images Action
Fit Images action resizes images to the constrained size.

Scale proportionally option must be checked if there is a need to 
keep the dimension ratio of an image unchanged.

Crop Images Action
Crop Images action crops supported images to the speci!ed 
dimensions. 

Use Relative mode to add or subtract from the image’s current 
canvas size and set the Anchor to indicate where to position the 
existing image on the new canvas.

Trim Images Action
Trim Images action allows to crop images using transparent, top-
left, or bottom-right pixels as a reference.

This action is similar to Crop Images. Transparent or solid color 
areas that surround the image are cut o" automatically.

Watermark Images Action
Watermark Images action allows you to place visible watermarks on 
your images.

Watermarks are semi-transparent markings often placed on an 
image to identify its owner. You can choose the position of the 
watermark in your image.

Change Type of Images Action
Change type of images action allows conversion of over 100 still 
image !le formats supported by Pixelmator. For more information 
about what !le formats are supported, please see Chapter 22.

See Automator Help for more information about how to use the 
application and its actions.
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Appendix A: Keyboard Shortcuts

You can use the keyboard to perform many of the Pixelmator 
menu commands and tasks. 



A List of Keyboard Shortcuts

You can use your keyboard, mouse, and trackpad to quickly accomplish many tasks in PIxelmator. To !nd the shortcuts for common 
commands, look in the menus (or see the menu shortcuts below). To complete an action, press the shortcut keys indicated below.

Action Shortcut

Selecting tools

Rectangular Marquee M

Move V

Elliptical Marquee Y

Lasso

Polygonal Lasso

L

Crop C

Slice K

Magic Wand W

Clone Stamp S

Pencil P

Eraser

Magic Eraser

E

Brush B

Gradient G

Paint Bucket N

Blur R

Sharpen O



Eyedropper I

Type T

Hand H

Zoom Z

Temporary selecting tools

Move Space bar

Duplicate Move 

Hand Space bar

Eyedropper Option

Zoom In Space bar-Command

Zoom Out Space bar-Option

Viewing Images

Zoom In Command–plus sign (+)

Zoom Out Command–minus sign (-)

Zoom In/Out Option-Mouse scroll

Horizontal scrolling Shift-Mouse scroll

Fit image in window Command-0 or double-click Zoom tool

Magnify 100% Option-Command-0 or double-click Zoom tool

Show/Hide Rulers Command–R

Show/Hide Guides Option-Command-;

Show/Hide Grid Option-Command-'



Snap guide to the ruler mark Shift-drag guide

Toggle between Standard screen mode and Full screen mode F

Toggle between Standard screen mode and Quick Mask mode Q

Editing images

Undo last action Command–Z

Redo last action Option-Command-Z

Fill with color Option-Command-F

Fill with Foreground color

Hold down Shift to preserve transparency.

Option-Backspace

Fill with Background color

Hold down Shift to preserve transparency.

Command-Backspace

Stroke Shift-Command-O

Invert colors I

Levels Command–L

Curves Command–K

Color Balance Command–B

Hue/Saturation Command–U

Desaturate Option-Command-U

Canvas Size Option-Command-C

Image Size Option-Command-I

Color Management Shift-Command-K



Last Filter Shift-Command-F

Working with selections

Constrain to a circle or square Shift-drag selection

Add to a selection Shift

Subtract from a selection Option

Select All Command–A

Deselect Command–D

Reselect Shift-Command-D

Load layer transparency as a selection Option-Command-L

Inverse selection Shift-Command-I

Re!ne selection Option-Command-R

Copy Command–C

Copy in a new layer Command–J

Cut Command–X

Cut in a new layer Shift-Command-J

Paste Command–V

Working with type layers

Move one character to the left Left Arrow

Move one character to the right Right Arrow

Move to the line above Up Arrow

Move to the line below Down Arrow



Copy Command–C

Cut Command–X

Paste Command–V

Show/Hide Spelling Shift-Command-;

Check Spelling Command-;

Select all text Command–A or double click type layer thumbnail

Save changes Command-Return or Escape

Move objects using arrows

Move layer or selection content with border layer by 1 pixel Command-Arrows

Move layer or selection content with border by 10 pixels Shift-Command-Arrows

Move selection border by 1 pixel Arrows

Move selection border by 10 pixels Shift-Arrows

Painting

Switch foreground and background colors X

Reset foreground and background colors D

Open brush editor sheet Double click on painting tool

Paint straight lines Shift-click

Paint vertical or horizontal lines Shift-drag

Navigate through brushes (,) comma sign or (.) dot sign

Change brush size [ or ]

Change brush hardness Shift-[ or Shift-]



Navigate through gradients (,) comma sign or (.) dot sign

Cycle gradient modes [ or ]

Constrain gradient to 45° angles Shift-drag gradient

Delete brush in Brushes palette Option-click brush

Sample Background color Option-click

Layers

Transform Command–F

Commit Transform Double-click or Enter

Preserve layer transparency /

Cycle blending modes Command–plus sign (+) or minus sign (-)

Select all layers Option-Command-A

Hide other layers Option-click layer visibility checkbox

Place new layer in the canvas center Shift-drag image from Finder

Create or release clipping mask Option-Command-G or Option-click between 
layers

Merge selected layers Command–E

Merge layers and paste in a new layer Option-Command-E

Merge visible layers Shift-Command-E

Merge visible layers and paste in a new layer Shift-Option-Command-E

Rename layer Double-click the layer name

Create new layer Shift-Command-N

Create new layer (no dialog) Shift-Option-Command-N



Duplicate layer Option-drag layer

Select top layer Option-(.) dot sign

Select next layer Option-[

Select previous layer Option-[

Select bottom layer Option-(,) comma sign

Send to front Option-Command-]

Bring forward Command–]

Send backward Command–[

Send to back Option-Command-[

Palettes

Show or hide all palettes Tab

Reset palettes locations Shift-Command-R

Tools Command–1

Tool Options Command–2

Layers Command–3

Gradients Command–4

Brushes Command–5

Swatches Command–6

Scratch Command–7

Photo Browser Command–8

Colors Shift-Command-C



Fonts Command–T

Share

Print Command–P

Page setup Shift-Command-P

Export for Web Shift-Command-E

General

Show preferences Command-(,) comma sign

Pixelmator Help Command–?

Close window Command–W

Close all windows Option-Command-W

Cycle through windows Command–(`)

Minimize window Command–M

Minimize all windows Option-Command-M

Hide Pixelmator Command–H

Hide Others Option-Command–H

Quit Pixelmator Command–Q



Thank you very much for using Pixelmator!


